Cacti (home)ForumsRepositoryDocumentation
Cacti: offical forums and support
It is currently Sun Oct 26, 2014 3:26 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 33 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: Cisco ASA templates - YMMV
PostPosted: Fri Nov 25, 2005 10:52 pm 
Offline

Joined: Fri Nov 25, 2005 10:46 pm
Posts: 2
These were created for the Cisco ASA 5520


Attachments:
cacti_graph_template_cisco_asa_sessions.xml [12.86 KiB]
Downloaded 11844 times
cacti_graph_template_cisco_asa_memory_usage.xml [14.8 KiB]
Downloaded 8037 times
cacti_graph_template_cisco_asa_cpu_usage.xml [10.83 KiB]
Downloaded 9205 times
Top
 Profile  
 
 Post subject: No session info...
PostPosted: Mon Aug 14, 2006 11:26 pm 
Offline
Cacti User

Joined: Wed Sep 07, 2005 9:00 am
Posts: 88
I don't see any session info with this template... Any fixes / updates to the template?


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 12, 2006 12:45 pm 
Offline
Cacti User

Joined: Wed Sep 28, 2005 1:39 pm
Posts: 495
My sessions graph isn't working either.. any news?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 06, 2006 7:41 pm 
Offline
Cacti User
User avatar

Joined: Mon Dec 13, 2004 2:55 pm
Posts: 145
Location: San Jose, CA
Here are a few of mine.


Attachments:
File comment: XML Templates
cisco-asa-cacti-templates.zip [109.88 KiB]
Downloaded 6662 times
File comment: RAS Sessions
RAS-sessions.png
RAS-sessions.png [ 23.62 KiB | Viewed 88775 times ]
File comment: Active VPN Tunnels
active-VPN-tunnels.png
active-VPN-tunnels.png [ 24.87 KiB | Viewed 88775 times ]
File comment: IKE Traffic
IKE-traffic.png
IKE-traffic.png [ 44.47 KiB | Viewed 88775 times ]
File comment: IKE Dropped Packets
IKE-dropped-packets.png
IKE-dropped-packets.png [ 28.69 KiB | Viewed 88775 times ]
Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 07, 2006 9:42 am 
Offline
Cacti User
User avatar

Joined: Wed Aug 03, 2005 4:14 am
Posts: 61
Location: Cologne Germany
You're templates had some minor errors regarding OID's and Data Sources. Took me a while to find that out. Anyhow i fixed them a bit and combined the whole thing into a Host Template.

If you had problems getting it to work before give this Host Template a try.


Attachments:
cacti_host_template_cisco_asa_security_appliance.zip [15.16 KiB]
Downloaded 14138 times

_________________
fear leads to anger, anger leads to hate and dancing leads to sex!
Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 07, 2006 11:37 am 
Offline
Cacti User
User avatar

Joined: Mon Dec 13, 2004 2:55 pm
Posts: 145
Location: San Jose, CA
ScOp3 wrote:
You're templates had some minor errors regarding OID's and Data Sources. Took me a while to find that out. Anyhow i fixed them a bit and combined the whole thing into a Host Template.

If you had problems getting it to work before give this Host Template a try.


Thanks ScOp3,

Yea, I forgot to mention that you need the Cisco MIBs installed for my versions to work.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 07, 2006 11:59 am 
Offline
Cacti User
User avatar

Joined: Wed Aug 03, 2005 4:14 am
Posts: 61
Location: Cologne Germany
Setarcos wrote:
Thanks ScOp3,

Yea, I forgot to mention that you need the Cisco MIBs installed for my versions to work.


Yup, figured the MIB issue quite fast. That's why i changed them to numerical notation so we have less dependencies. Nice work on the templates.

_________________
fear leads to anger, anger leads to hate and dancing leads to sex!


Top
 Profile  
 
 Post subject: ? about the cisco mib's
PostPosted: Thu Jan 18, 2007 2:46 pm 
Offline

Joined: Thu Sep 22, 2005 4:53 pm
Posts: 4
Location: nyc
hi guys. i'm hoping you can help me out here. Where do i get the cisco mibs and once i have them, where to I install them. Also, i was trying to import that template but am having problems doing so. I keep getting the following errors:


Notice: Only variable references should be returned by reference in C:\Apache2\htdocs\cacti\lib\import.php on line 44

Warning: Cannot modify header information - headers already sent by (output started at C:\Apache2\htdocs\cacti\lib\import.php:44) in C:\Apache2\htdocs\cacti\templates_import.php on line 67

when i hit the back button, it tells me the following:
Error: XML: Hash version does not exist.


If anyone can help I would greatly appreciate it. I'm trying to get some graphs going on my ASA 5505. Thanksa.


Top
 Profile  
 
 Post subject: Very Nice
PostPosted: Wed Aug 08, 2007 3:02 pm 
Offline

Joined: Sun Mar 05, 2006 4:05 am
Posts: 32
Location: Connecticut
These look awesome I will have to give them a try!!


Top
 Profile  
 
 Post subject: ASA VPN Monitoring
PostPosted: Thu Sep 13, 2007 1:18 pm 
Offline

Joined: Wed Sep 12, 2007 3:31 pm
Posts: 6
Location: Colorado
A coworker set up NMIS to monitor routers and such. So while searching for information on monitoring VPN tunnels off of multiple ASA's (all remote access IPSec) I found Cacti. I have it installed on a RH Linux box.

I have added the template located in the cacti_host_template_cisco_asa_security_appliance.zip file attachment mentioned previously. But I cannot get any graphs or anything and my polling consistently come back with the following error:
09/13/2007 05:22:34 PM - POLLER: Poller[0] Maximum runtime of 292 seconds exceeded. Exiting.
09/13/2007 05:22:34 PM - SYSTEM STATS: Time:292.9897 Method:cmd.php Processes:1 Threads:N/A Hosts:2 HostsPerProcess:2 DataSources:15 RRDsProcessed:0
PHP Warning: pclose(): 45 is not a valid stream resource in /opt/netmgt/cacti/lib/rrd.php on line 48

Can someone provide some direction or where to look?

Thanks,


Top
 Profile  
 
 Post subject: VPN Monitoring
PostPosted: Thu Sep 13, 2007 1:36 pm 
Offline

Joined: Wed Sep 12, 2007 3:31 pm
Posts: 6
Location: Colorado
Okay, I changed the SNMP version from 1 to 2 and it worked.


Top
 Profile  
 
 Post subject: ASA Template
PostPosted: Fri Sep 14, 2007 3:33 pm 
Offline

Joined: Wed Sep 12, 2007 3:31 pm
Posts: 6
Location: Colorado
How did you locate the correct OID's? I'd like to add a graph for IPSec traffic. IKE traffic should primarily be login traffic, and I'd like to see tunnel traffic. I'll look on Cisco's site, but thought you folks would know the answer in your sleep.

Thx


Top
 Profile  
 
 Post subject:
PostPosted: Tue Nov 13, 2007 7:07 pm 
Offline
User avatar

Joined: Fri Jun 11, 2004 1:35 pm
Posts: 38
im having an issue displaying Total Sessions with this.

For some reason i see 65523710 connections in the graph, which is an absolutely crazy number. When i manually run snmpget on the OID provided under "Cisco ASA - Total Sessions" (.1.3.6.1.4.1.9.9.147.1.2.2.2.1.5.40.6) i get somewhere around 750 connections on average, which seems like a reasonable number.

anyone knows how to fix that?


Attachments:
graph_image.png
graph_image.png [ 6.04 KiB | Viewed 82038 times ]
Top
 Profile  
 
 Post subject:
PostPosted: Thu Nov 15, 2007 12:58 pm 
Offline

Joined: Sat Aug 12, 2006 6:47 pm
Posts: 37
Very minor, but it looks like the legends between Total Sessions and Remote Sessions are transposed.


Top
 Profile  
 
 Post subject: Cisco ASA 5510 no CPU util graph
PostPosted: Tue Dec 04, 2007 9:04 am 
Offline

Joined: Mon Dec 03, 2007 10:22 pm
Posts: 10
all the other graphs work just fine, but on the 5510s the cpu utilization isnt working, there is a graph there, and on one there is some data that comes in but its either a value of 1 or 0. any ideas? Thanks


Update: I have later discovered that after a OS upgrade on the ASA fixed the issue and the ASA was also experiencing little load on it as well.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 33 posts ]  Go to page 1, 2, 3  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group