Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon May 22, 2017 4:17 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: 0.8.7.a to 0.8.7.b correction OK
PostPosted: Sun Feb 24, 2008 11:34 pm 
Offline

Joined: Fri May 12, 2006 5:59 am
Posts: 8
Since I have upgraded from 0.8.7.a to 0.8.7.b, all works fine.
I have no more "ERROR:the RRD does not contain an RRA matching the chosen CF", and All my graphs came back.
thanks


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 26, 2008 9:00 pm 
Offline
Cacti User

Joined: Thu May 12, 2005 7:26 pm
Posts: 53
gandalf wrote:
There are currently two different answers to the same problem. Some users have their problems fixed, some don't. I hope to work at least with one user to get it solved. Please post the whole failing rrdtool graph statement and rrdtool info for the rrd file used to help me debug it
Reinhard


understood. LAST appears to work fine in a GPRINT but in an AREA or LINE no joy

here is the details

if for example we take the built in unix processes graph template and change the AREA cf type from AVERAGE to LAST then create a new graph the graph fails to render

RRDTool Command:

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="monster - Processes" \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="processes" \
--slope-mode \
--font TITLE:9: \
--font AXIS:7: \
--font LEGEND:8: \
--font UNIT:7: \
DEF:a="/var/www/cacti/rra/monster_proc_21.rrd":proc:LAST \
DEF:b="/var/www/cacti/rra/monster_proc_21.rrd":proc:AVERAGE \
AREA:a#F51D30FF:"Running Processes" \
GPRINT:a:LAST:"Current\:%8.0lf" \
GPRINT:b:AVERAGE:"Average\:%8.0lf" \
GPRINT:b:MAX:"Maximum\:%8.0lf"

RRDTool Says:

ERROR: the RRD does not contain an RRA matching the chosen CF

i cant seem to paste in the rrdtool info because your forums say there is an error in the mysql syntax when i attempt to submit the posting

"General Error

Error in posting

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE forum_id = 21' at line 3

UPDATE forums SET forum_posts = forum_posts + 1, forum_last_post_id = WHERE forum_id = 21

Line : 423
File : functions_post.php"


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 28, 2008 4:04 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
I've hit a related issue from pure theory. Currently I'm working on a detailed HowTo to explain some issues with consoldidation functions. It MAY require quite some change to cacti, but I'm not sure, yet. Deinitively, another patch is required as a workaround. But, man, I tell you, it's a quite difficult issue to understand in all it's varieties.
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 04, 2008 9:28 am 
Offline
User avatar

Joined: Mon Sep 17, 2007 4:41 am
Posts: 24
Location: Kamp-Lintfort, Germany
Hey,

I don't know if this helps.

So I've two machines, one for production and one for testing purpose.
I made some SNMP queries on the test machine, with CF LAST in the used graph templates.
After I was satisfied with the results, I decided to port the queries to the production machine.
And then I ran in the same issue as described in this thread.
No Graphs at all.
Now after reading this thread I decided to change the CF to AVERAGE. But I don't create any new graphs.
The still untouched graph suddenly began to appear with all historical data since starting the query.
So I decided to switch back to CF LAST and the graph disappeared again.
On the testing machine the graph is still working, regardless of wich CF function I use.

If I can support with any Information - please let me know.

Kind Regards
Werner

_________________
There is more happiness in giving than there is in receiving.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 04, 2008 10:27 pm 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
What version of RRDtool? What version of Cacti?

TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 24, 2008 3:11 pm 
Offline

Joined: Wed Mar 28, 2007 5:48 pm
Posts: 22
I am having this problem with 0.8.7b with the ucd/net device I/O template discussed here:

http://forums.cacti.net/about8777-0-asc-75.html

Any idea when this will be fixed?


Top
 Profile  
 
 Post subject: another of the CF errors
PostPosted: Thu Apr 10, 2008 4:39 pm 
Offline

Joined: Thu Mar 20, 2008 9:40 am
Posts: 9
Location: Texas
I received this after setting up the Windows Service graphs from thread http://forums.cacti.net/viewtopic.php?t=15625&postdays=0&postorder=asc&start=0

Here is the info:
Ubuntu 7.10
Cacti 0.8.7
Latest version of RRDTool

I have only been running cacti for about a month. Here is the debug info.

Code:
RRDTool Command:

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="Utilities Server - Windows Services" \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
DEF:a="/usr/share/cacti/rra/utilities_server_snmp_qry_307.rrd":snmp_qry:LAST \
DEF:b="/usr/share/cacti/rra/utilities_server_snmp_qry_307.rrd":snmp_qry:AVERAGE \
DEF:c="/usr/share/cacti/rra/utilities_server_snmp_qry_307.rrd":spoolsv_qry:LAST \
DEF:d="/usr/share/cacti/rra/utilities_server_snmp_qry_307.rrd":spoolsv_qry:AVERAGE \
AREA:a#4444FF:"SNMP Service" \
GPRINT:a:LAST:" %8.0lf\n" \
AREA:c#F51D30:"Spooler Service":STACK \
GPRINT:c:LAST:"%8.0lf\n" \
COMMENT:"1 = Running 0 = Not Running"

RRDTool Says:

ERROR: the RRD does not contain an RRA matching the chosen CF


I changed the CF to average and it started graphing. This is monitoring the up status of a service. I would prefer to monitor last, since I will know if the service is down during the polling.

If y'all need anymore info. I would be glad to provide it.

Thanks for all the work on cacti.

Loren

_________________
Loren Erwin


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 11, 2008 8:00 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Then please add the LAST consolidation function to your RRA definition and re-create the data source.
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 11, 2008 8:15 am 
Offline

Joined: Thu Mar 20, 2008 9:40 am
Posts: 9
Location: Texas
Thanks. That works. I appreciate the help.

Loren

_________________
Loren Erwin


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 24, 2008 5:51 am 
Offline

Joined: Thu Apr 24, 2008 5:49 am
Posts: 4
gandalf wrote:
Then please add the LAST consolidation function to your RRA definition and re-create the data source.
Reinhard


how to i do that? any hint. i have the same problem with the rittal-cmc graph template.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 24, 2008 1:48 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Select "Data Sources", then "RRAs" below. Select each RRA in turn and mark all cf's that you want to use.
If you want to use LAST for a few Data Templates only, copy those RRAs and build new one that inclue the LAST. Select the Data Template and mark the new, copied ones
Last step, recreate the Graphs
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 25, 2008 6:08 am 
Offline

Joined: Thu Apr 24, 2008 5:49 am
Posts: 4
thx. its working now. i had to select all fields from the RRA's and then recreate the data sources.


Top
 Profile  
 
 Post subject:
PostPosted: Sun May 11, 2008 7:08 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Two approaches:
Either add the consolidation function LAST to your rrd definitions (this will have NO effect on existing rrd files; you will have to re-create them)
or
change the graph template to use e.g. AVERAGE instead of LAST.
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 12, 2008 7:57 pm 
Offline
Cacti User

Joined: Sat Apr 05, 2008 12:15 am
Posts: 54
----


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 13, 2008 2:40 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
cboyd213 wrote:
----
Sorry, this means what?
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot], Exabot [Bot], Yahoo [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group