Cacti (home)ForumsRepositoryDocumentation
Cacti: offical forums and support
It is currently Wed Jul 30, 2014 2:00 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 96 posts ]  Go to page 1, 2, 3, 4, 5 ... 7  Next
Author Message
 Post subject: Graph templates for Squid
PostPosted: Tue Jun 08, 2004 5:33 am 
I have made templates for the following:-

HTTP Requests (requests per second)
HTTP Traffic (kilobytes per second)
Cache object (objects)

See them in action here.


Top
  
 
 Post subject:
PostPosted: Tue Jun 08, 2004 5:38 am 
Offline

Joined: Tue Jun 08, 2004 5:34 am
Posts: 26
Forgot to log in. Added the templates to this post.


Attachments:
File comment: Squid - Cache Objects
cacti_graph_template_squid_cache_objects.xml [9.54 KiB]
Downloaded 17438 times
File comment: Squid - HTTP Traffic
cacti_graph_template_squid_http_data.xml [15.15 KiB]
Downloaded 12251 times
File comment: Squid - HTTP Requests
cacti_graph_template_squid_http_requests.xml [9.87 KiB]
Downloaded 11714 times
Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 10, 2004 4:22 am 
Offline

Joined: Tue Jun 08, 2004 5:34 am
Posts: 26
The server is temporarily offline due to an upgrade issue. That'll teach me to do it remotely. If I wasn't off sick it would have been fixed by now. I shall take a trip in to fix it this evening.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 15, 2005 10:27 am 
Offline

Joined: Tue Nov 09, 2004 12:28 am
Posts: 10
i think it should has data field for snmp port coz squid use 3401 for its snmp so perhaps you should re adjust the scripts. how is it bro ?
your script was so cool!


Top
 Profile  
 
 Post subject: using
PostPosted: Fri Feb 18, 2005 11:45 am 
Offline

Joined: Fri Feb 18, 2005 10:06 am
Posts: 4
I'm using all three of these.. working GREAT!

THANKS!


Top
 Profile  
 
 Post subject: Squid Issues
PostPosted: Tue Feb 22, 2005 8:52 pm 
Offline

Joined: Tue Feb 22, 2005 8:47 pm
Posts: 4
:evil:
I have the MIB and CFG file I have used to mointoring squid proxy service on port 3041 but how do I import that or get Cacti to reconize it?
I go to devices and try to query it but get SNMP error.
Any ideas will greatly help me, thank you.


Top
 Profile  
 
 Post subject: Sorry
PostPosted: Tue Feb 22, 2005 8:53 pm 
Offline

Joined: Tue Feb 22, 2005 8:47 pm
Posts: 4
The CFG File and MIB I use are with MRTG. It works fine with it but dunno how to import the MIB?


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 07, 2005 10:02 pm 
Offline

Joined: Wed Mar 02, 2005 10:40 am
Posts: 15
Makenshi wrote:
Forgot to log in. Added the templates to this post.

hi,Makenshi.
I add your three templates and created a new host template.
After I added a new squid driver ,I saw "snmp error" in my device and the data source hadn't been created.
I use
Code:
snmpwalk -v 1 -c xxx 10.23.8.1:3401 .1.3.6.1.4.1.3495.1.3.2.1.4

response:
Code:
SNMPv2-SMI::enterprises.3495.1.3.2.1.4.0 = Counter32: 731757


so I think my setting of squid is right.

how could I do?


Attachments:
squidsnmp.JPG
squidsnmp.JPG [ 69.53 KiB | Viewed 106225 times ]
Top
 Profile  
 
 Post subject:
PostPosted: Fri Apr 08, 2005 2:36 am 
Offline

Joined: Tue Jun 08, 2004 5:34 am
Posts: 26
From the look of it, the problem is that Cacti cannot communicate with the snmp agent. First you need to check if your Squid has been compiled with snmp support. Also, you will need the correct directives for snmp in squid.conf. An example of these are:-

snmp_port 3401
acl snmppublic snmp_community public
snmp_access allow snmppublic
snmp_incoming_address 0.0.0.0
snmp_outgoing_address 255.255.255.255

Hope this helps!


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 05, 2005 9:05 am 
Offline

Joined: Mon May 02, 2005 12:14 pm
Posts: 9
Location: Brazil
hi all,

I am trying to graph my two squid servers, but with no lucky. One machine is running redhat9, so i checked squid src rpm and the squid.spec already had a configure option to --enable-snmp. So i think that my squid is fine, snmp enabled.

I edited the squid.conf and added the lines:

snmp_port 3401
acl snmppublic snmp_community public
snmp_access allow snmppublic
snmp_incoming_address 0.0.0.0
snmp_outgoing_address 255.255.255.255

and then restarted squid, but no graph at all.

Any idea of what else should be done for getting the squid graphs??

thanks in advance,
Clovis Sena


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 05, 2005 11:32 am 
Offline

Joined: Mon May 02, 2005 12:14 pm
Posts: 9
Location: Brazil
extra info:

running manually:

[csena@CamposdePelenor csena]$ snmpwalk -v 1 -c public 10.0.1.9:3401 .1.3.6.1.4.1.3495.1.3.2.1
SNMPv2-SMI::enterprises.3495.1.3.2.1.1.0 = Counter32: 96557
SNMPv2-SMI::enterprises.3495.1.3.2.1.2.0 = Counter32: 44533
SNMPv2-SMI::enterprises.3495.1.3.2.1.3.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.4.0 = Counter32: 39046
SNMPv2-SMI::enterprises.3495.1.3.2.1.5.0 = Counter32: 499309
SNMPv2-SMI::enterprises.3495.1.3.2.1.6.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.7.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.8.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.9.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.10.0 = INTEGER: 61479
SNMPv2-SMI::enterprises.3495.1.3.2.1.11.0 = INTEGER: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.12.0 = Counter32: 433979
SNMPv2-SMI::enterprises.3495.1.3.2.1.13.0 = Counter32: 32112
SNMPv2-SMI::enterprises.3495.1.3.2.1.14.0 = Counter32: 138238
SNMPv2-SMI::enterprises.3495.1.3.2.1.15.0 = Counter32: 117


and on another machine:

[csena@CamposdePelenor csena]$ snmpwalk -v 1 -c public 10.0.1.10:3401 .1.3.6.1.4.1.3495.1.3.2.1
SNMPv2-SMI::enterprises.3495.1.3.2.1.1.0 = Counter32: 888
SNMPv2-SMI::enterprises.3495.1.3.2.1.2.0 = Counter32: 272
SNMPv2-SMI::enterprises.3495.1.3.2.1.3.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.4.0 = Counter32: 538
SNMPv2-SMI::enterprises.3495.1.3.2.1.5.0 = Counter32: 3784
SNMPv2-SMI::enterprises.3495.1.3.2.1.6.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.7.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.8.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.9.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.10.0 = INTEGER: 639
SNMPv2-SMI::enterprises.3495.1.3.2.1.11.0 = INTEGER: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.12.0 = Counter32: 3692
SNMPv2-SMI::enterprises.3495.1.3.2.1.13.0 = Counter32: 433
SNMPv2-SMI::enterprises.3495.1.3.2.1.14.0 = Counter32: 92148
SNMPv2-SMI::enterprises.3495.1.3.2.1.15.0 = Counter32: 1


as I see, squid snmp is working, but I still can't have graph data.

any idea??


Top
 Profile  
 
 Post subject:
PostPosted: Fri May 06, 2005 1:10 pm 
Offline

Joined: Mon May 02, 2005 12:14 pm
Posts: 9
Location: Brazil
I am making some more tests here and I would like to know if cacti is reaally using other port than default port 161...

How could I check this??


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 10, 2005 10:43 am 
Offline
Cacti User
User avatar

Joined: Wed Feb 25, 2004 3:38 am
Posts: 187
i posted a host template for bluecoat proxies. this should work on squid as they use the same mibs.

a brave soul should use the search button to find it.

Morgan


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 11, 2005 8:36 am 
Offline

Joined: Mon May 02, 2005 12:14 pm
Posts: 9
Location: Brazil
hi all,

searching the forums, I've found this:

http://forums.cacti.net/viewtopic.php?t ... =port+3401

-----------------------------------------
You can configure your snmpd.conf file to passthrough snmp queries like ...

proxy -v 1 -c <communityname> <squid_machine>:3401 .1.3.6.1.4.1.3495.1

In my case -

proxy -v 1 -c public localhost:3401 .1.3.6.1.4.1.3495.1

Hope this helps.

-P
----------------------------------------

This worked for me. Now I am getting my squid data beeing graphed.

I hope it helps somebody else.

:wink:


Clovis.


Top
 Profile  
 
 Post subject: problem with graphs
PostPosted: Tue Jul 05, 2005 12:23 pm 
Offline
Cacti User

Joined: Fri Aug 22, 2003 4:33 am
Posts: 83
my cacti.log shows up

7/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[13] WARNING: Result from SNMP not valid. Partial Result:
07/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[14] WARNING: Result from SNMP not valid. Partial Result:
07/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[15] WARNING: Result from SNMP not valid. Partial Result:
07/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[16] WARNING: Result from SNMP not valid. Partial Result:

what this error means


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 96 posts ]  Go to page 1, 2, 3, 4, 5 ... 7  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group