Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Apr 28, 2017 1:11 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: HP Laserjet 4100 and 4600 Percentage Templates
PostPosted: Wed Apr 05, 2006 7:23 am 
Offline

Joined: Fri Mar 17, 2006 6:16 am
Posts: 16
Hi All,

Hoping to do something in return now.. This template uses a custom CDEF and calculates the percentages.

Enjoy..

bio777..


Attachments:
File comment: host_template_hp_4600
cacti_host_template_hp_laserjet_4600.xml [28.19 KiB]
Downloaded 2178 times
File comment: HP4600
HP4600.JPG
HP4600.JPG [ 37.17 KiB | Viewed 19357 times ]
File comment: host_template_hp_4100
cacti_host_template_hp_laserjet_4100.xml [9.67 KiB]
Downloaded 2156 times
File comment: HP4100
HP4100.JPG
HP4100.JPG [ 23.08 KiB | Viewed 19357 times ]
Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 05, 2006 11:06 am 
Offline

Joined: Sun Feb 19, 2006 3:47 pm
Posts: 9
Location: FR -- Sophia-antipolis - Valence
thx a lot !


Top
 Profile  
 
 Post subject: Howto
PostPosted: Sun Mar 04, 2007 9:22 pm 
Offline

Joined: Sun Mar 04, 2007 8:45 pm
Posts: 1
Location: Gothenburg, Sweden
Yeah, I'm a newbie at cacti, but...

I imported the above host templates in ccacti-0.8.6j, defined my graphs, and everything seemed OK at first. Then I discovered that the HP Laserjet 4100 template worked just fine, but I get no values for the HP Color Laserjet 4600, which I've connected to my HP Laserjet 4500 printer. For all MIBs defined in the 4600 template, I've done the snmpget, but they all return -3 or similar. Does anyone know how to adapt the template for the 4500 printer?

Any help appreciated.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 28, 2007 1:39 am 
Offline

Joined: Mon May 21, 2007 6:55 pm
Posts: 14
Tried this template with HP4650dn. Working beautifully. thanks.


Top
 Profile  
 
 Post subject: Recent Use
PostPosted: Tue Oct 07, 2008 9:10 am 
Offline

Joined: Tue Oct 07, 2008 9:07 am
Posts: 2
Original Post:
Anybody used this one recently?
I am trying to get this to work with a 5550 Color Laserjet. I am getting data (based on logs), but the graphs do not display. (Actually, no graphic at all)
Thank you for any help.

Update:
Found the problems. The maximums were all wrong for a 5550. Fixed that and it started working. I have attached a modified Template for anyone using an HP Color Laserjet 5550.


Attachments:
File comment: HP Color Laserjet 5550
cacti_graph_template_hp_laserjet_5550_-_toner_transfer_fuser_kit.zip [4.32 KiB]
Downloaded 654 times
Top
 Profile  
 
 Post subject: Re: Recent Use
PostPosted: Tue Nov 25, 2008 5:52 am 
Offline

Joined: Tue Nov 25, 2008 5:50 am
Posts: 16
mvonherr wrote:
Update:
Found the problems. The maximums were all wrong for a 5550. Fixed that and it started working. I have attached a modified Template for anyone using an HP Color Laserjet 5550.


Hi,

Thanks for this.
But it will not work for me on a 5500.
It wont produce a graph image at all.

/Isse


Top
 Profile  
 
 Post subject: Re: HP Laserjet 4100 and 4600 Percentage Templates
PostPosted: Wed Feb 22, 2017 6:14 am 
Offline

Joined: Wed Oct 24, 2007 1:22 pm
Posts: 12
I'm using this template on a HP Color Laserjet 4700 and it worked great so far, the percentages of the consumables where displayed correctly. But now, for the first time after using this template, I replaced an empty toner cartridge (cyan) and ran into trouble with Cacti: The printer's SNMP server returns the correct value "10000" for the remaining pages of the new cartridge. This value is also correctly read by Cacti and stored into the respective .rrd file as I've checked with "rrdtool lastupdate". Also the maximum value for this value is set to 10000 in the respective Cacti data template.
However, the graphs created by Cacti don't contain "100" as the percentage for the cyan toner, but "-nan" instead. It even stayed this way after some pages where printed with the new cartridge and the remaining page count is now down to 9900.
Any idea what could be wrong here?

TIA
sjs


Top
 Profile  
 
 Post subject: Re: HP Laserjet 4100 and 4600 Percentage Templates
PostPosted: Thu Feb 23, 2017 10:45 am 
Offline

Joined: Wed Oct 24, 2007 1:22 pm
Posts: 12
sjs wrote:
I'm using this template on a HP Color Laserjet 4700 and it worked great so far, the percentages of the consumables where displayed correctly. But now, for the first time after using this template, I replaced an empty toner cartridge (cyan) and ran into trouble with Cacti: The printer's SNMP server returns the correct value "10000" for the remaining pages of the new cartridge. This value is also correctly read by Cacti and stored into the respective .rrd file as I've checked with "rrdtool lastupdate". Also the maximum value for this value is set to 10000 in the respective Cacti data template.
However, the graphs created by Cacti don't contain "100" as the percentage for the cyan toner, but "-nan" instead. It even stayed this way after some pages where printed with the new cartridge and the remaining page count is now down to 9900.
Any idea what could be wrong here?


Addendum: In the meantime, for testing purposes, I've created another Cacti host, querying the same printer. On that test host, all consumable values (including the cyan toner) show up correctly. Because of this, I suspect that the corresponding .rrd file might have an issue of some sort. Any idea how I could fix this? (Aside from removing and re-creating the file altogether.)


Regards,
sjs77


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group