Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri May 26, 2017 6:11 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: You are running MySQL in Strict Mode
PostPosted: Tue Nov 08, 2016 9:28 am 
Offline

Joined: Sat Oct 31, 2015 5:10 pm
Posts: 15
You are running MySQL in Strict Mode, which is not supported by Thold.
I'm getting the above error on Thold. In general I'm having a tough time getting plugins to work at all, I'm starting to question my OS choice of Ubuntu 16.04 lts.

Cacti Version 0.8.8f
PHP 7.0.8-0ubuntu0.16.04.3
Ubuntu 16.04 LTS
Thold version 0.5
MySql ??

I have added the Settings plugin successfully but Thold tab had the error above.
I edited the file
“/usr/share/mysql/my-default.cnf”
and replaced
“sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES”
with
(sql_mode = “”)

I restarted the MySql service but no change at all. Is there something I'm missing?
Any suggestions on how to get this working?

Thanks in Advance


Top
 Profile  
 
 Post subject: Re: You are running MySQL in Strict Mode
PostPosted: Tue Nov 08, 2016 9:36 am 
Offline
Developer

Joined: Thu Apr 07, 2005 3:29 pm
Posts: 2534
Location: B/CS Texas
You need to ensure that that is the correct config file, I don't use ubuntu, but for every distribution I have ever used, its always been /etc/my.cnf or in the directory /etc/my.cnf.d/

_________________
CactiEZ CD


Top
 Profile  
 
 Post subject: Re: You are running MySQL in Strict Mode
PostPosted: Tue Nov 08, 2016 1:06 pm 
Offline

Joined: Sat Oct 31, 2015 5:10 pm
Posts: 15
Close but for the version of MySql I'm on, this did not work but the link below did!

https://serverpilot.io/community/articles/how-to-disable-strict-mode-in-mysql-5-7.html

Thanks!


Top
 Profile  
 
 Post subject: Re: You are running MySQL in Strict Mode
PostPosted: Fri Feb 03, 2017 6:12 pm 
Offline

Joined: Wed Oct 02, 2013 7:14 am
Posts: 24
I had already done this to get rid of that error message, but I coudn't get thold to work: I create a threshold, no error messages, but none shows up later in the thold list.
I suspect that this is still a mysql issue.
Have you managed to get it working?
I've never had trouble with thold before, but this is the first time I'm running over mysql 5.7...

_________________
Cacti 0.8.8f over Ubuntu Server 16.04.1 monitoring
[list][*]Router Ubuntu Server 16.04.1 over Celeron J1900i
[*]TP-LINK WRT841ND / OpenWRT AP
[*]Humax HG100R-L2 Residential Gateway


Top
 Profile  
 
 Post subject: Re: You are running MySQL in Strict Mode
PostPosted: Mon Feb 06, 2017 10:07 am 
Offline

Joined: Sat Oct 31, 2015 5:10 pm
Posts: 15
Yes, I had to enter each new Thold entry as a "Threshold Type" as "Time Based" to get the DB to accept the entry under Thresholds. After that, I went back and edited and changed to another option, ex "High/Low Values". Then everything worked as expected. I don't know why this is, I only got this answer by trolling through other threads in this forum but it worked for me. Sorry I don't have the other thread link here but If you look you will find it, I'm going from memory this AM..


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group