Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Jun 23, 2017 12:27 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 49 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject:
PostPosted: Thu Jul 09, 2009 9:46 am 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
Post your analysis with both STD Dev and Variance. Oh, yes, your PHP Needs more memory. Please set to 256MB and restart Apache.

TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 09, 2009 10:42 am 
Offline

Joined: Mon Feb 11, 2008 11:44 am
Posts: 6
Quote:
PHP Needs more memory. Please set to 256MB and restart Apache.

I've tried to increase the memory value in php.ini and restart apache, it didn't work. Seems to work fine with the ini_set though. Not sure if this is ideal.

Here are my settings for spikekill.
Removal Method: Variance Based w/Outliers Removed
Replacement Method: Average
Number of Standard Deviations: 5
Variance Percentage: 300
Variance Number of Outliers: 5
Max Kills Per RRA: 5

stddev analysis
http://216.10.32.22/stddev_graph.php.html

variation analysis
http://216.10.32.22/variance_graph.php.html

Thanks!


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 27, 2010 6:56 pm 
Offline

Joined: Fri Nov 20, 2009 3:28 pm
Posts: 13
I've installed the plugin, given myself permission to use it, and can see the icon to run spikekill against a graph. When I select a menu option to remove or analyze I get a results popup that says "This script is only meant to run at command line".

Any clue what I've mis-configured somewhere?

thanks

Steve


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 27, 2010 11:00 pm 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
What is your web server?

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 28, 2010 10:52 am 
Offline

Joined: Fri Nov 20, 2009 3:28 pm
Posts: 13
Apache version 1.3.41_1

Cacti Version 0.8.7e

spikekill Version: 1.0 8 Mar 2009

FreeBSD 8.0


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 28, 2010 5:05 pm 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
This might have something to do with the Apache PHP interaction.
Since spikekill is exec'd from the PHP shell it should not have any of the variables that cause this type of message. So, the solution is to look at those few lines of code, and then when it's exec'd, dump it's information to a text file to find out "how" the request variables are being set.

It might just be that you have too old of a PHP, or that you don't have a CLI mode. In other words:

Code:
php -q <script>
is CGI only and assumes everything is a web site. So, in that case, upgrade PHP to something more modern. Take your time though, I don't want to get one of those rant and rave posts where you did an upgrade, messed things up and could not get back in operation for days as a result.

TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 28, 2010 5:14 pm 
Offline

Joined: Fri Nov 20, 2009 3:28 pm
Posts: 13
php5-5.2.11

How new must the PHP be?

The system was built from a new BSD ISO with a ports update. Runs nothing significant except cacti + weathermap and supporting programs.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 28, 2010 5:21 pm 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
That's new enough. Look in the database for the php_bin_path, it'll be in the settings table in MySQL. Capture that path and then run the following. Post the results:

Code:
/path/to/php -v


TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 17, 2010 10:13 am 
Offline

Joined: Fri Nov 20, 2009 3:28 pm
Posts: 13
There was no php_bin_path but there was a path_php_binary. The results of running the -v are:

Code:
# /usr/local/bin/php -v
PHP Warning:  Module 'gd' already loaded in Unknown on line 0
PHP 5.2.11 with Suhosin-Patch 0.9.7 (cli) (built: Mar  9 2010 12:25:10)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies



Steve


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 17, 2010 2:08 pm 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
You have the gd module loaded twice for some reason. You need to fix that...

TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 17, 2010 4:40 pm 
Offline

Joined: Fri Nov 20, 2009 3:28 pm
Posts: 13
I'll track down the unknown, but it is only a warning. A module already loaded should not be a fatal error, as evidenced by the command line version of spikekiller running just fine with the same error:

Code:
# php removespikes.php --rrdfile=/usr/local/share/cacti/rra/ln204_traffic_in_1079.rrd --stddev=1 --number=2
PHP Warning:  Module 'gd' already loaded in Unknown on line 0
NOTE: Creating XML file '/tmp/ln204_traffic_in_1079.dump.132779741' from '/usr/local/share/cacti/rra/ln204_traffic_in_1079.rrd'
NOTE: Searching for Spikes in XML file '/tmp/ln204_traffic_in_1079.dump.132779741'
NOTE: Backing Up '/usr/local/share/cacti/rra/ln204_traffic_in_1079.rrd' to '/tmp/ln204_traffic_in_1079.rrd.132779741'
NOTE: Re-Importing '/tmp/ln204_traffic_in_1079.dump.132779741' to '/usr/local/share/cacti/rra/ln204_traffic_in_1079.rrd'


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 17, 2010 4:47 pm 
Offline

Joined: Fri Nov 20, 2009 3:28 pm
Posts: 13
I did have to change into the spikekiller folder to run the command line version. It did not like running from the rra folder in the format "php /usr/local/share/cacti/spikekiller/removespikes.php...." .

Once I executed from the spikekiller folder instead and used the full path for the rrd file, the command line worked fine.

Since this server is FreeBSD, could there be an file path hardcoded into the web version that does not like the freebsd includes paths?


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 17, 2010 5:55 pm 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
Understood, if you want to submit a patch, you may do it here: http://bugs.cacti.net

TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: errormessage when running spikekiller
PostPosted: Wed Jun 30, 2010 7:01 pm 
Offline

Joined: Mon Jan 14, 2008 1:58 pm
Posts: 7
Hi, I do not get this tool running. I can't find a solution for the error below.

Any idea how to fix?

Thanks in advance

@lex


Attachments:
spike1.jpg
spike1.jpg [ 25.67 KiB | Viewed 7287 times ]
Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 30, 2010 7:02 pm 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
Looks like your PHP version is too old.

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 49 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group