Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Thu Jun 29, 2017 12:41 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Empty graphs in 1.0.3
PostPosted: Fri Feb 24, 2017 7:52 am 
Offline

Joined: Mon Feb 20, 2017 8:09 am
Posts: 8
Location: Brasil
I followed this http://forums.cacti.net/viewtopic.php?f=6&t=56843 tutorial, but the graphics are empty, did I do something wrong?


Top
 Profile  
 
 Post subject: Re: Empty graphs in 1.0.3
PostPosted: Fri Feb 24, 2017 9:19 am 
Offline
Cacti Guru User
User avatar

Joined: Thu Jan 31, 2008 6:39 am
Posts: 2589
Location: Kressbronn, Germany
Did you make sure that you have set a timezone in both php.ini and my.cnf ?

_________________
Greetings,
Phalek
---
Need more help ? Read the Cacti documentation or my new Cacti Book
Need on-site support ? Look here Cacti Workshop
Need professional Cacti support ? Look here CereusService
---
Plugins : CereusTransporter | CereusReporting | nmidWebService | nmidSmokeping | nmidWeb2 |

Code:
CereusServer Master:  SYSTEM STATS: Time:2.5621 Method:spine Processes:1 Threads:16 Hosts:446 HostsPerProcess:446 DataSources:14683 RRDsProcessed:7573
CereusServer Agent:   SYSTEM STATS: Time:27.4840 Method:spine Processes:1 Threads:8 Hosts:16 HostsPerProcess:16 DataSources:114576 RRDsProcessed:48061


Top
 Profile  
 
 Post subject: Re: Empty graphs in 1.0.3
PostPosted: Fri Feb 24, 2017 4:17 pm 
Offline

Joined: Mon Feb 20, 2017 8:09 am
Posts: 8
Location: Brasil
MariaDB [(none)]> SHOW GLOBAL VARIABLES LIKE 'time_zone';
+---------------+----------------+
| Variable_name | Value |
+---------------+----------------+
| time_zone | America/Recife |
+---------------+----------------+
1 row in set (0.00 sec)


PHP
Default timezone America/Recife
date.timezone America/Recife America/Recife

I really forgot the timezone. After placing timezone, restart services, these appear;
2017-02-24 18:15:00 - SYSTEM STATS: Time:299.6792 Method:spine Processes:1 Threads:1 Hosts:2 HostsPerProcess:2 DataSources:5 RRDsProcessed:0
2017-02-24 18:15:00 - POLLER: Poller[1] Maximum runtime of 298 seconds exceeded. Exiting.
2017-02-24 18:09:59 - SYSTEM STATS: Time:298.6795 Method:spine Processes:1 Threads:1 Hosts:2 HostsPerProcess:2 DataSources:5 RRDsProcessed:0
2017-02-24 18:09:59 - POLLER: Poller[1] Maximum runtime of 298 seconds exceeded. Exiting.


Top
 Profile  
 
 Post subject: Re: Empty graphs in 1.0.3
PostPosted: Sat Feb 25, 2017 4:16 am 
Offline

Joined: Mon Apr 22, 2013 1:30 pm
Posts: 25
I am seeing the same thing on my fresh install of 1.0.3 using Spine. CMD poller works fine but when moving to spine I get no love :oops:
When enabling debugging on poller.php the log is filled with the following:
Code:
2017-02-25 01:12:33 - DBCALL DEVEL: SQL Cell: "SELECT SQL_NO_CACHE count(*) FROM poller_time WHERE poller_id = ? AND end_time >'0000-00-00 00:00:00'"
2017-02-25 01:12:32 - DBCALL DEVEL: SQL Assoc: "SELECT po.output, po.time, UNIX_TIMESTAMP(po.time) as unix_time, po.local_data_id, dl.data_template_id, pi.rrd_path, pi.rrd_name, pi.rrd_num FROM poller_output AS po INNER JOIN poller_item AS pi ON po.local_data_id=pi.local_data_id AND po.rrd_name=pi.rrd_name INNER JOIN data_local AS dl ON dl.id=po.local_data_id ORDER BY po.local_data_id LIMIT 40000"
2017-02-25 01:12:32 - DBCALL DEVEL: SQL Cell: "SELECT SQL_NO_CACHE count(*) FROM poller_time WHERE poller_id = ? AND end_time >'0000-00-00 00:00:00'"
2017-02-25 01:12:31 - DBCALL DEVEL: SQL Assoc: "SELECT po.output, po.time, UNIX_TIMESTAMP(po.time) as unix_time, po.local_data_id, dl.data_template_id, pi.rrd_path, pi.rrd_name, pi.rrd_num FROM poller_output AS po INNER JOIN poller_item AS pi ON po.local_data_id=pi.local_data_id AND po.rrd_name=pi.rrd_name INNER JOIN data_local AS dl ON dl.id=po.local_data_id ORDER BY po.local_data_id LIMIT 40000"
2017-02-25 01:12:31 - DBCALL DEVEL: SQL Cell: "SELECT SQL_NO_CACHE count(*) FROM poller_time WHERE poller_id = ? AND end_time >'0000-00-00 00:00:00'"
2017-02-25 01:12:30 - DBCALL DEVEL: SQL Assoc: "SELECT po.output, po.time, UNIX_TIMESTAMP(po.time) as unix_time, po.local_data_id, dl.data_template_id, pi.rrd_path, pi.rrd_name, pi.rrd_num FROM poller_output AS po INNER JOIN poller_item AS pi ON po.local_data_id=pi.local_data_id AND po.rrd_name=pi.rrd_name INNER JOIN data_local AS dl ON dl.id=po.local_data_id ORDER BY po.local_data_id LIMIT 40000"
2017-02-25 01:12:30 - DBCALL DEVEL: SQL Cell: "SELECT SQL_NO_CACHE count(*) FROM poller_time WHERE poller_id = ? AND end_time >'0000-00-00 00:00:00'"
2017-02-25 01:12:29 - DBCALL DEVEL: SQL Assoc: "SELECT po.output, po.time, UNIX_TIMESTAMP(po.time) as unix_time, po.local_data_id, dl.data_template_id, pi.rrd_path, pi.rrd_name, pi.rrd_num FROM poller_output AS po INNER JOIN poller_item AS pi ON po.local_data_id=pi.local_data_id AND po.rrd_name=pi.rrd_name INNER JOIN data_local AS dl ON dl.id=po.local_data_id ORDER BY po.local_data_id LIMIT 40000"
2017-02-25 01:12:29 - DBCALL DEVEL: SQL Cell: "SELECT SQL_NO_CACHE count(*) FROM poller_time WHERE poller_id = ? AND end_time >'0000-00-00 00:00:00'"

wondering if you see the same thing?

This is via using Centos7 (under docker 1.13)
PHP Version 5.4.16
MySQL Version 5.7.17


Top
 Profile  
 
 Post subject: Re: Empty graphs in 1.0.3
PostPosted: Sat Feb 25, 2017 4:21 am 
Offline

Joined: Mon Apr 22, 2013 1:30 pm
Posts: 25
Just figured out my issue from another post, looks like Spine had a configuration error however logs did not display an error message to reflect this.

Quote:
DB_Host db-poller
DB_Database %DB_DB%
DB_User cactiuser
DB_Pass cactipassword
DB_Port 3306

:roll: failed automation script, double check your spine configuration file is all set.


Top
 Profile  
 
 Post subject: Re: Empty graphs in 1.0.3
PostPosted: Sat Feb 25, 2017 9:50 pm 
Offline

Joined: Mon Feb 20, 2017 8:09 am
Posts: 8
Location: Brasil
My solution was;
cp /usr/local/spine/etc/spine.conf.dist /usr/local/spine/etc/spine.conf

Go to Configuration -> Settings and click on the Paths tab.
Under the Alternate Poller Path, set the following:
Spine Config File Path = /usr/local/spine/etc/spine.conf


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group