Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Wed May 24, 2017 2:56 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Graphs not populating after new install of cacti 1.0.5
PostPosted: Tue Mar 14, 2017 1:55 pm 
Offline

Joined: Tue Mar 14, 2017 1:40 pm
Posts: 1
Decided to setup a new cacti host on some Raspberry Pi's at home.

SNMP is working, both v1 and v2c, from the command line as I can snmpget/walk OID's from one host to another. However, using the out of the box Net-SNMP template to poll a remote host (the Local Linux Machine works fine) I am getting NaN's.

I've tried alternating between both SNMP v1 and 2c with no luck.

In the cacti log I see:
Code:
2017-03-14 12:50:05 - POLLER: Poller[1] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q /var/www/cacti/poller_maintenance.php]
2017-03-14 12:50:05 - POLLER: Poller[1] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q /var/www/cacti/poller_automation.php -M]
2017-03-14 12:50:05 - POLLER: Poller[1] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q /var/www/cacti/poller_spikekill.php]
2017-03-14 12:50:05 - POLLER: Poller[1] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q /var/www/cacti/poller_reports.php]
2017-03-14 12:50:04 - SYSTEM STATS: Time:2.4374 Method:cmd.php Processes:2 Threads:N/A Hosts:3 HostsPerProcess:2 DataSources:10 RRDsProcessed:9
2017-03-14 12:50:04 - POLLER: Poller[1] Parsed MULTI output field '10min:0.12' [map 10min->load_15min]
2017-03-14 12:50:04 - POLLER: Poller[1] Parsed MULTI output field '5min:0.19' [map 5min->load_5min]
2017-03-14 12:50:04 - POLLER: Poller[1] Parsed MULTI output field '1min:0.23' [map 1min->load_1min]
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] DS[15] Graphs['cougar - Traffic - 192.168.0.17 (eth0)'] SNMP: v1: cougar.XXXXXXXX.net, dsname: traffic_out, oid: .1.3.6.1.2.1.2.2.1.16.2, output: U
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] DS[15] Graphs['cougar - Traffic - 192.168.0.17 (eth0)'] SNMP: v1: cougar.XXXXXXXX.net, dsname: traffic_in, oid: .1.3.6.1.2.1.2.2.1.10.2, output: U
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] DS[8] Graphs['cougar - CPU Usage'] SNMP: v1: cougar.XXXXXXXX.net, dsname: cpu_user, oid: .1.3.6.1.4.1.2021.11.50.0, output: U
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] DS[7] Graphs['cougar - CPU Usage'] SNMP: v1: cougar.XXXXXXXX.net, dsname: cpu_system, oid: .1.3.6.1.4.1.2021.11.52.0, output: U
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] DS[6] Graphs['cougar - CPU Usage'] SNMP: v1: cougar.XXXXXXXX.net, dsname: cpu_nice, oid: .1.3.6.1.4.1.2021.11.51.0, output: U
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] RECACHE DQ[2] OID: .1.3.6.1.2.1.1.3.0, output: U
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] RECACHE DQ[1] OID: .1.3.6.1.2.1.1.3.0, output: U
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] RECACHE: Processing 2 items in the auto reindex cache for 'cougar.XXXXXXXX.net'.
2017-03-14 12:50:03 - POLLER: Poller[1] WARNING: Unable to open session for System Mib collection for Device[3] Description[cougar]
2017-03-14 12:50:03 - POLLER: Poller[1] Device[3] Description[cougar] STATUS: Device 'cougar.XXXXXXXX.net' is UP.
2017-03-14 12:50:02 - POLLER: Poller[1] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q "/var/www/cacti/cmd.php" --poller=1 --first=3 --last=3 --mibs]
2017-03-14 12:50:02 - POLLER: Poller[1] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q "/var/www/cacti/cmd.php" --poller=1 --first=0 --last=1 --mibs]


Not sure where to look at next. It seems as it should work, but when the poller.php is pulling I get "output: U"? instead of values like I do from the command line?

It also looks like per the log that it's pulling the multi-output info from the load avg, but somehow still isn't populating the graphs.

Thanks,


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group