Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue May 23, 2017 1:57 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 27 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Thu Jul 28, 2011 8:55 am 
Offline

Joined: Wed Dec 02, 2009 1:20 pm
Posts: 4
I'm using ubuntu 10.04, cacti Version 0.8.7e and plugin Architecture v2.9. I do everything as I described, plugins, etc. appear. But the graph stops running. It just does not create more graphic. Can I use version 2.9 of the PIA in cacti 0.8.7e? Has anyone gone through this problem?


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Thu Jul 28, 2011 9:25 am 
Offline

Joined: Wed Dec 02, 2009 1:20 pm
Posts: 4
[Thu Jul 28 11:09:59 2011] [error] [client 10.7.5.57] PHP Warning: include_once (): Failed opening '/ usr / share / cacti / site / include / plugins.php' for inclusion (include_path = '.') in / usr / share / cacti / site / include / global.php on line 208
[Thu Jul 28 11:09:59 2011] [error] [client 10.7.5.57] PHP Fatal error: Call to undefined function api_plugin_hook () in / usr / share / cacti / site / include / global_arrays.php on line 663


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 5:36 am 
Offline

Joined: Fri Sep 30, 2011 3:37 am
Posts: 40
when you say

For a fresh install you have to import the pa.sql to your cacti database:

Quote:
mysql cacti < pa.sql -u root -p

if I have installed cacti and all configured and I want to add PIA, have to do this?

_________________
Thanks

Edu


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 7:04 am 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
Look here, but use full files instead of patch method. Also keep in mind that Debian's config.php and global.php are different than stock, so you have to tread lightly. In addition, Debian moves a few directories to alternate locations.

http://docs.cacti.net/manual:087:1_installation.9_pia

TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 7:15 am 
Offline

Joined: Fri Sep 30, 2011 3:37 am
Posts: 40
I got working, first time it mess up in my sql server, I have 3 cacti in production, in these one works well, only I had to restart mysqld before apply pa.sql and after.

_________________
Thanks

Edu


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 7:18 am 
Offline

Joined: Tue Nov 01, 2011 7:04 am
Posts: 5
I've installed cacti from repository following the instructions written on cacti's offical site,my linux distribution is ubuntu 10.But when ı want to install a plugin it is not possible to install directly from aministration panel,because there is no such a menu item.
Also,ı've tried to install manually,getting the plugin then extracting into the plugin installation folder.I checked the configuration many times,but didn'd succeed.
What else should ı do more?

Thank you so much for your time.


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 7:22 am 
Offline

Joined: Fri Sep 30, 2011 3:37 am
Posts: 40
1 could you copy your /include/config.php here
2 ls fo /plugins/...
3 check if your user have the configuration of PIA tick mark

_________________
Thanks

Edu


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 7:24 am 
Offline

Joined: Fri Sep 30, 2011 3:37 am
Posts: 40
I did this

tar xvfz cacti-plugin-0.8.7h-PA-v3.0.tar.gz
cd cacti-plugin-arch/
cp cacti-plugin-0.8.7h-PA-v3.0.diff /var/www/cacti/
cd /var/www/cacti/
patch -p1 -N --dry-run < cacti-plugin-0.8.7h-PA-v3.0.diff
patch -p1 -N < cacti-plugin-0.8.7h-PA-v3.0.diff
vi ./include/config.php

Add this lines

/* load up old style plugins here */
$plugins = array();
//$plugins[] = 'thold';

/*
Edit this to point to the default URL of your Cacti install
ex: if your cacti install as at http://serverip/cacti/ this
would be set to /cacti/
*/
$url_path = "/cacti/";



service mysqld restart
cd /tmp/cacti-plugin-arch/
mysql cacti < pa.sql -u root -p
service mysqld restart

and works for me, only you have to go to user management and in your use tick the mark pluggins management.

_________________
Thanks

Edu


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 7:40 am 
Offline

Joined: Tue Nov 01, 2011 7:04 am
Posts: 5
This my screen


Attachments:
Untitled.png
Untitled.png [ 74.83 KiB | Viewed 5424 times ]
Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 9:01 am 
Offline

Joined: Fri Sep 30, 2011 3:37 am
Posts: 40
ok did you apply the steps like i did it?

_________________
Thanks

Edu


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Tue Nov 01, 2011 4:28 pm 
Offline

Joined: Tue Nov 01, 2011 7:04 am
Posts: 5
Successfully apply a patch consists of these steps, while the point while cactinin lot of trouble from there I'm doing is taking the main directory of the diff file. but it was not
I am about to go nuts:)
From there can I contact if I have an email address.


Top
 Profile  
 
 Post subject: Re: How To Install Plugin Architecture on Ubuntu 9.10 Server
PostPosted: Wed Jan 16, 2013 12:12 pm 
Offline

Joined: Wed May 11, 2011 3:10 pm
Posts: 14
I think something might be wrong with the forum site, would someone be able to post what is the correct code- see whats underlined below. I opened this forum page in firefox, chrome, and ie and get the same scrambled code. Not sure why. Thank you.
$config["rra_path"] = $config["base_path"]."/rra";
change it to:
$config["rra_path"] = "/var/lib/cacti/rra";


include($config["library_path"]."/adodb/adodb.inc.php");
change it to:
include("/usr/share/php/adodb/adodb.inc.php");


$config[’url_path’] = ‘/’;
to:
$config[’url_path’] = ‘/cacti/’;


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 27 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group