Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Jun 23, 2017 7:13 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 21 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: No Plugins Found
PostPosted: Mon Oct 31, 2011 9:35 am 
Offline

Joined: Mon Oct 24, 2011 9:50 am
Posts: 14
PROBLEM RESOLVED

OK, we finally discovered what the issue was. Unbeknownst to us, Linux was installed/running in selinux mode. Once we turned that off everything seemed to install and work just fine.

Thanks for all your help on this. Sorry it ended up being a 'chase your tail" type of problem, but at least I did learn a few things along the way.

Again, many thanks - John


Top
 Profile  
 
 Post subject: Re: No Plugins Found
PostPosted: Mon Oct 31, 2011 10:53 am 
Offline
Developer
User avatar

Joined: Tue May 14, 2002 5:08 pm
Posts: 14863
Location: MI, USA
John,

It's good to know that SELinux does that. For future reference, I refer to these things as PEBKAC (Problem Exists Between Keyboard and Chair).

TheWitness

_________________
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
Gandalfs Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: No Plugins Found
PostPosted: Mon Oct 31, 2011 12:35 pm 
Offline

Joined: Mon Oct 24, 2011 9:50 am
Posts: 14
TheWitness wrote:
John,

It's good to know that SELinux does that. For future reference, I refer to these things as PEBKAC (Problem Exists Between Keyboard and Chair).

TheWitness

:oops: :wink:


Top
 Profile  
 
 Post subject: Re: No Plugins Found
PostPosted: Thu Jul 12, 2012 10:20 pm 
Offline

Joined: Thu Jul 12, 2012 10:08 pm
Posts: 1
Thk John & TheWitness

On the same my issue. :wink:

Cacti Version: 0.8.8a
Plugin Architecture Version: 3.1

SELinux = disabled :lol: :D


Top
 Profile  
 
 Post subject: Re: No Plugins Found
PostPosted: Thu Aug 02, 2012 6:33 pm 
Offline

Joined: Thu Jul 16, 2009 12:57 am
Posts: 11
I am running into the no plugins found problem. I set up a new machine with CentOS 6.3 x86_64.
I installed apache and mysql as well as enabled the RPMForge repository.

I then installed cacti using yum. It installed cacti 0.8.8a on the machine.

There was no plugin directory, so I created one using these commands:
mkdir /var/www/cacti/plugins
chown cacti.cacti /var/www/cacti/plugins

Then, I downloaded the aggregate plugin to the directory, extracted it, and removed the tar file.

When I go to Plugin Management, it says No Plugins found.

I checked the log, there is nothing fishy in there.
Selinux is diabled.

I dont know what is wrong. Any ideas?

Thanks,
Neil


Top
 Profile  
 
 Post subject: Re: No Plugins Found
PostPosted: Mon Aug 06, 2012 8:59 am 
Offline

Joined: Thu Jul 16, 2009 12:57 am
Posts: 11
I figured it out. I had to rename the directory extracted from the aggregate tar to "aggregate". It has a version identifier in the name which apparently was messing things up.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group