Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue May 23, 2017 1:53 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Help with Plugin Architecture
PostPosted: Tue Jan 21, 2014 7:47 am 
Offline

Joined: Tue Jan 21, 2014 7:24 am
Posts: 3
Hello im new to cacti im trying to learn how to use this nice system

i got some problems installing new plugins on cacti im using cactiez 0.7 package so:

Cacti Version: 0.8.8a, Plugin Architecture Version: 3.1

this is my directory plugins (default instaled by cactiez)

/var/www/html/plugins

a screenshot using winscp

as u can see the plugin im trying to install is gpsmaps and rights and owner its diferent from all .. this is the reason to cause the plugin dont appear on my plugin management on cacti website? if it is how i can change? im using centos

this error appear

Warning: include_once(/var/www/html/plugins/gpsmap/setup.php): failed to open stream: Permission denied in /var/www/html/plugins.php on line 280 Warning: include_once(): Failed opening '/var/www/html/plugins//gpsmap/setup.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/plugins.php on line 280

i got another problem making graphs i followed this steps:

http://docs.cacti.net/usertemplate:data:motorola:canopy

the snmp is ok on the device and i can get some ethernet graphs as show on the attach


but when i try to add motorola canopy template this error is shown when i click verbose debbuging

+ Running data query [9].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at '/var/www/html/resource/snmp_queries/motorola_canopy_whisp-aps.xml'
+ Error parsing XML file into an array.
+ Found data query XML file at '/var/www/html/resource/snmp_queries/motorola_canopy_whisp-aps.xml'
+ Found data query XML file at '/var/www/html/resource/snmp_queries/motorola_canopy_whisp-aps.xml'
+ Found data query XML file at '/var/www/html/resource/snmp_queries/motorola_canopy_whisp-aps.xml'

if u think im missing any aditional information please tell me so i can show


thanks for attention!


Attachments:
motorola device.png
motorola device.png [ 31.82 KiB | Viewed 3512 times ]
File comment: folder plugins
folder plugins.png
folder plugins.png [ 50.72 KiB | Viewed 3512 times ]
Top
 Profile  
 
 Post subject: Re: Help with Plugin Architecture
PostPosted: Tue Jan 21, 2014 10:32 am 
Offline
Developer

Joined: Thu Apr 07, 2005 3:29 pm
Posts: 2534
Location: B/CS Texas
For the 1st problem, you will need to change the permissions and ownership of the plugin directory and all the files underneath.
http://linuxcommand.org/learning_the_shell.php
You may be able to do it from WinSCP, just right click and go to properties. Be sure to check the box to set permissions recursively.

Your template problem is almost likely the same issue. In this installation step, you copied some files over.
Via scp or other tool, copy the files “resource/snmp_queries/*.xml” into directory ”<path_cacti>/resource/snmp_queries

You need to go to those files and check that their permissions are correct.

_________________
CactiEZ CD


Top
 Profile  
 
 Post subject: Re: Help with Plugin Architecture
PostPosted: Tue Jan 21, 2014 3:10 pm 
Offline

Joined: Tue Jan 21, 2014 7:24 am
Posts: 3
i follow ur instructions and i was enable to see plugin on plugin management after checking the recursive box. thanks for the help

sadly this plugin seems is not working anymore... the reason as i see is the google map api v3.... the map is shown on gpsmap tab but it doesnt show any host... do you know any solution or another plugin that show hosts on google maps?

now on template its seem working now im going to test on the work tonight(where i got acess to motorola) the verbose query is different now

+ Running data query [5].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at '/var/www/html/resource/snmp_queries/motorola_canopy_whisp-aps.xml'
+ XML file parsed ok.
+ <oid_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting oid_index entries
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.161.19.3.1.7.2' Index Count: 0
+ No SNMP data returned

i really appreciate your help thanks again!

ok forget about gpsmaps it appear after some time


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group