Cacti (home)ForumsRepositoryDocumentation
Cacti: offical forums and support
It is currently Wed Jul 30, 2014 8:07 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Thu Aug 15, 2013 10:31 am 
Offline

Joined: Thu Aug 15, 2013 10:16 am
Posts: 2
hello

after i update my cacti to 0.8.8b,the Preview Mode Graphs will not display,like this
Attachment:
20130815232019.png
20130815232019.png [ 68.11 KiB | Viewed 3774 times ]

but when turn it on, the Graphs is ok
Attachment:
20130815232249.png
20130815232249.png [ 112.09 KiB | Viewed 3774 times ]

so what is the problem?


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Thu Aug 15, 2013 11:36 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
The bug is related to COMMENT handling and has been fixed.
Patch has been poted to the forum for testing, will attach here as well
R.


Attachments:
cacti088b_empty_comment.patch [2.56 KiB]
Downloaded 586 times

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository
Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Thu Aug 15, 2013 10:41 pm 
Offline

Joined: Thu Aug 15, 2013 10:16 am
Posts: 2
gandalf wrote:
The bug is related to COMMENT handling and has been fixed.
Patch has been poted to the forum for testing, will attach here as well
R.

Hi gandalf

When i use this patch , display error:
patch -p1 -N < cacti088b_empty_comment.patch
patching file rrd.php
Hunk #1 FAILED at 1343.
1 out of 1 hunk FAILED -- saving rejects to file rrd.php.rej

help :cry:


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Fri Aug 16, 2013 1:52 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Please post the reject file.
R.

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Sat Aug 17, 2013 10:39 am 
Offline

Joined: Sat Aug 17, 2013 9:47 am
Posts: 3
I have the same problem. Attached the .rej

Thanks in advance


Attachments:
rrd.php.rej.txt [2.42 KiB]
Downloaded 149 times
Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Sat Aug 17, 2013 1:04 pm 
Offline

Joined: Sat Aug 17, 2013 9:47 am
Posts: 3
The problem appears when activated Thumbnails.

Hows it could solve?

Thanks


Attachments:
cacti.jpg
cacti.jpg [ 30.66 KiB | Viewed 3727 times ]
Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Mon Aug 19, 2013 12:22 pm 
Offline

Joined: Sat Aug 17, 2013 9:47 am
Posts: 3
I SOLVED the problem by replacing the files from the links

http://svn.cacti.net/viewvc/cacti/branches/0.8.8/lib/rrd.php?view=markup&pathrev=7418
http://svn.cacti.net/viewvc/cacti/branches/0.8.8/rra.php?view=log


Thanks


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Mon Aug 19, 2013 9:52 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
a good move
R.

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Fri Aug 23, 2013 5:32 am 
Offline

Joined: Fri Aug 23, 2013 5:26 am
Posts: 8
Location: Paris, France
You saved my day . Thanx so much


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Sat Sep 14, 2013 6:43 am 
Offline
Cacti User

Joined: Fri Sep 19, 2008 10:14 am
Posts: 54
Location: UK
so why hasnt this path been intergrated into the release? its quite serious, are you going to leave the latest version buggy for months?


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Wed Sep 18, 2013 3:59 pm 
Offline

Joined: Wed Sep 18, 2013 2:18 am
Posts: 10
I just installed Cacti version Version 0.8.8b and seem to have a similar problem.

This only happens with "interface" templates.

All others display fine, but devices using the template Interface + Total Bandwidth are dead images. When I click on them they do work.

Is this the same bug?


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Thu Sep 19, 2013 2:50 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
The bug is related to some specific COMMENTs. Graph templates that don't use those will work
R.

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Mon Dec 23, 2013 7:54 pm 
Offline

Joined: Mon Dec 01, 2008 2:14 pm
Posts: 15
For anyone that finds this thread because you have the same problem (and have 0.8.8b installed), I have created a patch file.

Only use this patch if you have the original lib/rrd.php file (from 0.8.8b; md5sum=a8a2137537d9aa49aec468a373a59350) installed.

To apply patch (linux), SSH to your cacti server and change to the base cacti directory. Copy the attached file to this directory. Then, (assuming you have 'patch' installed) run:

Code:
patch -p0 -b < rrd.php.patch

The '-b' will create a backup copy of your original rrd.php file (patch will automatically name it 'rrd.php.orig'). In case things go awry after the patch is applied, you can reinstate the original file.

Note: it is important that you run the patch from the base cacti directory.

Use this patch at your own risk! I assume no liability if you hose your cacti installation.



Edit: added md5sum of original rrd.php file


Attachments:
rrd.php.patch [2.5 KiB]
Downloaded 355 times
Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Sat Mar 08, 2014 3:49 pm 
Offline

Joined: Sun Aug 25, 2013 2:10 am
Posts: 3
THANK YOU to sdavied for posting the patch file above. What some people may be missing that are relatively "novice" users of Cacti is how "exactly" to apply it.

If you installed the EZCacti use the Cacti WebAdmin at http://<ipaddress>:10000 in a web browser and go to the "Upload and download" topic on the left colum. Here is where you upload the patch to your server that sdavied uploaded earlier. Upload the patch file to the directory /var/www/html Remember this does not apply the patch, it only sends it to the server.

You can use the SSH tool in the WebAdmin that you just used, but I find it easier to go the terminal of your server either sitting right at it or by ssh. Issue the command cd /var/www/html and hit return. It should return to a prompt with html in it. Then type patch -p0 -b < rrd.php.patch and hit enter. This should return to the same html prompt that you were just at.....with no errors.

That's it. Go back to your Cacti webpage and do a page refresh and click on the "Thumbnails" checkbox and you will see your graphs again for the first time in months !

Just in case I attached sdavied file from a previous post.

Hope this helps a lot of people....it worked for me.

Gary


Attachments:
rrd.php.patch [2.5 KiB]
Downloaded 97 times
Top
 Profile  
 
 Post subject: Re: Cacti 0.8.8b Preview Mode Graphs bug ?
PostPosted: Thu Mar 13, 2014 8:26 pm 
Offline
Cacti User

Joined: Mon Oct 16, 2006 11:50 pm
Posts: 56
OK, applied the patch, restarted apache.

md5sum rrd*
dba8d5efb99b197f43cc321fd55e379f rrd.php
a8a2137537d9aa49aec468a373a59350 rrd.php.orig


where should i look now. In a previous port, some mentioned that rra.php needs updating too, tho this patch doesn't deal with that.

(picture attached)

brand new installation. opensuse 13.1. As can be seen i can't even prove data is being collected at this point.

also have a EZcacti 0.7 install that does the same thing.

H


Attachments:
File comment: picture of what i get
16A96A2526A0A6A1.jpg
16A96A2526A0A6A1.jpg [ 120.39 KiB | Viewed 1946 times ]

_________________
"The difference between theory and practice, is that in theory, there is no difference between theory and practice."

"The first 90% of a project takes 90% of the time, the last 10% takes the other 90% of the time" - Murphy's Law
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google Adsense [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group