Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Apr 23, 2017 6:39 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Error after upgrading cacti
PostPosted: Wed Mar 15, 2017 1:51 pm 
Offline

Joined: Wed Mar 15, 2017 1:36 pm
Posts: 1
Hello,

I'm try to upgrade from 0.8.8h to 1.0.4 and I'm have this error on /var/log/httpd/error_log:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:

PHP Warning: file_get_contents(/usr/share/cacti/mibs/CACTI-BOOST-MIB): failed to open stream: No such file or directory in /usr/share/cacti/lib/mib_parser.php on line 66, referer:

PHP Fatal error: Call to a member function row() on a non-object in /usr/share/cacti/lib/snmpagent.php on line 536, referer:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:

PHP Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /usr/share/cacti/lib/functions.php on line 636, referer:


Did anyone have idea what it is?

Thank you.


Top
 Profile  
 
 Post subject: Re: Error after upgrading cacti
PostPosted: Mon Mar 20, 2017 12:55 am 
Offline
Developer

Joined: Thu Apr 07, 2005 3:29 pm
Posts: 2517
Location: B/CS Texas
Not a Cacti issue for timezone stuff. You need to properly set the timezone in your php.ini.

As for
Quote:
PHP Warning: file_get_contents(/usr/share/cacti/mibs/CACTI-BOOST-MIB): failed to open stream: No such file or directory in /usr/share/cacti/lib/mib_parser.php on line 66, referer:

PHP Fatal error: Call to a member function row() on a non-object in /usr/share/cacti/lib/snmpagent.php on line 536, referer:

That looks like a permissions issue most likely.

_________________
CactiEZ CD


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group