Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Wed May 24, 2017 6:40 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 908 posts ]  Go to page Previous  1 ... 56, 57, 58, 59, 60, 61  Next
Author Message
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Fri Feb 24, 2017 3:35 am 
Offline

Joined: Wed Nov 23, 2016 2:42 am
Posts: 43
phalek wrote:
What exactly do you click where ?


Click on Cacti web interface, when i try to open new graphs. Nothing appear only blank screen on other menu too. Also I can not log out. This problem happen to me after upgrade to 1.0.0 too on other server.


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Fri Feb 24, 2017 3:32 pm 
Offline
Cacti User
User avatar

Joined: Tue May 03, 2005 4:29 pm
Posts: 163
Location: MD, US
Is there a place where I can download the rest of the templates that I have the option to install at the end of the install? I wanted to select all of them but every time I select more than one I get the attached error.

Thanks.


Attachments:
Template Import Timeout.PNG
Template Import Timeout.PNG [ 56.49 KiB | Viewed 2423 times ]
Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Mon Feb 27, 2017 4:32 am 
Offline

Joined: Wed Nov 23, 2016 2:42 am
Posts: 43
Thank you so much BSOD2600, for uploading this installer!


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Tue Feb 28, 2017 8:25 am 
Offline
Cacti User
User avatar

Joined: Tue May 03, 2005 4:29 pm
Posts: 163
Location: MD, US
When a new version of Cacti is released (like 1.0.4 for example) should we apply that on top of our existing Windows installs (Mine was installed using the 1.0.3 installer) or should we wait for BSOD to release a new version of the installer? Which is recommended? I've had mixed results with updating Cacti manually so I wanted to make sure.

Thanks.


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Fri Mar 03, 2017 1:16 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12115
Location: USA
Diggit2001 wrote:
When a new version of Cacti is released (like 1.0.4 for example) should we apply that on top of our existing Windows installs (Mine was installed using the 1.0.3 installer) or should we wait for BSOD to release a new version of the installer? Which is recommended?

Follow the Cacti Upgrade procedure (backup, replace updated files, upgrade, done). The installer is really only needed to bootstrap the semi-complicated configuration procedures and save users time and frustration.
http://docs.cacti.net/manual:100:1_inst ... ding_cacti

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Fri Mar 03, 2017 1:18 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12115
Location: USA
Diggit2001 wrote:
Is there a place where I can download the rest of the templates that I have the option to install at the end of the install? I wanted to select all of them but every time I select more than one I get the attached error.

Are you getting this with the latest 1.0.4 and/or github code?

https://github.com/Cacti/cacti/tree/dev ... /templates - is where you can get the templates from.
although would need to dig into the cacti setup wizard to see what CLI commands are ran to actually import them.

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Fri Mar 03, 2017 11:17 am 
Offline
Cacti User
User avatar

Joined: Tue May 03, 2005 4:29 pm
Posts: 163
Location: MD, US
BSOD2600 wrote:
Are you getting this with the latest 1.0.4 and/or github code?


I was using the 1.0.3 installer.

Thanks.


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.3] [Updated 2017-02-21]
PostPosted: Thu Mar 09, 2017 1:06 am 
Offline

Joined: Wed Nov 23, 2016 2:42 am
Posts: 43
All of my graph templates is not working at all even though RRD is working.
Anyone know why ?
My Graph is not generated at all.

Cacti Log : snmp2_get(): No response from devices xxx, : OID: xxx
PHP_errors : Nothing

Already tried to Verbouse Query for each devices but didnt solve the issue. What should I do next?
EDIT : Tried to upgrade to 1.0.4 also got same problem.
I am using Net-SNMP 5.5.0-2 (SNMPv2) and installer 1.0.3 from BSOD2600


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 0.8.8h] [Updated 2016-05-09]
PostPosted: Tue Mar 14, 2017 2:33 pm 
Offline

Joined: Mon Nov 30, 2015 11:00 am
Posts: 2
dalfaroc wrote:
Hello,

does someone have feedback about windows 10??

Thanks,


I've tried a few different times (even with different windows 10 builds/pcs) and was never able to get everything to work properly. Usually the installer will not complete when it gets to MySQL. When it does complete the install, it seems the poller will not actually run and no rrd's are every generated unless you do realtime - and that even is spotty. I tried back on 0.8.8 and most recently the 1.0.3 and 1.0.5 builds with the same results. I gave up on messing with it!


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.0.5] [Updated 2017-03-12]
PostPosted: Wed Apr 05, 2017 9:36 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12115
Location: USA
zetoo:
your issue is not with the installer. per the OP, create a separate post and outline your errors/details. it would appear the device is not correctly configured for snmp or a firewall possible blocking the traffic.

jwm1986:
what are the errors from the failed mysql install?

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.1.2] [Updated 2017-04-05]
PostPosted: Wed Apr 05, 2017 9:58 pm 
Offline

Joined: Wed Nov 23, 2016 2:42 am
Posts: 43
BSOD2600 wrote:
zetoo:
your issue is not with the installer. per the OP, create a separate post and outline your errors/details. it would appear the device is not correctly configured for snmp or a firewall possible blocking the traffic.

jwm1986:
what are the errors from the failed mysql install?


Currently I am using SNMP Agent from Windows by disabling SNMP module from PHP and got no timeout response again in clog.
Did I do the right thing? :o

Well I can snmpwalk my devices so its suppose to be configured but for firewall .. I dont know which one I need to enable except for SNMP Services which enabled from installation.\

EDIT : I did create a post but in the General section :D

Link : Graph is not populated and mail reporting is not working


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.1.2] [Updated 2017-04-05]
PostPosted: Fri Apr 07, 2017 8:31 am 
Offline

Joined: Thu Apr 06, 2017 4:40 pm
Posts: 1
MySQL is failing to install, please see install log attached, I can't seem to find any relevant logs as to why this is happening

*Server 2008 R2


Attachments:
cacti-installer.txt [147.94 KiB]
Downloaded 25 times
Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.1.2] [Updated 2017-04-05]
PostPosted: Tue Apr 11, 2017 12:33 pm 
Offline

Joined: Tue Apr 11, 2017 12:21 pm
Posts: 3
Same to me, running the 1.1.12 installer and it end-up with installing mySQL 5.7.17

When i try to start the mySQL service (with the default credentials of even as Administrator) it fails. (and the event log is filled with logging and 3 errors)
seems the installer waits for the startup of mySQL, but it's waiting forever .....

Running on Server 2016 (Clean install)


Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.1.2] [Updated 2017-04-05]
PostPosted: Tue Apr 11, 2017 4:11 pm 
Offline

Joined: Fri Nov 21, 2014 12:49 pm
Posts: 2
Hi,

I also experienced issues with the Cacti v1.05 installer hanging during installation of MySQL 5.7. However, I managed to resolve the problem by deleting a few files.

MySQL files remained on the system after running either the cacti or MySQL uninstaller, and the installation would not proceed until they were gone. For me, the residual was found in C:\Program Data\MySQL and C:\Program Files\MySQL. Deleting these two folders manually cleared up the issue for me.

Windows 2012 R2


PLEASE NOTE
-------------------------------------
Backup the files in C:\Program Data\MySQL\ before doing this. Your MySQL databases live in this location.


Last edited by Phoenix54c on Thu Apr 13, 2017 9:36 am, edited 2 times in total.

Top
 Profile  
 
 Post subject: Re: Windows Installer [Cacti 1.1.2] [Updated 2017-04-05]
PostPosted: Wed Apr 12, 2017 5:20 am 
Offline

Joined: Tue Apr 11, 2017 12:21 pm
Posts: 3
after some testing and checking logfiles: there's a work around:

Run the Cacti installer, in my case the Cacti-1.1.2-3.2.0.0.exe
The installer runs until [Initializing Databse [if necessary] and wait until the mySQL db is available > so waiting forever :-|

to continue the installation:
1) delete the content in C:\ProgramData\MySQL\MySQL Server 5.7\Data
2) remove (place # in front of if) of all lines starting with innodbcluster in the configfile C:\ProgramData\MySQL\MySQL Server 5.7\my.ini
3) run (CMD) the following command again : "C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe" --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.7\my.ini" --initialize-insecure=on --console
4) start manually the mysql service

... and the installer continues and finish :-)

usefull log: C:\ProgramData\MySQL\MySQL Installer for Windows\Logs\Administrator installer.log


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 908 posts ]  Go to page Previous  1 ... 56, 57, 58, 59, 60, 61  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group