Cacti (home)ForumsRepositoryDocumentation
Cacti: offical forums and support
It is currently Fri Oct 31, 2014 2:36 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Occasionally missing thumbnail graph title in preview mode
PostPosted: Thu Dec 01, 2011 11:37 am 
Offline

Joined: Thu Nov 03, 2011 8:29 am
Posts: 3
Can anybody help me? This is not a big issue, however it's pretty annoying. Occasionally in the preview mode, some thumbnail graphs don't show the graph title; if I click the thumbnail to show all the rra graphs, everything is fine. If I refresh the page, the missing graph title might be back, however other thumbnails may lose their titles.

It seems the width of the thumbnail graph with missing title is always shorter(439 x 266) than normal graphs (503 x 266), if I copy the image link directly to the address bar of the browser, the graph is correctly displayed with the title and correct size.

Please check the attachment for the screenshot. You generous help is highly appreciated.

Windows XP+ Cygwin+ Apache2.2

Technical Support :
General Information
Date Thu, 01 Dec 2011 11:09:50 -0500
Cacti Version 0.8.7h
Cacti OS win32
SNMP Version NET-SNMP version: 5.5.1
RRDTool Version RRDTool 1.2.x
Hosts 15
Graphs 63
Data Sources Script/Command: 107
Total: 107
Poller Information
Interval 60
Type cmd.php
Items Action[1]: 35
Total: 35
Concurrent Processes 15
Max Threads 12
PHP Servers 10
Script Timeout 25
Max OID 10
Last Run Statistics Time:6.8080 Method:cmd.php Processes:15 Threads:N/A Hosts:11 HostsPerProcess:1 DataSources:35 RRDsProcessed:35
PHP Information
PHP Version 5.3.8
PHP OS WINNT
PHP uname Windows NT TSTOBLAM9230 5.1 build 2600 (Windows XP Professional Service Pack 3) i586
PHP SNMP Not Installed
max_execution_time 30
memory_limit 512M

Screenshot:
The thumbnail on the right upper corner didn't show the graph title. It is using the same graph template as the below thumbnail.


Attachments:
thumbnail.PNG
thumbnail.PNG [ 43.56 KiB | Viewed 832 times ]
Top
 Profile  
 
 Post subject: Re: Occasionally missing thumbnail graph title in preview mo
PostPosted: Thu Dec 01, 2011 1:49 pm 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 11382
Location: USA
What rrdtool version/build?
This type of problem also was caused by php in the past. what build of php are you using?

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: Occasionally missing thumbnail graph title in preview mo
PostPosted: Thu Dec 01, 2011 2:18 pm 
Offline

Joined: Thu Nov 03, 2011 8:29 am
Posts: 3
Thanks BSOD.
php version is 5.3.8 thread-safe.

rrdtool win32 version is 1.2.30:
RRDtool 1.2.30 Copyright 1997-2008 by Tobias Oetiker <tobi@oetiker.ch>
Compiled Jan 20 2009 01:39:35

BSOD2600 wrote:
What rrdtool version/build?
This type of problem also was caused by php in the past. what build of php are you using?


Top
 Profile  
 
 Post subject: Re: Occasionally missing thumbnail graph title in preview mo
PostPosted: Thu Dec 01, 2011 2:43 pm 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 11382
Location: USA
You're not the first person I've seen lately with this issue unfortunately. You already found rdege's thread which your exact software config and issue. Since rrdtool 1.2.30 win32 build has been stable for quite a while, I'm starting to wonder if its PHP.

You up for reverting PHP back to 5.2.17 and see if the issues persist?

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group