Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon May 22, 2017 2:34 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Server Shutdown - Cacti No Longer Working
PostPosted: Sun Jul 31, 2016 9:30 am 
Offline
Cacti User
User avatar

Joined: Tue May 03, 2005 4:29 pm
Posts: 163
Location: MD, US
Hello. I am running Cacti on a Windows 7 box and have had it up and running for several years. Last night we had some storms roll through and we lost power for longer than the UPS's could keep the load up. As a result, my Cacti box shut down. When I boot it up now, the Cacti site is no longer accessible and it appears to be an issue with PHP. When I try to hit the site locally, I get this:

HTTP Error 500.0 - Internal Server Error

C:\php\php-cgi.exe - The FastCGI process exited unexpectedly

Module FastCgiModule

Notification ExecuteRequestHandler

Handler PHP-FastCGI

Error Code 0x000000ff

Requested URL http://localhost:80/cacti/index.php

Physical Path C:\inetpub\wwwroot\cacti\index.php

Logon Method Anonymous

Logon User Anonymous

I get the same error when I try to launch my phpinfo.php file.

Obviously something got corrupt, I'm just not sure how to fix it. Any assistance would be much appreciated.


Top
 Profile  
 
 Post subject: Re: Server Shutdown - Cacti No Longer Working
PostPosted: Thu Aug 04, 2016 1:43 am 
Offline
Cacti Moderator
User avatar

Joined: Sat May 08, 2004 12:44 pm
Posts: 12115
Location: USA
run chkdsk c: /f ?
php -m have any errors?
anything in windows event logs?

_________________

| Scripts: Monitor processes | RFC1213 MIB | DOCSIS Stats | Dell PowerEdge | Speedfan | APC UPS | DOCSIS CMTS | 3ware | Motorola Canopy |
| Guides: Windows Install | [HOWTO] Debug Windows NTFS permission problems |
| Tools: Windows All-in-one Installer |


Top
 Profile  
 
 Post subject: Re: Server Shutdown - Cacti No Longer Working
PostPosted: Thu Aug 04, 2016 8:59 am 
Offline
Cacti User
User avatar

Joined: Tue May 03, 2005 4:29 pm
Posts: 163
Location: MD, US
Chkdsk came back fine but I did see a lot of errors in my server App log mentioning php_snmp.dll so for kicks, I commented out that line under extensions in my php.ini file and Cacti started working again. I figured that was probably a pretty important component but everything appears to be working, as far as I can tell. Any idea how to get that extension working again?

The only thing I see now in my server log is one of these about 10 times a minute:

C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqld.exe: The table 'data_source_stats_hourly_cache' is full

Thanks.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group