Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Jun 23, 2017 8:41 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: PHP Error?
PostPosted: Fri Dec 16, 2016 1:02 pm 
Offline

Joined: Fri Dec 16, 2016 12:53 pm
Posts: 2
Hello,
I am totally new to Cacti, Ive followed the instructions for 0.8.8h by installing
Apache
PHP
RDDTool
MySql
Cacti

When I fire up cacti url localhost/cacti I get a list of topic for php one of them maybe 25 down is index.php which I can click on but nothing if formatted correcty, Im presuming I have a issue with my configuration of php?

when i run the test I get the following

C:\Windows\system32>php -m
PHP: syntax error, unexpected '=' in C:\PHP\php.ini on line 1488
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\php\ext\php_mysql.
dll' - The specified module could not be found.
in Unknown on line 0
MIB search path: c:\PHP\Extras\mibs
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (HOST-RESOURCES-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (SNMPv2-SMI): At line 0 in (none)
Cannot find module (NOTIFICATION-LOG-MIB): At line 0 in (none)
Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
Cannot find module (NET-SNMP-AGENT-MIB): At line 0 in (none)
Cannot find module (DISMAN-EVENT-MIB): At line 0 in (none)
Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
Cannot find module (SNMPv2-TM): At line 0 in (none)
[PHP Modules]
bcmath
calendar
Core
ctype
date
dom
filter
gd
hash
iconv
json
ldap
libxml
mcrypt
mysqli
mysqlnd
pcre
PDO
Phar
readline
Reflection
session
SimpleXML
snmp
sockets
SPL
standard
tokenizer
wddx
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]


C:\Windows\system32>

I believe I have uncommented and amended what is discussed, but I could well be wrong. Could someone please offer me some advice to get me going.

Ive added my php config file and a screenshot.

Thank you.


Attachments:
error.GIF
error.GIF [ 91.14 KiB | Viewed 1118 times ]
Top
 Profile  
 
 Post subject: Re: PHP Error?
PostPosted: Sat Dec 17, 2016 12:04 am 
Offline
Developer

Joined: Thu Apr 07, 2005 3:29 pm
Posts: 2562
Location: B/CS Texas
swilt170571 wrote:
C:\Windows\system32>php -m
PHP: syntax error, unexpected '=' in C:\PHP\php.ini on line 1488
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\php\ext\php_mysql.
dll' - The specified module could not be found.
in Unknown on line 0
That shows that you have an error in your php.ini file. Fix that first. Also it looks like PHP module for MySQL may not be installed.


swilt170571 wrote:
When I fire up cacti url localhost/cacti I get a list of topic for php one of them maybe 25 down is index.php which I can click on but nothing if formatted correcty, Im presuming I have a issue with my configuration of php?
It doesn't seem like you properly configured Apache to use PHP.

_________________
CactiEZ CD


Top
 Profile  
 
 Post subject: Re: PHP Error?
PostPosted: Sun Dec 18, 2016 6:34 am 
Offline

Joined: Fri Dec 16, 2016 12:53 pm
Posts: 2
Thanks for the response,

Ive downloaded another version of PHP I think I downloaded wrong version and now no errors on mysql etc but still same issue.

Reading the documentation Im pretty sure I am still using wrong download versions for
php
apache

My systems is Windows 32bit.

It talks about NOT using PHP5.6 as that does not work with CACTI but im struggling to ensure I have threaded version of 5.5?

Also I notice some talk of using a different compiled version for Apache.

If you have 5 minutes and you obviously know what your doing if you stumble across the correct download links whilst I carry on googling around it would really be appreciated

Thank you


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group