Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Jun 23, 2017 8:47 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: routerconfigs on Windows 7 PC
PostPosted: Mon Mar 13, 2017 4:12 am 
Offline

Joined: Mon Mar 13, 2017 3:35 am
Posts: 1
Hi Everyone
need some assistance / advice please

I have installed CACTI using the installer package Cacti-0.8.8h.
CACTI is running on a Windows 7 Pro machine.
CACTI itself is working, but I can't get routerconfigs to download the running-config from a Cisco Catalyst switch.

- at first I couldn't add any devices in routerconfigs, fixed that by editing my.ini
- in folder C:\ProgramData\MySQL\MySQL Server 5.6
- remarked STRICT mode
- # sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
- stop / start mysql service

Installed Solarwinds TFTP server and set tftp directory to "C:\Apache24\htdocs\cacti\plugins\routerconfigs\backups" in solarwinds program

The routerconfigs plugin is installed and enabled
In CACTI under settings ... Misc ... server ip and backup directory patch has been set (same path and tftp server folder)
- backup directory path : C:/Apache24/htdocs/cacti/plugins/routerconfigs/backups
- REALM permissions have been set fort Plugin-> Router Configs

Here is what I have tried to do to get it working
- In folder "C:\Apache24\htdocs\cacti\plugins\routerconfigs\tftp-config-file\etc\xinetd.d"
- edit tftp file and change to : server_args = -c -s /home/htdocs/cacti/plugins/routerconfigs/backups
- before changing : server_args = -c -s /home/configs/backups

There are no errors in the log when I try to run the config download

I have searched the internet but don't find any information to get this working on Windows 7.

Can anyone give me advice on what else to do please
Thank you


Attachments:
cacti-routerconfigs-settings.jpg
cacti-routerconfigs-settings.jpg [ 154.03 KiB | Viewed 325 times ]
Top
 Profile  
 
 Post subject: Re: routerconfigs on Windows 7 PC
PostPosted: Tue Mar 14, 2017 11:08 am 
Offline
Cacti User

Joined: Mon Sep 10, 2012 5:54 pm
Posts: 60
For the device type you have selected, there is a field in the database table "plugin_routerconfigs_devicetypes" called "copytftp". Whatever is in that field value is what the plugin sends the device to run as a command. Typically on Cisco devices that command is "copy start tftp".

The first thing to ensure is that you can run that command manually from the router before you assume the issue is with the plugin configuration. If you are not successfully pushing backups by manually running the command, the plugin will not either.

On the device tab, there is an action icon named "Router Debug Info" which will display the console output when a backup is attempted. This output is useful for troubleshooting individual devices that are failing to complete.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group