Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Jun 23, 2017 10:24 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: Error during Cacti Installation Wizard
PostPosted: Sat Apr 15, 2017 7:07 am 
Offline

Joined: Thu Mar 23, 2017 11:50 pm
Posts: 5
Hi All,

I am getting error during Cacti Installation Wizard, I have attached screenshot, Please help me to fix it.

Thanks,
Shailu2014

1. ERROR: Your MySQL TimeZone database is not populated. Please populate this database before proceeding.

2.version 5.5.52-MariaDB >= 5.6 MySQL 5.6+ and MariaDB 10.0+ are great releases, and are very good versions to choose. Make sure you run the very latest release though which fixes a long standing low level networking issue that was casuing spine many issues with reliability.

3. max_heap_table_size 16M >=88M If using the Cacti Performance Booster and choosing a memory storage engine, you have to be careful to flush your Performance Booster buffer before the system runs out of memory table space. This is done two ways, first reducing the size of your output column to just the right size. This column is in the tables poller_output, and poller_output_boost. The second thing you can do is allocate more memory to memory tables. We have arbitrarily chosen a recommended value of 10% of system memory, but if you are using SSD disk drives, or have a smaller system, you may ignore this recommendation or choose a different storage engine. You may see the expected consumption of the Performance Booster tables under Console -> System Utilities -> View Boost Status.


Attachments:
cacti-3.PNG
cacti-3.PNG [ 21.33 KiB | Viewed 1615 times ]
cacti-2.PNG
cacti-2.PNG [ 111.86 KiB | Viewed 1615 times ]
cacti-1.PNG
cacti-1.PNG [ 28.06 KiB | Viewed 1615 times ]
Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Sun Apr 23, 2017 6:28 pm 
Offline
Cacti User
User avatar

Joined: Mon Jan 05, 2015 10:10 am
Posts: 302
By now you should have figured it out right?

_________________
Before history, there was a paradise, now dust.


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Thu Apr 27, 2017 7:57 am 
Offline

Joined: Thu Apr 27, 2017 7:43 am
Posts: 7
Hi all,

I'm currently having the same issue than shailu. I'm trying to install Cacti on CentOS 7 with the last Cacti release (1.1.5), and I'm having the exact same issue.

Here are some screeshots attached.

Attachment:
cacti1.PNG
cacti1.PNG [ 46.29 KiB | Viewed 934 times ]


Attachment:
cacti2.PNG
cacti2.PNG [ 70.52 KiB | Viewed 934 times ]


Attachment:
cacti3.PNG
cacti3.PNG [ 74.06 KiB | Viewed 934 times ]


I guess the first error is just a connexion issue to the database so I'm going to check that.

I then checked the last Mariadb version doing a "yum install mariadb updateinfo" and it says 5.5.52 is the last version.

Can you please help me guys ?

Thank you very much :)


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Thu Apr 27, 2017 8:14 am 
Offline

Joined: Wed Apr 26, 2017 4:35 am
Posts: 17
Hi,

I'm new as user cacti but I had this problem.
For the configuration of mysql and all your error, you need to parameterize by hand my.cnf in /etc like my attachment.
For your first error of timezone, i continues to seek in my memori because i had the same error but forgot the solution

I hope this info will help you

edit :
For the timezone, you can test that :
cd /usr/share/mysql
mysql -u root mysql < mysql_test_data_timezone.sql
and then log in mysql and write (don't forget flush privilege at the end)
GRANT SELECT ON mysql.time_zone_name TO cactiuser@localhost

I'm really not sure but it seems to me that it worked for me


Attachments:
Capture3.JPG
Capture3.JPG [ 57.98 KiB | Viewed 930 times ]
Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Thu Apr 27, 2017 10:00 am 
Offline

Joined: Thu Apr 27, 2017 7:43 am
Posts: 7
Hi tyrr,

Thank you very much for your help.
First, I upgraded the version of MariaDB. I followed that tutorial where that is pretty well explained : http://www.tecmint.com/upgrade-mariadb-5-5-to-10-centos-rhel-debian-ubuntu/

Then, I installed again these packages :

# yum install php-mysql
# yum install php-pdo

Finally, I followed your advice. I edited the /etc/my.cnf file and I added what you just wrote down.

For the TimeZone issue, I changed the /etc/php.ini file. You normally have :

[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
;date.timezone =


That part was empty for me. I uncommented the line ";date.timezone = " and changed it :

date.timezone = Europe/Paris


Now I have to find out how to populate that Timezone.

Thank you very much for your time, hope that will help some people :)


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Thu Apr 27, 2017 2:35 pm 
Offline

Joined: Thu Mar 23, 2017 11:50 pm
Posts: 5
Hi Stefey & tyrr,

I followed same steps which mentioned and edited the /etc/my.cnf file and I added line which mentioned below (Screenshot attached)

#
# This group is read both both by the client and the server
# use it for options that affect everything
#
[client-server]

#
# include all files from the config directory
#
!includedir /etc/my.cnf.d

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
character_set_server = utfs
max_heap_table_size = 98M
max_allowed_packet = 16777216
tmp_table_size = 64M
join_buffer_size = 64M
innodb_file_per_table = ON
innodb_buffer_pool_size = 1024M
innodb_doublewrite = OFF
innodb_additional-mem-pool-size = 80M
innodb_flush_log_at_timeout = 3
innodb_read_io_threads = 32
innodb_write_io_threads = 16

Symbolic_links=0

[mysqld_safe]
log-error=/var/log/mariadb/mariadb.log
pid-file=/var/run/mariadb/mariadb.pid


After that I started the mariadb services and then i refresh the browser and got the below error

FATAL: Connection to Cacti database failed. Please insure the database is running and your credentials in config.php are valid.



Please let me know where is the issue during edit the file (/etc/my.cnf)

Thanks,
Shailu


Attachments:
Error-Cacti.PNG
Error-Cacti.PNG [ 26.18 KiB | Viewed 903 times ]
Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Fri Apr 28, 2017 3:22 am 
Offline

Joined: Thu Apr 27, 2017 7:43 am
Posts: 7
Hi shailu,

- What is your linux distro ?
- Is the service mariadb running or it failed when you restarted it ?
- Have you correctly filled in your database's information in the include/config.php file ?

In addition to that, when you uninstalled the old version of MariaDB, did you make a backup of the database, and have you imported it again ?
If not, it won't work, and you maybe will to have to create the database again, and import cacti.sql again in your database.

Please let me know so that I try to help you a bit more.


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Fri Apr 28, 2017 3:26 am 
Offline

Joined: Thu Apr 27, 2017 7:43 am
Posts: 7
You can also do a :

# tail -f /var/log/httpd/error_log

And check if there is something wrong. You can write down the output here.


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Fri Apr 28, 2017 5:34 am 
Offline

Joined: Thu Mar 23, 2017 11:50 pm
Posts: 5
Hi Stefey,

- I am using Centos-7 OS in Vmware.

- I have direct installed New Version of MariaDB by below link, so i don't require the data backup.
http://www.tecmint.com/install-mariadb-in-centos-7/

- mariadb Version mentioned below-
# mysql -V
mysql Ver 15.1 Distrib 10.1.22-MariaDB, for Linux (x86_64) using readline 5.1



- database's information in the include/config.php file working before edit the my.cnf file,

- after edit my.cnf file restart the MariaDB service it's giving error mentioned below.
# systemctl restart mariadb
Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.


- Sending the logs of httpd


# tail -f /var/log/httpd/error_log (result)
# tail -f /var/log/httpd/error_log
[Fri Apr 28 00:27:09.187956 2017] [mpm_prefork:notice] [pid 895] AH00163: Apache/2.4.6 (CentOS) PHP/5.4.16 configured -- resuming normal operations
[Fri Apr 28 00:27:09.188020 2017] [core:notice] [pid 895] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
[Fri Apr 28 00:28:04.627916 2017] [autoindex:error] [pid 2237] [client 192.168.81.1:51414] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive
[Fri Apr 28 00:29:25.297590 2017] [mpm_prefork:notice] [pid 895] AH00170: caught SIGWINCH, shutting down gracefully
[Fri Apr 28 00:29:55.725249 2017] [suexec:notice] [pid 891] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::20c:29ff:fe8c:81d. Set the 'ServerName' directive globally to suppress this message
[Fri Apr 28 00:29:56.252330 2017] [auth_digest:notice] [pid 891] AH01757: generating secret for digest authentication ...
[Fri Apr 28 00:29:56.252681 2017] [lbmethod_heartbeat:notice] [pid 891] AH02282: No slotmem from mod_heartmonitor
[Fri Apr 28 00:29:59.727812 2017] [mpm_prefork:notice] [pid 891] AH00163: Apache/2.4.6 (CentOS) PHP/5.4.16 configured -- resuming normal operations
[Fri Apr 28 00:29:59.727937 2017] [core:notice] [pid 891] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

Please let me know where is the issue....

Thanks,
Shailu


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Mon May 01, 2017 8:14 am 
Offline

Joined: Fri Feb 10, 2017 2:45 pm
Posts: 40
What is the location of your Cacti install? Apache should be pointing to that.


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Thu Jun 08, 2017 4:03 am 
Offline

Joined: Fri Jun 02, 2017 5:09 am
Posts: 2
shailu2014 wrote:
Hi Stefey & tyrr,

I followed same steps which mentioned and edited the /etc/my.cnf file and I added line which mentioned below (Screenshot attached)

#
# This group is read both both by the client and the server
# use it for options that affect everything
#
[client-server]

#
# include all files from the config directory
#
!includedir /etc/my.cnf.d

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
character_set_server = utfs
max_heap_table_size = 98M
max_allowed_packet = 16777216
tmp_table_size = 64M
join_buffer_size = 64M
innodb_file_per_table = ON
innodb_buffer_pool_size = 1024M
innodb_doublewrite = OFF
innodb_additional-mem-pool-size = 80M
innodb_flush_log_at_timeout = 3
innodb_read_io_threads = 32
innodb_write_io_threads = 16

Symbolic_links=0

[mysqld_safe]
log-error=/var/log/mariadb/mariadb.log
pid-file=/var/run/mariadb/mariadb.pid


After that I started the mariadb services and then i refresh the browser and got the below error

FATAL: Connection to Cacti database failed. Please insure the database is running and your credentials in config.php are valid.



Please let me know where is the issue during edit the file (/etc/my.cnf)

Thanks,
Shailu


Can you share fix this issue? Thanks :)


Top
 Profile  
 
 Post subject: Re: Error during Cacti Installation Wizard
PostPosted: Thu Jun 08, 2017 7:21 am 
Offline

Joined: Wed Jul 08, 2015 8:48 am
Posts: 16
Hi, for Ubuntu i had the same error about Timezone populate.
I fixed it editing this.

root@akenaton:/usr/share/mysql# nano /etc/mysql/conf.d/mysql.cnf

Here i added

[mysql]
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = America/Montevideo

Then i restart the mysql server

root@akenaton:/usr/share/mysql# /etc/init.d/mysql restart
[ ok ] Restarting mysql (via systemctl): mysql.service.
root@akenaton:/usr/share/mysql#

It s works!

Thanks.
Regars..

Diego


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group