Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue May 23, 2017 1:44 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Cacti & php 7 on Centos 7.1
PostPosted: Thu Dec 10, 2015 5:05 pm 
Offline

Joined: Fri Jul 24, 2009 10:29 pm
Posts: 2
Hi,
I have been playing with PHP and the Cacti latest development code on a system. I thought I would share my results.

Cacti 0.8.x running on php7 does not work. There are several adodb related errors, due to changes in the language. Dropping in the latest stable adodb does not resolve the database issues, as there are calls to deprecated instructions (mysql_pconnect).

As far as the web interface goes, the latest Cacti development code does work. I had to do some minor tweaks, but after installation, everything is running as expected.

OS: CentOS 7.1 (Linux daisy.example.com 3.10.0-229.20.1.el7.x86_64 #1 SMP Tue Nov 3 19:10:07 UTC 2015 x86_64), up-to-date.
Apache/PHP version: Apache/2.4.6 (CentOS) mod_auth_kerb/5.4 mod_wsgi/3.4 Python/2.7.5 PHP/7.0.0

All client devices are using SNMPv3, with AuthPriv (SHA/AES)

PHP7.0 is from the remi repository, http://blog.remirepo.net/post/2015/03/25/PHP-7.0-as-Software-Collection

Tweaks:
cacti.sql:
I commented out line 289 as the number of values does not match the number of columns. I have not had a chance to investigate this further.
  • Code:
    # INSERT INTO `automation_networks` VALUES (1,0,'Test Network','192.168.1.0/24','','on',1,254,14,8,2,22,400,1,2,10,1200,'2015-05-17 16:15','0000-00-00 00:00:00',2,'4','1,2,6','1,2,3,4,6,7,11,12,14,15,17,19,26,32','','',40.178689002991,'2015-05-19 02:23:22','','on');
  • Lines 3682 & 3683, add a '1' to each line, as the number of values does not match the columns. The 1 should be inserted between column 12 and column 15. This will allow the initial user accounts (admin & guest) to be generated
include/config.php.dist
  • Line 45. missing trailing '/' to close the comments
automation_networks.php
  • line 844: s/Dene/Done

I have not set up polling as it breaks my normal cacti polling. I will do so later and report in.

Edit: grammar cleanup.


Top
 Profile  
 
 Post subject: Re: Cacti & php 7 on Centos 7.1
PostPosted: Sun Dec 20, 2015 5:37 pm 
Offline
Developer
User avatar

Joined: Thu Feb 20, 2003 10:16 am
Posts: 1635
Location: Canada
Quote:
cacit.sql: Lines 3682 & 3683, add a '1' to each line, as the number of values does not match the columns. The 1 should be inserted between column 12 and column 15. This will allow the initial user accounts (admin & guest) to be generated


Fixed

Quote:
include/config.php.dist Line 45. missing trailing '/' to close the comments


Fixed

Quote:
automation_networks.php line 844: s/Dene/Done


Fixed

https://github.com/Cacti/cacti/commit/c ... fc23141955

_________________
--
Live fast, die young
You're sucking up my bandwidth.

J.P. Pasnak,CD
CCNA, LPIC-1
http://www.warpedsystems.sk.ca


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group