Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sat Mar 25, 2017 12:40 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: SQL errors for poller
PostPosted: Thu May 19, 2016 3:00 am 
Offline

Joined: Wed Nov 14, 2012 10:11 am
Posts: 7
Hello

Using the git version, I got some errors during poller:

05/19/2016 07:45:01 AM - CMDPHP ERROR: SQL Assoc Failed!, Error:1054, SQL:"SELECT SQL_NO_CACHE id FROM host WHERE poller_id=0 AND disabled='' ORDER BY id"
05/19/2016 07:45:01 AM - CMDPHP ERROR: SQL Assoc Failed!, Error: Unknown column 'poller_id' in 'where clause'
05/19/2016 07:45:01 AM - CMDPHP SQL Backtrace: (/poller.php: 246 db_fetch_assoc)(/lib/database.php: 282 db_fetch_assoc_prepared)(/lib/database.php: 321 cacti_debug_backtrace)
05/19/2016 07:45:01 AM - CMDPHP ERROR: SQL Cell Failed!, Error:1054, SQL:"SELECT COUNT(*) FROM host WHERE poller_id = ?"
05/19/2016 07:45:01 AM - CMDPHP ERROR: SQL Cell Failed!, Error: Unknown column 'poller_id' in 'where clause'
05/19/2016 07:45:01 AM - CMDPHP SQL Backtrace: (/cmd.php: 181 db_fetch_cell_prepared)(/lib/database.php: 220 cacti_debug_backtrace)
05/19/2016 07:45:01 AM - POLLER: Poller[0] FATAL: No hosts matching this poller exist on the system

How can I upgrade the database when the git is updated?

Thanks


Top
 Profile  
 
 Post subject: Re: SQL errors for poller
PostPosted: Thu May 19, 2016 11:28 am 
Offline
Cacti User
User avatar

Joined: Wed Feb 03, 2016 3:38 pm
Posts: 261
ouafnico wrote:
Hello

How can I upgrade the database when the git is updated?

Thanks


You dont. You can drop the database, and then reinstall it.


Top
 Profile  
 
 Post subject: Re: SQL errors for poller
PostPosted: Fri May 20, 2016 12:41 am 
Offline

Joined: Wed Nov 14, 2012 10:11 am
Posts: 7
ok... but I will loose my configuration :s


Top
 Profile  
 
 Post subject: Re: SQL errors for poller
PostPosted: Wed Jun 01, 2016 5:40 am 
Offline
Cacti User
User avatar

Joined: Wed Feb 03, 2016 3:38 pm
Posts: 261
ouafnico wrote:
ok... but I will loose my configuration :s


Yes, but its only for development now. Im guessing the following releases 1.1 etc will have an update script just like before.

If there is a specific config you want to keep you can export it and then import it again after schema change.

Or you can diff the schemas and alter the changes manually.

Its a bit tricky now but there is to many changes being made currently.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group