Cacti (home)ForumsRepositoryDocumentation
Cacti: offical forums and support
It is currently Wed Apr 16, 2014 2:14 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Polling twice?
PostPosted: Mon Feb 20, 2012 4:11 pm 
Offline

Joined: Thu Dec 01, 2011 8:54 am
Posts: 20
Location: West Lafayette, Indiana
Cacti 0.8.7i polling with cmd.php every minute with 10 processes

When looking at Cacti logfile it appears that polling is happening twice in a 60 second window. One completes in about 5 seconds and one in about 25 seconds:

02/20/2012 04:08:09 PM - SYSTEM THOLD STATS: Time:2.0177 Tholds:278 DownHosts:0
02/20/2012 04:08:07 PM - SYSTEM STATS: Time:5.3997 Method:cmd.php Processes:10 Threads:N/A Hosts:85 HostsPerProcess:9 DataSources:2853 RRDsProcessed:882
02/20/2012 04:07:28 PM - SYSTEM THOLD STATS: Time:1.7841 Tholds:278 DownHosts:0
02/20/2012 04:07:26 PM - SYSTEM STATS: Time:24.7145 Method:cmd.php Processes:10 Threads:N/A Hosts:85 HostsPerProcess:9 DataSources:2853 RRDsProcessed:882

I can't imagine that this is right. Can anyone suggest where to begin troubleshooting this?


Top
 Profile  
 
 Post subject: Re: Polling twice?
PostPosted: Tue Feb 21, 2012 8:25 am 
Offline

Joined: Thu Dec 01, 2011 8:54 am
Posts: 20
Location: West Lafayette, Indiana
Update:

I've installed Spine and have the same issue. According to my scheduled cron jobs in Webmin I have one command running every 60 seconds:

/usr/bin/php /var/www/html/cacti/poller.php > /dev/null 2>&1


Top
 Profile  
 
 Post subject: Re: Polling twice?
PostPosted: Wed Feb 22, 2012 3:17 am 
Offline
Cacti Guru User

Joined: Thu Aug 05, 2010 2:04 am
Posts: 1573
Location: Japan
I think it's not so big problem..
Your poller started at every minute, and finished within 60 seconds.


Top
 Profile  
 
 Post subject: Re: Polling twice?
PostPosted: Wed Feb 22, 2012 8:16 am 
Offline

Joined: Thu Dec 01, 2011 8:54 am
Posts: 20
Location: West Lafayette, Indiana
Where I was concerned was that it ran two pollers in that one minute window. I changed the Maximum Concurrent Poller Processes to '1' and that resolved the problem. I also adjusted the spine specific parameters to increase the Maximum Threads per Process to 50, Number of PHP Script Servers to 10, Script and Script Server Timeout Value to 40, and The Maximum SNMP OID's Per SNMP Get Request to 100. I've not seen a "best practices" guide but the poller completes in about 24 seconds. Is thaht normal even for using spine?

SYSTEM STATS: Time:23.2544 Method:spine Processes:1 Threads:50 Hosts:84 HostsPerProcess:84 DataSources:2766 RRDsProcessed:867


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group