Microsoft IIS current connection template

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
dagonet
Cacti User
Posts: 89
Joined: Sat Oct 29, 2005 4:05 pm
Location: Wuerzburg

Microsoft IIS current connection template

#1 Post by dagonet » Sun Oct 30, 2005 4:01 pm

Hi community,

another template from me.

Dagonet.
Attachments
cacti_graph_template_iis_http_current_connections.xml
Shows the current connections of a MS IIS server.
(9.54 KiB) Downloaded 5320 times

stevewest15
Posts: 9
Joined: Tue Oct 25, 2005 1:09 pm

#2 Post by stevewest15 » Tue Nov 01, 2005 12:39 am

great job...Thanks!

ollid
Posts: 2
Joined: Mon Aug 29, 2005 8:12 am

#3 Post by ollid » Tue Nov 08, 2005 3:23 am

I tried to import the template. But i got an error: Error: XML: Hash version does not exist.

Whats wrong?

hapklaar
Posts: 38
Joined: Tue May 31, 2005 10:06 am

#4 Post by hapklaar » Wed Nov 09, 2005 5:27 pm

same here, haven't been able to figure out what's wrong as well.

Running Cacti Version 0.8.6f on linux

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

#5 Post by BSOD2600 » Wed Nov 09, 2005 8:49 pm

Both of you probably need cacti 0.8.6g installed with patches.

spignataro
Posts: 41
Joined: Mon Nov 07, 2005 11:21 pm

#6 Post by spignataro » Thu Nov 10, 2005 10:41 am

works for me.

Thanks

dagonet
Cacti User
Posts: 89
Joined: Sat Oct 29, 2005 4:05 pm
Location: Wuerzburg

Re: Microsoft IIS current connection template

#7 Post by dagonet » Sun Nov 13, 2005 4:20 pm

dagonet wrote:Hi community,

another template from me.

Dagonet.
Sorry guys. Forgot to mention I created it with cacti 0.8.6g.

joshm
Cacti User
Posts: 82
Joined: Mon Oct 03, 2005 1:34 pm
Location: STL

#8 Post by joshm » Wed Nov 16, 2005 4:38 pm

Thanks, FInally found a IIS script that I could just insert and it worked great without any changes.

yianniska
Posts: 4
Joined: Mon Jun 06, 2005 6:13 am

minor iis questions

#9 Post by yianniska » Tue Dec 06, 2005 3:20 am

Hi all,
The script is working fine (thanks).
i have 2 more questions.

1)What if i need to get the iis connections for each web site that i run !
what i mean is that this script gives you the total number of iis connections, instead i need the individual number of iis connection for each web site!

2) I've got a problem when the iis connections get over 1000!
in the graph appears a gap.

thanks
Yiannis

joshm
Cacti User
Posts: 82
Joined: Mon Oct 03, 2005 1:34 pm
Location: STL

Re: minor iis questions

#10 Post by joshm » Thu Jan 26, 2006 12:55 pm

yianniska wrote: ............
2) I've got a problem when the iis connections get over 1000!
in the graph appears a gap.

thanks
Yiannis
I have also noticed this problem/limitation... Anyone got any ideas on how to fix it?

africanw
Cacti User
Posts: 124
Joined: Thu Mar 31, 2005 4:24 pm
Location: Sydney, Asutralia
Contact:

#11 Post by africanw » Mon Jan 30, 2006 3:34 am

Go to the data template and up the maximun value to whatever you need it to be.

joshm
Cacti User
Posts: 82
Joined: Mon Oct 03, 2005 1:34 pm
Location: STL

#12 Post by joshm » Mon Jan 30, 2006 12:27 pm

africanw wrote:Go to the data template and up the maximun value to whatever you need it to be.
Under the data template for
IIS - cur. connections

I tried changing the number that was by
Maximum Value
Use Per-Data Source Value (Ignore this Value)

It was at 1000, but i changed it to 2000, then 10000 All with the same results. I am still seeing blank spots when my server goes over 1000 connections. Any ideas? Any other settings or things I need to change to get this template to display larger numbers?

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

#13 Post by BSOD2600 » Mon Jan 30, 2006 3:47 pm

If you update the data source min/max values in cacti, you must manually update the rrd file(s) with the rrdtool tune command.

User avatar
dust2k
Cacti User
Posts: 101
Joined: Sun Dec 04, 2005 3:14 am

#14 Post by dust2k » Mon Jan 30, 2006 7:38 pm

BSOD2600 wrote:you must manually update the rrd file(s) with the rrdtool tune command.
how ? I am curious.


Post Reply