Trango T-Link10 and Atlas RSSI and Traffic Graphs

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
LtTentacle
Posts: 6
Joined: Mon Nov 28, 2005 2:34 pm

Trango T-Link10 and Atlas RSSI and Traffic Graphs

#1 Post by LtTentacle » Mon Nov 28, 2005 3:38 pm

Cacti Version 0.8.6g

I've gotten together a set of queries and graphs for Trango Link10 and Atlas radios. Specifically RSSI and Traffic graphs.


RSSI Graphs Look like:

Image

Radio Traffic:

Image

Radio Traffic w/ Totals and 95 percentile:

Image

Ethernet Traffic:

Image


If anything doesn't work right or needs changing please let me know and I'll do my best to help out. All graph templates and queries should be included. Hopefully this helps someone out.
Attachments
Trango-Link10-and-Atlas-Graphs.zip
(19.85 KiB) Downloaded 1068 times

hamidur
Posts: 10
Joined: Mon Dec 19, 2005 3:33 am

#2 Post by hamidur » Tue Mar 14, 2006 12:16 am

plz provide me P5830S-MU/RU, M5830S AP, M5800S FSU templates for cacti.. looking for it for long time..

hamidur
Posts: 10
Joined: Mon Dec 19, 2005 3:33 am

#3 Post by hamidur » Tue Mar 14, 2006 3:29 am

i used the templates u give for trangolink 10. but graph shows nothing
only freq and distance is shown. plz help..

LtTentacle
Posts: 6
Joined: Mon Nov 28, 2005 2:34 pm

#4 Post by LtTentacle » Tue Mar 14, 2006 10:14 am

hamidur wrote:plz provide me P5830S-MU/RU, M5830S AP, M5800S FSU templates for cacti.. looking for it for long time..
Templates for the M5830S AP are available at http://forums.cacti.net/about7572.html&highlight=trango. All the snmp information for clients is gathered from the AP , so there is no need for a specific fox templates.

The P5830S-MU/Ru should be the Link-10 templates above.

hamidur
Posts: 10
Joined: Mon Dec 19, 2005 3:33 am

#5 Post by hamidur » Mon Mar 20, 2006 2:17 am

I am using cacti-0.8.6g and I have used the trangolink10 templates. but the problem is that i am not getting the graph for interface - traffic. only rssi field is showing some data. i think everything i have done is ok. but still no result. Plz help ....

plz see the graph..
Attachments
cacti.jpg
cacti.jpg (199.7 KiB) Viewed 20184 times

darwinism
Posts: 11
Joined: Wed Mar 29, 2006 2:39 pm

#6 Post by darwinism » Wed Mar 29, 2006 2:59 pm

Yea its kind of weird. Here is my data query debug

+ Running data query [10].
+ Found type = '3' [snmp query].
+ Found data query XML file at '/usr/share/cacti/resource/snmp_queries/trango_tlink10-mu.xml'
+ XML file parsed ok.
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.5454.1.22.1'
+ Located input field 'murfActiveChannel' [walk]
+ Executing SNMP walk for data @ '1.3.6.1.4.1.5454.1.22.2.2'
+ Found item [murfActiveChannel='11'] index: 0 [from value]
+ Located input field 'murfActivePolarization' [walk]
+ Executing SNMP walk for data @ '1.3.6.1.4.1.5454.1.22.2.3'
+ Found item [murfActivePolarization='h'] index: 0 [from value]
+ Located input field 'ruDistance' [walk]
+ Executing SNMP walk for data @ '1.3.6.1.4.1.5454.1.22.3.7'
+ Found item [ruDistance='0'] index: 0 [from value]
+ Found data query XML file at '/usr/share/cacti/resource/snmp_queries/trango_tlink10-mu.xml'
+ Found data query XML file at '/usr/share/cacti/resource/snmp_queries/trango_tlink10-mu.xml'
+ Found data query XML file at '/usr/share/cacti/resource/snmp_queries/trango_tlink10-mu.xml'


Nothing is mentioned of RSSI or the interface traffic. All od the OID's seem right.

darwinism
Posts: 11
Joined: Wed Mar 29, 2006 2:39 pm

#7 Post by darwinism » Wed Apr 26, 2006 8:30 am

bump?

geskorup
Posts: 24
Joined: Thu Nov 23, 2006 1:08 am

Trango Atlas

#8 Post by geskorup » Fri Jun 29, 2007 5:28 am

I've taken the Atlas example templates from this post and modified them. To get all of the graphs you need to be running at least 1p2r7 on the radio. This template is unified for MU/RU u-type since the OID's are the same for either mode unlike LINK-10's. The name Trango is calling the Atlas (aka P5010M, Atlas PtP) is now Trango LINK-45, so thats what I called the templates. I built these on 0.8.6j. The trango_link45.xml file needs to go into your <cacti root>/resource/snmp_queries/ directory.

Please post if you have suggestions for changes or problems. I'll do my best to help out.

George

Please go to this post for Trango templates: http://forums.cacti.net/viewtopic.php?t=22214
Last edited by geskorup on Sat Jul 07, 2007 9:41 pm, edited 1 time in total.

geskorup
Posts: 24
Joined: Thu Nov 23, 2006 1:08 am

#9 Post by geskorup » Sun Jul 01, 2007 5:40 am

I've updated the LINK-10 templates based on the ones in the original post. Added missing MU/RU radio temperature graph. These were built on 0.8.6j. The trango_link10-mu.xml and trango_link10-ru.xml files need to be uploaded to your <cacti root>/resources/snmp_queries/ directory.

NOTE: You may need to have the 1p11 firmware loaded on the radios.

George

Please go to this post for Trango templates: http://forums.cacti.net/viewtopic.php?t=22214

lonecrow
Posts: 44
Joined: Tue Dec 11, 2007 9:49 am

#10 Post by lonecrow » Tue Dec 11, 2007 9:54 am

I have had no luck with these and out Atlas AP's.

I get this error after I import the graphs etc it says ok, but when I go to view them, I get this:

Notice: Undefined index: sgg_11 in /usr/share/cacti/site/graphs_new.php on line 71

Warning: Cannot modify header information - headers already sent by (output started at /usr/share/cacti/site/graphs_new.php:71) in /usr/share/cacti/site/graphs_new.php on line 322


line 71 has something like this which looks correct to me

description>Fetch SU-related statistics from Trango M5800 series AP's.</description>

Post Reply