netapp space available query template

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
egironda
Posts: 45
Joined: Mon Dec 19, 2005 6:44 pm

netapp space available query template

#1 Post by egironda » Mon Jan 16, 2006 6:45 pm

Just a quick one I did to query the space free on the netapp, per volume. Have fun.
Attachments
cacti_data_template_netapp_data_template.xml
import this
(8.33 KiB) Downloaded 2964 times
cacti_graph_template_netapp_percent_used.xml
import this
(12.22 KiB) Downloaded 3185 times
cacti_graph_template_netapp_space_detail.xml
import this
(17.05 KiB) Downloaded 3031 times
cacti_data_query_netapp.xml
import this
(24.15 KiB) Downloaded 3395 times
netapp.xml
This goes in your resource/snmp_queries directory.
(1.48 KiB) Downloaded 4301 times

User avatar
AndyStewart
Cacti User
Posts: 102
Joined: Thu Sep 29, 2005 5:21 am
Location: Edinburgh, Scotland

#2 Post by AndyStewart » Fri Feb 24, 2006 4:21 am

I'm getting the following error trying to create the graphs on this?

all files copied and imported as stated above, but when i come to click on create graphs, the following happens when i select the volumes to graph:
Notice: Undefined index: sgg_16 in c:\apache\htdocs\cacti\graphs_new.php on line 71

Notice: Undefined index: sgg_16 in c:\apache\htdocs\cacti\graphs_new.php on line 71

Notice: Undefined index: sgg_16 in c:\apache\htdocs\cacti\graphs_new.php on line 71

Notice: Undefined index: sgg_16 in c:\apache\htdocs\cacti\graphs_new.php on line 71

Warning: Cannot modify header information - headers already sent by (output started at c:\apache\htdocs\cacti\graphs_new.php:71) in c:\apache\htdocs\cacti\graphs_new.php on line 322
I don't care if the glass is half full or half empty, i want to know, who's been drinking my pint!!!

[size=75][Windows 2003 & IIS6] [Cacti 0.8.7b] [ActivePerl 5.8.8.817] [MySql 5.0.19] [NetSNMP 5.2.1.2-1] [PHP 5.1.2] [RRDTool 1.2.11]
[Plugins: PluginArchitecture, Monitor, Discovery, Threshold, Update, Reports, Manage, RealTime][/size]

egironda
Posts: 45
Joined: Mon Dec 19, 2005 6:44 pm

#3 Post by egironda » Tue Mar 07, 2006 10:57 pm

Hmm... sorry I can't offer too much help here, but...

Does cacti see the xml file okay in the "Data Query" section?
When you click on verbose output for the query, what does it say?

User avatar
AndyStewart
Cacti User
Posts: 102
Joined: Thu Sep 29, 2005 5:21 am
Location: Edinburgh, Scotland

#4 Post by AndyStewart » Thu May 04, 2006 8:55 am

NetApp Volumes in Data Query section - checked - Successfully located XML file

Running Verbose Query on Device screen under "Associated Data Queries" - NetApp Volumes
+ Running data query [16].
+ Found type = '3' [snmp query].
+ Found data query XML file at 'E:/Inetpub/wwwroot/cacti/resource/snmp_queries/netapp-volumes.xml'
+ XML file parsed ok.
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.789.1.5.4.1'
+ Located input field 'dfIndex' [walk]
+ Executing SNMP walk for data @ '.1.3.6.1.4.1.789.1.5.4.1.1'
+ Found item [dfIndex='1'] index: 1 [from value]
+ Found item [dfIndex='2'] index: 2 [from value]
+ Found item [dfIndex='3'] index: 3 [from value]
+ Found item [dfIndex='4'] index: 4 [from value]
+ Located input field 'dfMountedOn' [walk]
+ Executing SNMP walk for data @ '.1.3.6.1.4.1.789.1.5.4.1.2'
+ Found item [dfMountedOn='/vol/vol2/'] index: 1 [from value]
+ Found item [dfMountedOn='/vol/vol2/.snapshot'] index: 2 [from value]
+ Found item [dfMountedOn='/vol/vol1/'] index: 3 [from value]
+ Found item [dfMountedOn='/vol/vol1/.snapshot'] index: 4 [from value]
+ Found data query XML file at 'E:/Inetpub/wwwroot/cacti/resource/snmp_queries/netapp-volumes.xml'
+ Found data query XML file at 'E:/Inetpub/wwwroot/cacti/resource/snmp_queries/netapp-volumes.xml'
+ Found data query XML file at 'E:/Inetpub/wwwroot/cacti/resource/snmp_queries/netapp-volumes.xml'
On Create Graphs Screen, listed under Data Query [NetApp - Volumes]
4 volumes listed:
/vol1/vol2/
/vol1/vol2/.snapshot
/vol1/vol1/
/vol1/vol1/.snapshot

Click any one or more of them, and click create, and the error appears:
Notice: Undefined index: sgg_16 in E:\Inetpub\wwwroot\cacti\graphs_new.php on line 71

Warning: Cannot modify header information - headers already sent by (output started at E:\Inetpub\wwwroot\cacti\graphs_new.php:71) in E:\Inetpub\wwwroot\cacti\graphs_new.php on line 322
I don't care if the glass is half full or half empty, i want to know, who's been drinking my pint!!!

[size=75][Windows 2003 & IIS6] [Cacti 0.8.7b] [ActivePerl 5.8.8.817] [MySql 5.0.19] [NetSNMP 5.2.1.2-1] [PHP 5.1.2] [RRDTool 1.2.11]
[Plugins: PluginArchitecture, Monitor, Discovery, Threshold, Update, Reports, Manage, RealTime][/size]

User avatar
AndyStewart
Cacti User
Posts: 102
Joined: Thu Sep 29, 2005 5:21 am
Location: Edinburgh, Scotland

#5 Post by AndyStewart » Mon Jun 05, 2006 4:16 am

/bump - anyone come across this anywhere?

I REALLY need to get the NetApp disk space graphs working ...
I don't care if the glass is half full or half empty, i want to know, who's been drinking my pint!!!

[size=75][Windows 2003 & IIS6] [Cacti 0.8.7b] [ActivePerl 5.8.8.817] [MySql 5.0.19] [NetSNMP 5.2.1.2-1] [PHP 5.1.2] [RRDTool 1.2.11]
[Plugins: PluginArchitecture, Monitor, Discovery, Threshold, Update, Reports, Manage, RealTime][/size]

User avatar
AndyStewart
Cacti User
Posts: 102
Joined: Thu Sep 29, 2005 5:21 am
Location: Edinburgh, Scotland

#6 Post by AndyStewart » Mon Jun 05, 2006 9:48 am

nvm - got it sorted...
I don't care if the glass is half full or half empty, i want to know, who's been drinking my pint!!!

[size=75][Windows 2003 & IIS6] [Cacti 0.8.7b] [ActivePerl 5.8.8.817] [MySql 5.0.19] [NetSNMP 5.2.1.2-1] [PHP 5.1.2] [RRDTool 1.2.11]
[Plugins: PluginArchitecture, Monitor, Discovery, Threshold, Update, Reports, Manage, RealTime][/size]

shawncsmith
Posts: 3
Joined: Thu Nov 30, 2006 2:12 pm

Graphing titles getting truncated

#7 Post by shawncsmith » Thu Nov 30, 2006 2:17 pm

I have several volumes and some of them have the 1st 14 characters the same in their volume name, so when they are graphed it seems the |query_dfMountedOn| is getting truncated in the graphing title so you don't know which volume is which.

Anyone else having this issue, and do you know how to solve it?

Thanks.

thaihoamai
Posts: 8
Joined: Tue Dec 05, 2006 8:15 pm

#8 Post by thaihoamai » Fri Jan 05, 2007 12:42 am

egironda,

great job. this works great!

I have one minor issue: my volumes are in the GB and TB size range but the graphs are 1 order of magnitue off, e.g. a volume that's 200GB shows as 200M and a volume of 1.6TB shows up as 1.6G.

Where do I go to rectify this?

Thanks again.

shawncsmith
Posts: 3
Joined: Thu Nov 30, 2006 2:12 pm

#9 Post by shawncsmith » Fri Jan 05, 2007 12:51 am

You should look in the graphing template and make sure you use the multiply by 1024, that will fix it.

thaihoamai
Posts: 8
Joined: Tue Dec 05, 2006 8:15 pm

#10 Post by thaihoamai » Fri Jan 05, 2007 2:07 pm

shawncsmith,

great! that worked. thanks.

another weird thing i'm noticing is that the size reported in the graph is not 100% accurate. the Used, Avail and Total is off by anywhere between 6GB to 12GB.

a 'df' on the netapp matches (in KB) the output of the snmpwalk against the OIDs in the netapp.xml file but the graphs for all volumes are off.

can't figure out how the graphs are calculating the Used, Avail and Total values for the graphs.

do you know?

shawncsmith
Posts: 3
Joined: Thu Nov 30, 2006 2:12 pm

#11 Post by shawncsmith » Fri Jan 05, 2007 2:25 pm

Where are you looking at the values. If you are looking at the filer at-a-glance and are trying to convert those values into GB or TB you may be off.

Look at the values that show up in the volume/manage in the naadmin page.

Those will show you values in GB or TB and should be spot on with what is showing up in your graph.

It all comes down to the 1024.

pyoung
Posts: 13
Joined: Mon Nov 07, 2005 2:51 pm
Contact:

Re: Graphing titles getting truncated

#12 Post by pyoung » Fri May 04, 2007 3:58 pm

shawncsmith wrote:I have several volumes and some of them have the 1st 14 characters the same in their volume name, so when they are graphed it seems the |query_dfMountedOn| is getting truncated in the graphing title so you don't know which volume is which.

Anyone else having this issue, and do you know how to solve it?

Thanks.
I'm seeing this same issue - has anyone got a fix for it?

(Sorry to bump an old thread.).

Laffer
Posts: 14
Joined: Fri Aug 24, 2007 8:47 am

#13 Post by Laffer » Tue Sep 04, 2007 4:37 am

This can be solved through:

CONSOLE -> Configuration: SETTINGS -> VISUAL TAB -> Data Queries: Maximum Field Length

set this Value greater than 15 Characters, in case increase also Maximum Title Length

johno12345
Posts: 2
Joined: Wed May 19, 2010 6:07 am

#14 Post by johno12345 » Wed May 19, 2010 6:15 am

Hi,

I'm also having troubles with the graphs displaying mb instead of gb and gb instead of tb....

I've looked in the graph template to find a multiplier or similar, only thing i can find is base which was set to 1000 i changed this to 1024 with no luck (yes i recreated graphs and data sources).

any help will be er, helpful :)

FYI: i'm running the latest version of cacti..

Other than the obvious prob, these templates are awesome man! :D

johno12345
Posts: 2
Joined: Wed May 19, 2010 6:07 am

#15 Post by johno12345 » Wed May 19, 2010 6:43 am

Not to worry, i figured it...

Its a CDEF which needs applying to the graph template items.

Post Reply