HP Laserjet 4100 and 4600 Percentage Templates

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
bio777
Posts: 16
Joined: Fri Mar 17, 2006 6:16 am

HP Laserjet 4100 and 4600 Percentage Templates

#1 Post by bio777 » Wed Apr 05, 2006 7:23 am

Hi All,

Hoping to do something in return now.. This template uses a custom CDEF and calculates the percentages.

Enjoy..

bio777..
Attachments
HP4100.JPG
HP4100
HP4100.JPG (23.08 KiB) Viewed 21093 times
cacti_host_template_hp_laserjet_4100.xml
host_template_hp_4100
(9.67 KiB) Downloaded 2302 times
HP4600.JPG
HP4600
HP4600.JPG (37.17 KiB) Viewed 21093 times
cacti_host_template_hp_laserjet_4600.xml
host_template_hp_4600
(28.19 KiB) Downloaded 2304 times

tierpel
Posts: 9
Joined: Sun Feb 19, 2006 3:47 pm
Location: FR -- Sophia-antipolis - Valence

#2 Post by tierpel » Wed Apr 05, 2006 11:06 am

thx a lot !

stava
Posts: 1
Joined: Sun Mar 04, 2007 8:45 pm
Location: Gothenburg, Sweden

Howto

#3 Post by stava » Sun Mar 04, 2007 9:22 pm

Yeah, I'm a newbie at cacti, but...

I imported the above host templates in ccacti-0.8.6j, defined my graphs, and everything seemed OK at first. Then I discovered that the HP Laserjet 4100 template worked just fine, but I get no values for the HP Color Laserjet 4600, which I've connected to my HP Laserjet 4500 printer. For all MIBs defined in the 4600 template, I've done the snmpget, but they all return -3 or similar. Does anyone know how to adapt the template for the 4500 printer?

Any help appreciated.

toddyp
Posts: 14
Joined: Mon May 21, 2007 6:55 pm

#4 Post by toddyp » Mon May 28, 2007 1:39 am

Tried this template with HP4650dn. Working beautifully. thanks.

mvonherr
Posts: 2
Joined: Tue Oct 07, 2008 9:07 am

Recent Use

#5 Post by mvonherr » Tue Oct 07, 2008 9:10 am

Original Post:
Anybody used this one recently?
I am trying to get this to work with a 5550 Color Laserjet. I am getting data (based on logs), but the graphs do not display. (Actually, no graphic at all)
Thank you for any help.

Update:
Found the problems. The maximums were all wrong for a 5550. Fixed that and it started working. I have attached a modified Template for anyone using an HP Color Laserjet 5550.
Attachments
cacti_graph_template_hp_laserjet_5550_-_toner_transfer_fuser_kit.zip
HP Color Laserjet 5550
(4.32 KiB) Downloaded 726 times

isse
Posts: 16
Joined: Tue Nov 25, 2008 5:50 am

Re: Recent Use

#6 Post by isse » Tue Nov 25, 2008 5:52 am

mvonherr wrote: Update:
Found the problems. The maximums were all wrong for a 5550. Fixed that and it started working. I have attached a modified Template for anyone using an HP Color Laserjet 5550.
Hi,

Thanks for this.
But it will not work for me on a 5500.
It wont produce a graph image at all.

/Isse

sjs
Posts: 22
Joined: Wed Oct 24, 2007 1:22 pm

Re: HP Laserjet 4100 and 4600 Percentage Templates

#7 Post by sjs » Wed Feb 22, 2017 6:14 am

I'm using this template on a HP Color Laserjet 4700 and it worked great so far, the percentages of the consumables where displayed correctly. But now, for the first time after using this template, I replaced an empty toner cartridge (cyan) and ran into trouble with Cacti: The printer's SNMP server returns the correct value "10000" for the remaining pages of the new cartridge. This value is also correctly read by Cacti and stored into the respective .rrd file as I've checked with "rrdtool lastupdate". Also the maximum value for this value is set to 10000 in the respective Cacti data template.
However, the graphs created by Cacti don't contain "100" as the percentage for the cyan toner, but "-nan" instead. It even stayed this way after some pages where printed with the new cartridge and the remaining page count is now down to 9900.
Any idea what could be wrong here?

TIA
sjs

sjs
Posts: 22
Joined: Wed Oct 24, 2007 1:22 pm

Re: HP Laserjet 4100 and 4600 Percentage Templates

#8 Post by sjs » Thu Feb 23, 2017 10:45 am

sjs wrote:I'm using this template on a HP Color Laserjet 4700 and it worked great so far, the percentages of the consumables where displayed correctly. But now, for the first time after using this template, I replaced an empty toner cartridge (cyan) and ran into trouble with Cacti: The printer's SNMP server returns the correct value "10000" for the remaining pages of the new cartridge. This value is also correctly read by Cacti and stored into the respective .rrd file as I've checked with "rrdtool lastupdate". Also the maximum value for this value is set to 10000 in the respective Cacti data template.
However, the graphs created by Cacti don't contain "100" as the percentage for the cyan toner, but "-nan" instead. It even stayed this way after some pages where printed with the new cartridge and the remaining page count is now down to 9900.
Any idea what could be wrong here?
Addendum: In the meantime, for testing purposes, I've created another Cacti host, querying the same printer. On that test host, all consumable values (including the cyan toner) show up correctly. Because of this, I suspect that the corresponding .rrd file might have an issue of some sort. Any idea how I could fix this? (Aside from removing and re-creating the file altogether.)


Regards,
sjs77

Post Reply