Barracuda Spam Firewall Templates

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
etijburg
Posts: 5
Joined: Thu Jul 20, 2006 11:48 am
Location: Plano, TX

Barracuda Spam Firewall Templates

#1 Post by etijburg » Thu Jul 20, 2006 4:37 pm

Here are some Barracuda Spam Firewall templates that we have been using. I have these running against 4 of these appliances on 2 different Cacti servers.
Attachments
Barracuda.zip
(22.15 KiB) Downloaded 3988 times
Erik Tijburg
Chief Network Analyst
RedMoon Inc.

Imadiff
Posts: 3
Joined: Fri Jul 21, 2006 7:20 am
Location: Paris 13
Contact:

#2 Post by Imadiff » Fri Jul 21, 2006 7:24 am

Hi,
Thanks for your template.

But i have a problem during import the template.

In fact i have the error : XML : Hash version does not exist.

i do the modification in config_array.php and add this :

$hash_version_codes = array(
"0.8.4" => "0000",
"0.8.5" => "0001",
"0.8.5a" => "0002",
"0.8.6" => "0003",
"0.8.6a" => "0004",
"0.8.6b" => "0005",
"0.8.6c" => "0006",
"0.8.6d" => "0007",
"0.8.6e" => "0008",
"0.8.6f" => "0009",
"0.8.6g" => "0010"
);


But nothing !

My version of cacti is 0.8.6g.

Thanks for your help

etijburg
Posts: 5
Joined: Thu Jul 20, 2006 11:48 am
Location: Plano, TX

#3 Post by etijburg » Fri Jul 21, 2006 8:30 am

These were exported by 0.8.6h Build 42
Erik Tijburg
Chief Network Analyst
RedMoon Inc.

Imadiff
Posts: 3
Joined: Fri Jul 21, 2006 7:20 am
Location: Paris 13
Contact:

#4 Post by Imadiff » Fri Jul 21, 2006 8:37 am

etijburg wrote:These were exported by 0.8.6h Build 42
Thanks :)
I try to updrage my cacti :)

Imadiff
Posts: 3
Joined: Fri Jul 21, 2006 7:20 am
Location: Paris 13
Contact:

#5 Post by Imadiff » Fri Jul 21, 2006 10:54 am

On Debian the version of cacti is 0.8.6c. :/

Can you change the template just for me :oops:

:wink:

etijburg
Posts: 5
Joined: Thu Jul 20, 2006 11:48 am
Location: Plano, TX

#6 Post by etijburg » Fri Jul 21, 2006 10:56 am

Not sure how to do that for you. I have just recently started making my own templates. I create them on our Dev box and get them working the way I want them too. Export them. and then import them to our production box.
Erik Tijburg
Chief Network Analyst
RedMoon Inc.

MrKeith
Posts: 6
Joined: Fri Oct 06, 2006 1:54 pm

#7 Post by MrKeith » Fri Oct 06, 2006 2:45 pm

Dumb question but how do I enable SNMP on my Barracuda? I've looked and can't seem to find it.

high.pointe
Posts: 3
Joined: Fri Oct 13, 2006 3:20 pm

SNMP on Barracuda

#8 Post by high.pointe » Mon Oct 23, 2006 5:11 pm

It depends on your model of Barracuda. What is your model number?

wwolkers
Posts: 24
Joined: Thu Sep 14, 2006 6:44 am

#9 Post by wwolkers » Tue Oct 24, 2006 4:34 am

there's another template on the forums, which doesn't require the use of SNMP on the barracuda, it uses the XML file from the barracuda.

only problem with that is that the system temperature isn't working :(

that's a problem with the XML from the Barracuda though, not a template or cacti issue. It's already been reported to Barracuda.

User avatar
cpt_ahab
Cacti User
Posts: 60
Joined: Tue Feb 01, 2005 11:34 am

...

#10 Post by cpt_ahab » Wed Oct 25, 2006 5:24 am

here is the thread for barracudas without snmp.
http://forums.cacti.net/viewtopic.php?t=16580
as wwolkers said the xml is reporting wrong numbers for the sys_temp.
but the total performance and the firmware storage work...

edit: cpu_temp _works now --> look in the thread

l


greez ahab
cacti 0.8.6j ** cactid 0.8.6d ** rrdtool 1.2.15
Debain ** Apache 2 ** PHP 4.3.0

mcleveland
Posts: 7
Joined: Fri Dec 15, 2006 7:14 pm

HELP WITH BARRACUDA

#11 Post by mcleveland » Fri Dec 15, 2006 7:16 pm

Ok i am new to cacti and i was wondering if someone would help me get data from my Barracuda 300. It seems like it does not have snmp capability and i need to run a script. can someone please help. THANKS

cpdans
Posts: 43
Joined: Mon Oct 28, 2002 7:59 am

Problem importing template

#12 Post by cpdans » Fri Jan 12, 2007 3:13 pm

I am having a problem importing the cacti_host_template_barracuda_spam_firewall.xml template file. It is like it is to big or something. It sits for a minute or two and then goes to a blank page. Any ideas would be great, the other three xml files imported fine.

mcleveland
Posts: 7
Joined: Fri Dec 15, 2006 7:14 pm

#13 Post by mcleveland » Fri Jan 12, 2007 3:14 pm

open up the xml file and copy the text, then paste what you copied into cacti and inport it that way. Worked for me

cpdans
Posts: 43
Joined: Mon Oct 28, 2002 7:59 am

#14 Post by cpdans » Fri Jan 12, 2007 3:19 pm

I tried that too...same issue.

cpdans
Posts: 43
Joined: Mon Oct 28, 2002 7:59 am

#15 Post by cpdans » Fri Jan 12, 2007 3:50 pm

I got it to work by increasing the php timeout. I added the following to line 2 of the template_import.php file.

set_time_limit(0);

Post Reply