Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Wed Jun 19, 2019 1:55 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: [SOLVED] Cisco Nexus Template
PostPosted: Thu Sep 03, 2009 2:50 am 
Offline

Joined: Wed Jan 28, 2009 9:20 am
Posts: 9
Dear all,
I tried to create a new template to graph Cisco Nexus devices performances.
Everything is working well for interface graphs.
But when I try to use CPU Usage and/or Memory usage I get the following messages:

09/03/2009 09:02:14 AM - CMDPHP: Poller[0] Host[117] DS[2496] SNMP: v2: 10.200.1.10, dsname: 5min_cpu_nexus, oid: .1.3.6.1.4.1.9.9.305.1.1.1, output: U
09/03/2009 09:02:14 AM - CMDPHP: Poller[0] Host[117] DS[2496] WARNING: Result from SNMP not valid. Partial Result: U
09/03/2009 08:57:08 AM - CMDPHP: Poller[0] Host[117] DS[2496] SNMP: v2: 10.200.1.10, dsname: 5min_cpu_nexus, oid: .1.3.6.1.4.1.9.9.305.1.1.1, output: U
09/03/2009 08:57:08 AM - CMDPHP: Poller[0] Host[117] DS[2496] WARNING: Result from SNMP not valid. Partial Result: U
09/03/2009 08:52:07 AM - CMDPHP: Poller[0] Host[117] DS[2496] SNMP: v2: 10.200.1.10, dsname: 5min_cpu_nexus, oid: .1.3.6.1.4.1.9.9.305.1.1.1, output: U
09/03/2009 08:52:07 AM - CMDPHP: Poller[0] Host[117] DS[2496] WARNING: Result from SNMP not valid. Partial Result: U


Performin a SNMPwalk against that particular OID is returning back a good value. I'm attaching the templates if someone wants to analyze them.

Thanks.
Fabio


Attachments:
Cacti_Cisco_Nexus_Template.zip [37.17 KiB]
Downloaded 3563 times


Last edited by limuerti on Tue Oct 06, 2009 4:53 am, edited 1 time in total.
Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 18, 2009 5:54 pm 
Offline

Joined: Thu Jun 15, 2006 11:36 am
Posts: 48
I have deleted my reply, since I have found that it was unrelated.


Last edited by imro on Fri Sep 18, 2009 6:38 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 18, 2009 6:34 pm 
Offline

Joined: Thu Jun 15, 2006 11:36 am
Posts: 48
I have deleted my reply, since I have found that it was unrelated.


Top
 Profile  
 
 Post subject: [solved] Cisco Nexus Templates
PostPosted: Tue Oct 06, 2009 4:52 am 
Offline

Joined: Wed Jan 28, 2009 9:20 am
Posts: 9
I created a template for Cisco Nexus switches.

Please add your comments.

Regards,

Fabio


Attachments:
Cacti Nexus.zip [37.8 KiB]
Downloaded 3581 times
Top
 Profile  
 
 Post subject: Problem importing host template
PostPosted: Mon Jan 18, 2010 3:50 pm 
Offline

Joined: Mon Jan 29, 2007 12:16 pm
Posts: 3
Hello Fabio,

Thanks for taking the time to create these definitions for the Nexus gear. I am getting one error while importing the host def where it is complaining about a data template:

+ Found Dependency: (Graph Template) Interface - Traffic (bits/sec)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Unmet Dependency: (Data Template)
+ Found Dependency: (Graph Template) Interface - Traffic (bits/sec, 95th Percentile)

Any idea what data template this is?

Thanks,

Adam


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 18, 2010 2:28 am 
Offline

Joined: Sun Apr 18, 2010 2:20 am
Posts: 1
Did anyone ever figure out what the missing templates were?

How would I go about getting them?

-Joe


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 20, 2010 5:19 am 
Offline
Cacti Moderator
User avatar

Joined: Tue Mar 02, 2010 9:03 am
Posts: 348
Would also be very interesting for me :)


Top
 Profile  
 
 Post subject:
PostPosted: Thu Apr 22, 2010 9:38 am 
Offline
Cacti User

Joined: Tue May 03, 2005 8:54 am
Posts: 298
Location: GA
I have the same unmet dependencies....some of my interface graphs work but most do not??


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jul 26, 2010 1:53 am 
Offline
Cacti User

Joined: Thu Mar 01, 2007 5:43 pm
Posts: 276
Location: Melbourne, Australia
spoonman wrote:
I have the same unmet dependencies....some of my interface graphs work but most do not??


Are you sure that you've got the correct OIDs? I have downloaded the XML files and walked the OIDs on my Nexus 5010 and the values do not appear to be that of the CPU utilisation.

I have tried to find the MIBs/OIDs for the CPU and memory but have had no luck so far :(


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jul 26, 2010 9:13 pm 
Offline
Cacti User

Joined: Thu Mar 01, 2007 5:43 pm
Posts: 276
Location: Melbourne, Australia
Upon further investigation I found that he was in fact using the correct OIDs.

When I walked OID 1.3.6.1.4.1.9.9.109.1.1.1.1.8 (which is for CPU utilisation) it gave me a value of 25, but when I issued the sh system resources command I could not find 25 anywhere, until I took a better took. I found it here:

Code:
Load average:   1 minute: 1.41   5 minutes: 0.25   15 minutes: 0.17


In regards to the memory utilisation OID, that was a little bit tricker. When I walked the OID .1.3.6.1.4.1.9.9.305.1.1.2.0 it gave me a value of 58. Once again when I issued the sh system resources command I could not find the 58 anywhere (as per the output below):

Code:
Memory usage:   2074284K total,   1220456K used,    853828K free


However, when I worked out the memory used as a percentage of the total memory, I got my 58 :)

Code:
1220456 divided by 2074284 = 58.83


I am going to put this in to a Host Template when I get the chance. If anyone wants a copy let me know and I will happily upload it.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2010 2:35 am 
Offline

Joined: Mon Jul 26, 2010 8:30 am
Posts: 4
Yes, could you upload it, and comment it ?

thanks


Top
 Profile  
 
 Post subject: Re: [SOLVED] Cisco Nexus Template
PostPosted: Fri Oct 22, 2010 3:09 am 
Offline

Joined: Tue Feb 24, 2009 7:33 am
Posts: 14
Hi , we have a Cisco NX-OS(tm) n5000 and we configured the snmp community but,
If I get a snmpwalk on the ethernet interface that is working, the output is always 0.

This is my query snmp:
[[email protected] ~]# snmpget -v1 -ccomm sw-host ifInOctets.436211712
IF-MIB::ifInOctets.436211712 = Counter32: 0

But on the switch i have traffic:
SW1-NX# sh int e1/2 | grep second
30 seconds input rate 80 bits/sec, 0 packets/sec
30 seconds output rate 72072 bits/sec, 48 packets/sec
We would like to graph the ethernet interfaces, any idea, wrong mib ?
Gian Paolo


Top
 Profile  
 
 Post subject: Re:
PostPosted: Sun Oct 24, 2010 10:28 pm 
Offline
Cacti User

Joined: Mon Dec 11, 2006 10:17 am
Posts: 215
Quote:
I am going to put this in to a Host Template when I get the chance. If anyone wants a copy let me know and I will happily upload it.
Can you upload this somewhere? I am in need for the Nexus template, but I get unmet dependencies on the initial template.


Top
 Profile  
 
 Post subject: Re: [SOLVED] Cisco Nexus Template
PostPosted: Mon Jan 03, 2011 5:59 pm 
Offline

Joined: Thu Dec 30, 2010 4:42 pm
Posts: 2
Hi voiper99,

Would I be able to get a copy of the host template? I wasn't able to send you a message as I have no permission to do so.

Cheers,
Matt Hanna


Top
 Profile  
 
 Post subject: Re: [SOLVED] Cisco Nexus Template
PostPosted: Fri Feb 18, 2011 2:16 am 
Offline

Joined: Thu Jan 24, 2008 7:53 pm
Posts: 25
Anyone get this? I noticed it's solved but I don't see the fixed host template.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group