Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Jun 16, 2019 12:21 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Windows Processor
PostPosted: Thu Aug 26, 2004 6:05 pm 
Offline

Joined: Thu Aug 26, 2004 4:19 pm
Posts: 14
Location: Ireland
Needs the standard SNMP Informant agent from http://www.snmp-informant.com/



% DPC Time
% Interrupt Time
% Privileged Time
% Processor Time
% User Time


First time own graph so......


Attachments:
cacti_graph_template_lit_nfo_std_processor.xml [24.05 KiB]
Downloaded 4355 times
cacti_data_template_lit_nfo_std_processor_percents.xml [8.95 KiB]
Downloaded 3556 times
cacti_data_query_lit_nfo_std_processor_percents.xml [27.07 KiB]
Downloaded 3699 times
Top
 Profile  
 
 Post subject: I can´t
PostPosted: Tue Aug 31, 2004 12:41 pm 
Offline

Joined: Tue Jul 27, 2004 4:05 pm
Posts: 8
Location: Rosario, Argentina
I can´t import the templates!!!

could you try to post again ?

Tnks


Top
 Profile  
 
 Post subject: Exported Graph Template
PostPosted: Wed Sep 01, 2004 5:15 pm 
Offline

Joined: Thu Aug 26, 2004 4:19 pm
Posts: 14
Location: Ireland
Exported Graph Template including dependencies


Attachments:
cacti_graph_template_lit_nfo_std_processor_percents.xml [23.75 KiB]
Downloaded 3107 times
Top
 Profile  
 
 Post subject: missing
PostPosted: Thu Sep 02, 2004 7:25 am 
Hi! thanks for all, BUT
'cacti-home'/resource/snmp_queries/Lit_Cacti_NFO_STD_Processor.xml
file is missing!

Can you post it to here?


Top
  
 
 Post subject: Query
PostPosted: Thu Sep 02, 2004 8:01 am 
Offline

Joined: Thu Aug 26, 2004 4:19 pm
Posts: 14
Location: Ireland
Try this.


Attachments:
Lit_Cacti_NFO_STD_Processor.xml [1.38 KiB]
Downloaded 3174 times
Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 03, 2004 12:02 pm 
Offline
Cacti User

Joined: Fri Jul 16, 2004 1:59 pm
Posts: 166
Location: Oregon
Could you post a screenshot of the graph please Lit? Good job.


Top
 Profile  
 
 Post subject: Screenshot
PostPosted: Fri Sep 03, 2004 7:50 pm 
Processor Graph


Attachments:
ScreenHunter_001.jpg
ScreenHunter_001.jpg [ 67.93 KiB | Viewed 46533 times ]
Top
  
 
 Post subject: Consolidation of Processor Graphs - SNMP
PostPosted: Fri Sep 17, 2004 4:10 pm 
Added a graph for the Total CPU breakdown.

Requirements

http://www.snmp-informant.com/
(Work Standard Version - Ver 1.3 - problems with 1.2)

Notes on SNMP Informant

SNMP Informant will not install on Windows 95, 98, Me or Windows NT, or any derivative of Linux or Unix. It is designed for Windows 2000, XP and 2003.


Copy
Lit_Cacti_NFO_STD_Processor.xml TO ......\cacti\resource\snmp_queries

Copy Lit_Cacti_NFO_STD_Processor_Total.xml TO .......\cacti\resource\snmp_queries

Import
cacti_data_query_lit_nfo_std_processor_percents.xml
cacti_data_query_lit_nfo_std_processor_percents_total.xml


Attachments:
Processor.gif
Processor.gif [ 119.27 KiB | Viewed 46368 times ]
Lit_Cacti_NFO_STD_Processor.xml [1.39 KiB]
Downloaded 3080 times
cacti_data_query_lit_nfo_std_processor_percents.xml [26.82 KiB]
Downloaded 2956 times
Top
  
 
 Post subject:
PostPosted: Fri Sep 17, 2004 4:19 pm 
Offline

Joined: Thu Aug 26, 2004 4:19 pm
Posts: 14
Location: Ireland
Total Cpu Graph

WMI Processor details : - [url=http://forums.cacti.net/viewtopic.php?t=4370&start=0&postdays=0&postorder=asc&highlight=]WMI W32 CPU (any number of processors) Perl Script via WMI
[/url]


Attachments:
cacti_data_query_lit_nfo_std_processor_percents_total.xml [26.84 KiB]
Downloaded 2926 times
Lit_Cacti_NFO_STD_Processor_Total.xml [1.5 KiB]
Downloaded 2599 times
Top
 Profile  
 
 Post subject: Problem with win cpu graph - no data
PostPosted: Sun Jul 30, 2006 9:59 pm 
Offline

Joined: Mon Jul 24, 2006 8:25 pm
Posts: 9
I can't c any data in my graph. Any idea what is happening?? Attached a copy of my screen capture. It only shows a blank chart even though i followed the sample template here.


Attachments:
win-cpu.jpg
win-cpu.jpg [ 45.42 KiB | Viewed 43718 times ]
Top
 Profile  
 
 Post subject: Lit_Cacti_NFO_STD_Processor.xml won't import
PostPosted: Mon Aug 07, 2006 2:28 pm 
Offline

Joined: Fri Sep 30, 2005 5:12 pm
Posts: 11
Location: Madison, WI
Lit_Cacti_NFO_STD_Processor.xml will not import into 0.8.6h. when I try to manually copy and past, I get an import error.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 29, 2006 6:26 am 
Offline

Joined: Wed Nov 29, 2006 5:59 am
Posts: 4
Hi, is it possible to use this to feed info to a linux cacti server? Mind you, I'm new to this and rather clueless
If there are resources on how to do this, please point me in the right direction.
This question goes for all windows based queries as my cacti box is linux based

Tnx
Patrick


Top
 Profile  
 
 Post subject: Why it doesn´t work ? ...
PostPosted: Wed Sep 09, 2009 8:39 am 
Offline

Joined: Wed Sep 09, 2009 7:10 am
Posts: 1
Hi, my english is very poor, but i will try ... :D ,

I install:
* the standard SNMP Informant agent
* Lit_NFO_Std_Memory_Pages tamplate (works fine)
* Lit_NFO_Std_Processor_Percents (doesnt work )

But, the Lit_NFO_Std_Processor_Percents doesn´t works.

I import this tamplates:
cacti_data_query_lit_nfo_std_processor_percents.xml
cacti_data_query_lit_nfo_std_processor_percents_total.xml
cacti_data_template_lit_nfo_std_processor_percents.xml
cacti_graph_template_lit_nfo_std_processor.xml
cacti_graph_template_lit_nfo_std_processor_percents.xml

and I copy to /srv/www/cacti/resource/snmp_queries:
Lit_Cacti_NFO_STD_Processor.xml
Lit_Cacti_NFO_STD_Processor_Total.xml

more information: the memory template works with SNMPv1 or SNMPv2, SNMP UDP port 161m and SNMP Timeout 500

When i import cacti_graph_template_lit_nfo_std_processor_percents.xml, i get one error:

Graph Template

[success] Lit_NFO_Std_Processor_Percents [update]
...
+ Found Dependency: (Data Template Item) cpuPrivileged
+ Found Dependency: (Data Template Item) cpuUser
+ Unmet Dependency: (Data Template Item)

DEBUB:

RRDTool Command:
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="TESTE - XXX_XXX_XXX_XXX - CPU Utilization" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="percent" \
--slope-mode \
DEF:a="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_cpuuser_713.rrd":cpuProcessor:AVERAGE \
DEF:b="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_cpuuser_713.rrd":cpuInterrupt:AVERAGE \
DEF:c="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_cpuuser_713.rrd":cpuDPC:AVERAGE \
DEF:d="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_cpuuser_713.rrd":cpuPrivileged:AVERAGE \
DEF:e="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_cpuuser_713.rrd":cpuUser:AVERAGE \
AREA:a#CDCFC4:"Processor" \
GPRINT:a:LAST:" Current\:%8.0lf" \
GPRINT:a:AVERAGE:"Average\:%8.0lf" \
GPRINT:a:MAX:"Max\:%8.0lf\n" \
LINE1:b#dd0000:"Interrupt" \
GPRINT:b:LAST:" Current\:%8.0lf" \
GPRINT:b:AVERAGE:"Average\:%8.0lf" \
GPRINT:b:MAX:"Max\:%8.0lf\n" \
LINE1:c#862F2F:"DPC" \
GPRINT:c:LAST:" Current\:%8.0lf" \
GPRINT:c:AVERAGE:"Average\:%8.0lf" \
GPRINT:c:MAX:"Max\:%8.0lf\n" \
LINE1:d#4444FF:"Privileged" \
GPRINT:d:LAST:"Current\:%8.0lf" \
GPRINT:d:AVERAGE:"Average\:%8.0lf" \
GPRINT:d:MAX:"Max\:%8.0lf\n" \
LINE2:e#FFF200:"User" \
GPRINT:e:LAST:" Current\:%8.0lf" \
GPRINT:e:AVERAGE:"Average\:%8.0lf" \
GPRINT:e:MAX:"Max\:%8.0lf\n" \
COMMENT:"\n" \
COMMENT:"COMMENT\: Last Updated\: Tue 08 Sep 14\:20\:07 BRT 2009\n"


RRDTool Says:
ERROR: opening '/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_cpuuser_713.rrd': No such file or direc


----------------------------------------------------------------------


RRDTool Command:
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="TESTE - XXX_XXX_XXX_XXX - Memory Pages Per Sec" \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="Pages Sec" \
--slope-mode \
DEF:a="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_mempagespersec_712.rrd":memPagesPerSec:AVERAGE \
DEF:b="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_mempagefaultspersec_709.rrd":memPageFaultsPerSec:AVERAGE \
DEF:c="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_mempagesinputpersec_710.rrd":memPagesInputPerSec:AVERAGE \
DEF:d="/srv/www/cacti/rra/teste_XXX_XXX_XXX_XXX_mempagesoutputperse_711.rrd":memPagesOutputPerSe:AVERAGE \
LINE2:a#005199:"PagesPerSec" \
GPRINT:a:LAST:" Current\:%8.2lf %s" \
GPRINT:a:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:a:MAX:"Maximum\:%8.2lf %s\n" \
LINE2:b#35962B:"PagesFaultsPerSec" \
GPRINT:b:LAST:"Current\:%8.2lf %s" \
GPRINT:b:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:b:MAX:"Maximum\:%8.2lf %s\n" \
LINE2:c#8F005C:"PagesInputPerSec" \
GPRINT:c:LAST:" Current\:%8.2lf %s" \
GPRINT:c:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:c:MAX:"Maximum\:%8.2lf %s\n" \
LINE2:d#FFF200:"PagesOutputPerSec" \
GPRINT:d:LAST:"Current\:%8.2lf %s" \
GPRINT:d:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:d:MAX:"Maximum\:%8.2lf %s\n" \
COMMENT:"\n" \
COMMENT:"Last Updated\: Tue 08 Sep 14\:30\:15 BRT 2009"

RRDTool Says:
OK

---------

Whats is wrong ?

Thanks for help!


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 11, 2009 2:59 am 
Offline

Joined: Thu Jun 18, 2009 8:52 pm
Posts: 21
becase standard SNMP Informant agent is not to support win2k8 sp2
,how do you fix this issue for template
thx for post


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group