[XML] Microsoft DHCP Free / In Use Script

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
User avatar
pshankland
Cacti User
Posts: 247
Joined: Fri Dec 31, 2004 7:07 am
Location: UK

[XML] Microsoft DHCP Free / In Use Script

#1 Post by pshankland » Sun Jan 09, 2005 10:51 am

These XML files are for retrieving DHCP Free & In-Use information on Microsoft servers. This has only been tested on W2K servers but should work on 2003.

Let me know if there are any problems.

Thanks.

Pete.
Attachments
microsoft_dhcp.xml
XML Script I Wrote
(926 Bytes) Downloaded 3748 times
cacti_data_query_microsoft_dhcp_info.xml
Data Query
(17.59 KiB) Downloaded 3693 times
cacti_graph_template_microsoft_dhcp.xml
Graph Template
(15.5 KiB) Downloaded 4256 times

User avatar
pshankland
Cacti User
Posts: 247
Joined: Fri Dec 31, 2004 7:07 am
Location: UK

#2 Post by pshankland » Sun Jan 09, 2005 10:53 am

Data Templates & Screen-Shot
Attachments
cacti_data_template_microsoft_dhcp_free.xml
Data Template - DHCP Free
(6.52 KiB) Downloaded 2681 times
cacti_data_template_microsoft_dhcp_in_use.xml
Data Template - DHCP In Use
(6.52 KiB) Downloaded 2798 times
DHCP Example.jpg
Screenshot - The information has only just started populating so their is only a bit of data on the graph.
DHCP Example.jpg (50.23 KiB) Viewed 43439 times

vtmgr
Posts: 27
Joined: Wed Aug 11, 2004 2:23 pm
Location: Vermont, USA

Graph templates not showing up???

#3 Post by vtmgr » Thu Jan 13, 2005 2:29 pm

Hi,
This looks really useful, but...

I imported the templates, all seemed to go fine, put the XML script where it should go, and I can see the data queries, data templates, graph templates, etc.

However, when I go to a device and try to add the graph template, it doesn't show up in the "Add Graph Template" drop-down box.

Am I missing something?

I am running 0.8.6c on Win2k3, iis6, php 5, mysql 4.0.20

Thanks!

User avatar
pshankland
Cacti User
Posts: 247
Joined: Fri Dec 31, 2004 7:07 am
Location: UK

#4 Post by pshankland » Thu Jan 13, 2005 2:43 pm

It isn't in Associated Graph Templates, it can be found under Associated Data Queries as per the screenshot.

Pete.
Attachments
DHCP Data Query.jpg
DHCP Data Query.jpg (25.29 KiB) Viewed 43308 times

shadow1975
Posts: 32
Joined: Wed Mar 02, 2005 11:58 am

#5 Post by shadow1975 » Wed Mar 23, 2005 10:43 am

Hi thanks very much for this very usefull information. I was wondering if had a way to show total of use and free?

shadow1975
Posts: 32
Joined: Wed Mar 02, 2005 11:58 am

#6 Post by shadow1975 » Wed Mar 23, 2005 10:44 am

Hi thanks very much for this very usefull information. I was wondering if had a way to show total of use and free?

ggarbe
Posts: 6
Joined: Fri Apr 01, 2005 8:36 am
Contact:

for: pshankland

#7 Post by ggarbe » Tue Apr 05, 2005 9:26 am

Congratulations for your great job man! :P

I did like to know which the way to collect the DHCP data. I´m asking it to you because I have a very large subnete (B class) and when I add the DHCP graph statistics my POOLing process delay for a long time.

Without DHCP Statistics = 1 min.
With DHCP Statistics = 5 minuts (or more)

Know you about the reason to this are happen?

User avatar
mrh
Cacti User
Posts: 84
Joined: Tue Mar 08, 2005 9:50 am

#8 Post by mrh » Fri Mar 31, 2006 10:35 am

vtmgr: you need to import the xml just like a normal template, this will create the data query.
mrh | cacti 0.8.6h | plugin architecture | thold | monitor | iis6

that_kid
Posts: 29
Joined: Fri Mar 18, 2005 10:29 pm

#9 Post by that_kid » Fri Apr 07, 2006 11:45 am

Ok I can't get the microsoft_dhcp.xml file to import into cacti. I hit save and I don't get any indication that it was imported.

jazer
Posts: 3
Joined: Thu May 26, 2005 8:15 am
Location: Rome - Italy

#10 Post by jazer » Wed May 17, 2006 6:15 am

Ok I can't get the microsoft_dhcp.xml file to import into cacti. I hit save and I don't get any indication that it was imported.
I've the same same problem!

rickyboone
Posts: 4
Joined: Wed Aug 23, 2006 9:07 am

#11 Post by rickyboone » Tue Sep 05, 2006 12:21 pm

that_kid wrote:Ok I can't get the microsoft_dhcp.xml file to import into cacti. I hit save and I don't get any indication that it was imported.
The microsoft_dhcp.xml file isn't imported using the web interface. You'll need to save it in the $CACTI_ROOT/resource/snmp_queries directory, at least as far as I can tell. :)

that_kid
Posts: 29
Joined: Fri Mar 18, 2005 10:29 pm

#12 Post by that_kid » Tue Sep 05, 2006 12:25 pm

Ahh I'll give that a try, thanks

apperrault
Cacti User
Posts: 372
Joined: Fri Feb 16, 2007 11:37 am
Location: Emeryville, CA
Contact:

#13 Post by apperrault » Fri Apr 27, 2007 9:38 am

This is a great template. One question. Is there a way to add the Total DHCP addresses to the template. I know that i can just do a quick add when i am looking at the graph of the Free and Available, but if i could get a line at the top of the graph with the total, i can tell at a glance.

Thanks much

app
[b]Cacti Version[/b] - 0.8.7b
[b]Plugin Architecture[/b] - 2.2 Beta
[b]Poller Type[/b] - CMD.php
[b]Server Info[/b] - Linux 2.6.9-78.0.1.ELsmp
[b]Web Server[/b] - Apache/2.0.52 (Red Hat)
[b]PHP[/b] - 4.3.9
[b]MySQL[/b] - 4.1.22
[b]RRDTool[/b] - 1.2.23
[b]SNMP[/b] - 5.1.2
[b]Plugins[/b][list]Global Plugin Settings (settings - v0.5)
SuperLinks (superlinks - v0.72)
Host Info (hostinfo - v0.2)
Report Creator (reports - v0.3)
Update Checker (update - v0.4)
Realtime for Cacti (realtime - v0.35)
Cacti Log View (clog - v1.1)
RRD File Cleaner (rrdclean - v0.36)
Network Discovery (discovery - v0.9)
Uptime (uptime - v0.4)[/list]

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#14 Post by mcutting » Fri Apr 27, 2007 12:41 pm

Use a CDEF to do the maths. Once you have done this, you'll need to create another data source and apply this CDEF to it.

Have a look at the documentation for more info
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

dmace
Posts: 3
Joined: Tue Oct 17, 2006 6:09 am
Location: amsterdam, nl

#15 Post by dmace » Thu Jul 03, 2008 2:42 am

Great Work! Thanks!

Post Reply