Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Apr 19, 2019 6:30 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: icecast statistic
PostPosted: Mon May 23, 2005 5:13 pm 
Offline

Joined: Mon Nov 22, 2004 5:15 am
Posts: 38
Location: Zuerich; Switzerland
hello

i have finally done work on the script which reads the icecast2 xml file, to get the current listeners connected to my icecast2 server and put it into cacti...

this script is far away from a productive plug-in but it fullfills my actual needs.

my aim to publish it here whould be to find someone how whould like to help give it some great possibilities like:

- shoutcast - icecast support
- variables to set the host - password outside of the script
- and a lot more

here is it i hope it helps somone.

;-)

bbk


Attachments:
icecast0.zip [4.59 KiB]
Downloaded 2835 times
Top
 Profile  
 
 Post subject: Icecast 2 Listeners
PostPosted: Sat Oct 15, 2005 5:16 pm 
Offline

Joined: Mon Nov 22, 2004 5:15 am
Posts: 38
Location: Zuerich; Switzerland
Hi,

I did a small change:

- IP, User and Password can be given for each graph
- only Icecast2 support

You must have Cacti version 0.8.6c to import the templates but they are easy to create yourself.

Have fun - I hope one day someone will use it..... maybe.

Greets
Rik


Attachments:
File comment: Icecast2 Stats
v2.zip [6.34 KiB]
Downloaded 3356 times
Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 16, 2005 1:00 pm 
Offline
Cacti User
User avatar

Joined: Mon Apr 26, 2004 7:18 am
Posts: 68
Location: Switzerland
thanx for the script ! nice work

i will enhance this script or a similar scripts for monitoring different mountpoints.
btw i did allready a similar script for shoutcast servers. just search the forum.

cheers
tom

_________________
http://www.lounge-radio.com/


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 27, 2005 3:22 am 
Offline
Cacti User

Joined: Wed Jun 22, 2005 3:00 pm
Posts: 58
Hi
I have a small problem with your script, the graph alway show that there is 1 listener on the icecast server, but there is no one on it.


Attachments:
graph_20_1.png
graph_20_1.png [ 21.87 KiB | Viewed 38271 times ]

_________________
Visit my web site: http://www.websat-telecom.com
Top
 Profile  
 
 Post subject:
PostPosted: Sat Oct 29, 2005 4:47 am 
Offline

Joined: Tue May 10, 2005 9:27 am
Posts: 9
Thank you for this script.


Top
 Profile  
 
 Post subject: not working icecast2 stats
PostPosted: Tue Nov 08, 2005 3:03 am 
Offline

Joined: Mon Nov 22, 2004 5:15 am
Posts: 38
Location: Zuerich; Switzerland
hello websat

i had the same problem as well and then the connected listeners didn't reduce, that means i had about 200 listeners ;-) (great... but not true)

i checked the stats file of my icecast server and i found out that it was the problem.

my solution was to update the icecast server to the new version and then it worked like hell :P

hope it help's you (i think it is a problem of the icecast server 2.0)

greetz


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 27, 2006 4:04 am 
Offline
Cacti User

Joined: Wed Jun 22, 2005 3:00 pm
Posts: 58
websat wrote:
Hi
I have a small problem with your script, the graph alway show that there is 1 listener on the icecast server, but there is no one on it.


I reinstall cacti, and the icecast script, alway the same problem, is there someone who can make the script working well ?
thanks

_________________
Visit my web site: http://www.websat-telecom.com


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 27, 2006 5:09 am 
Offline

Joined: Mon Nov 22, 2004 5:15 am
Posts: 38
Location: Zuerich; Switzerland
What Version of Icecast do you have?

Did you check the http://www.yourserver.net:8000/admin/stats.xsl if there the number of listeners are correct?

When you have listeners on your stream, does it count them always +1, like 3 listeners = 4 in the stats?

for me i just upgraded the icecast software it self, not the cacti.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 27, 2006 1:05 pm 
Offline
Cacti User

Joined: Wed Jun 22, 2005 3:00 pm
Posts: 58
hi, thanks for your help, i have icecast 2.3.1 and the numbers of listeners is correct on the stats.xsl when i have 0 listener the stats.xsl show 0 and when i have 1 the stats.xsl show 1.

_________________
Visit my web site: http://www.websat-telecom.com


Top
 Profile  
 
 Post subject: Icecast 2.3.1
PostPosted: Tue Jul 25, 2006 9:16 am 
Offline

Joined: Mon Nov 22, 2004 5:15 am
Posts: 38
Location: Zuerich; Switzerland
finally I have a icecast 2.3.1 up and running.

just that I have a problem with ices 0.4.

after I solved ices...

I will test and modify the script to the needs of icecast 2.3.1.

.::BBK::.
www.audioasyl.net


Top
 Profile  
 
 Post subject: Help!!!!
PostPosted: Sat Dec 16, 2006 11:50 pm 
Offline

Joined: Sat Dec 16, 2006 11:38 pm
Posts: 1
Greetings!

Thanks for this excellent tool I believe that it is going to help to me much! I have the following problem: :oops: :oops: the truth is that not that he is what readme requests the arhivo to me to do, some of you podria to give an example me?



Thanks!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Dec 17, 2006 9:26 am 
Offline

Joined: Mon Nov 22, 2004 5:15 am
Posts: 38
Location: Zuerich; Switzerland
sorry....

i didn't understood your question about the readme.

do you want an example? of what?

about the posts before... i think the counter also counts a connected admin to the webinterface as an listener... that's why there is a 1.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jul 23, 2007 6:01 am 
Offline

Joined: Mon Jul 23, 2007 5:59 am
Posts: 1
Hi!
Could you post any "installation howto"? I've tried, but it doesn't work :(
The php script works (in cli, it prints the clients), but cacti doesn't paint the graph :S
Thanks!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 12, 2008 8:11 am 
Offline

Joined: Sun Oct 12, 2008 8:08 am
Posts: 1
e-Minguez wrote:
Hi!
Could you post any "installation howto"? I've tried, but it doesn't work :(
The php script works (in cli, it prints the clients), but cacti doesn't paint the graph :S
Thanks!


import the xml files, put the php files in the /scripts directory in cacti.
what I did additionally was to append "| tail -1 " to the input string in data input methods after the command to be executed (the first line is a blank when executing php -q .... and you get something like this the following in cacti.log:

10/12/2008 03:50:03 PM - CMDPHP: Poller[0] Host[22] DS[409] WARNING: Result from CMD not valid. Partial Result:

then it worked ;-)


Top
 Profile  
 
 Post subject: Back again.
PostPosted: Tue Apr 27, 2010 2:27 am 
Offline

Joined: Mon Nov 22, 2004 5:15 am
Posts: 38
Location: Zuerich; Switzerland
Ok.

Now after 5 years i come back to this plug in... it seems for me i still have a need for this :o

I am cleaning up the code a little bit.... i just discovered that the script was getting the wrong value.

I will build in the possibility to survey the listeners regarding multiple mountpoints.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group