Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Apr 19, 2019 1:41 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 35 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: RMON Group 1 Etherstats - Templates
PostPosted: Tue Jul 05, 2005 2:01 pm 
Offline
User avatar

Joined: Tue Aug 17, 2004 12:39 pm
Posts: 26
Location: London
I (unfortunately) still deal with quite a few managed hubs (in this case the Cisco Fasthub 424M) that can't really be monitored via the interface MIB. However they do present good info in their RMON MIB.

These templates (and a query based on the "interface.xml" query) should allow for creating graphs for any device that supports the standard RMON Group 1 Ethernet statistics MIB (from RFC 2819).

Screenshot of graphs attached.

Quote:
Files included:
cacti_data_query_rmon_interface_statistics.xml
cacti_data_template_rmon_mib_etherstats_broadcast_packets_in.xml
cacti_data_template_rmon_mib_etherstats_errors.xml
cacti_data_template_rmon_mib_etherstats_multicast_packets_in.xml
cacti_data_template_rmon_mib_etherstats_sizes.xml
cacti_data_template_rmon_mib_etherstats_total_packets_in.xml
cacti_graph_template_rmon_mib_etherstats_errors.xml
cacti_graph_template_rmon_mib_etherstats_multicast_broadcast_and_total.xml
cacti_graph_template_rmon_mib_etherstats_valid_sizes.xml


The design of the templates is not ideal and there's an unused field on the traffic data source template since it's copied straight from the bundled interfaces template.

I've never actually imported a template myself - so hopefully this is everything you need.


Attachments:
File comment: Updated 27th July
rmon_templates.tar.gz [15.6 KiB]
Downloaded 4253 times
File comment: Screenshot of all 4 graphs
rmonGraphs.jpg
rmonGraphs.jpg [ 98.14 KiB | Viewed 57308 times ]

_________________
Steve W


Last edited by stevew on Wed Jul 27, 2005 3:23 am, edited 1 time in total.
Top
 Profile  
 
 Post subject: Re: RMON Group 1 Etherstats - Templates
PostPosted: Tue Jul 26, 2005 12:01 pm 
Offline

Joined: Sat Nov 22, 2003 4:47 am
Posts: 3
Hi,

when i try to import files, I have errors on several files which are binary files instead of xml

what 's wrong ?

thanks
Luc

stevew wrote:
I (unfortunately) still deal with quite a few managed hubs (in this case the Cisco Fasthub 424M) that can't really be monitored via the interface MIB. However they do present good info in their RMON MIB.

These templates (and a query based on the "interface.xml" query) should allow for creating graphs for any device that supports the standard RMON Group 1 Ethernet statistics MIB (from RFC 2819).

Screenshot of graphs attached.

Quote:
Files included:
cacti_data_query_rmon_interface_statistics.xml
cacti_data_template_rmon_mib_etherstats_broadcast_packets_in.xml
cacti_data_template_rmon_mib_etherstats_errors.xml
cacti_data_template_rmon_mib_etherstats_multicast_packets_in.xml
cacti_data_template_rmon_mib_etherstats_sizes.xml
cacti_data_template_rmon_mib_etherstats_total_packets_in.xml
cacti_graph_template_rmon_mib_etherstats_errors.xml
cacti_graph_template_rmon_mib_etherstats_multicast_broadcast_and_total.xml
cacti_graph_template_rmon_mib_etherstats_valid_sizes.xml


The design of the templates is not ideal and there's an unused field on the traffic data source template since it's copied straight from the bundled interfaces template.

I've never actually imported a template myself - so hopefully this is everything you need.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jul 26, 2005 3:18 pm 
Offline
User avatar

Joined: Tue Aug 17, 2004 12:39 pm
Posts: 26
Location: London
Hi Luc,

I've just imported all successfully - except the data query which isn't in good condition. I'll post a new copy tomorrow when I get to work.

Which templates are you having trouble with?

Steve

_________________
Steve W


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 27, 2005 3:24 am 
Offline
User avatar

Joined: Tue Aug 17, 2004 12:39 pm
Posts: 26
Location: London
I have recreated the tarball on a different system and updated it in the original post.

_________________
Steve W


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 27, 2005 9:58 am 
Offline
Cacti User

Joined: Thu Oct 14, 2004 4:14 pm
Posts: 97
I'm very interested in this Cacti script, and have imported all the files into v0.8.6f on Windows. All imported ok, but the data query for the RMON Stats says 'Could not locate XML file'.

The query file (as imported) is named;

cacti_data_query_rmon_interface_statistics.xml

Yet the script being referenced in the data query is;

rmon-grp1-etherstats.xml

I have tried renaming the script, but Cacti still says it cannot be located.

Any ideas?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 27, 2005 10:35 am 
Offline

Joined: Mon May 23, 2005 8:20 am
Posts: 45
Location: France
i had the same problem than tman but when i changed file name, it was OK
me i have another problem
i create a device and in associated data queries, i choose "Rmon Interface Statistics"
in status of this data query i have Success [0 items , 0 rows]. I think this result is not normal
when i want to create a graph, i have these lines :
Warning: reset(): Passed variable is not an array or object in cacti_path\graphs_new.php on line 534

Warning: Variable passed to each() is not an array or object in cacti_path\graphs_new.php on line 535
Data Query [RMON - Interface Statistics]

Warning: reset(): Passed variable is not an array or object in cacti_path\graphs_new.php on line 610

Warning: Variable passed to each() is not an array or object in cacti_path\graphs_new.php on line 611

and :
This data query returned 0 rows, perhaps there was a problem executing this data query. You can run this data query in debug mode to get more information.

if i choose to run this data query in debug mode, page load but nothing happen

i use cacti 0.8.6f on a windows XP


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 28, 2005 3:42 am 
Offline
Cacti User

Joined: Thu Oct 14, 2004 4:14 pm
Posts: 97
Ok, sorted out the XML file location problem, but when I add the data query to the device, I now get the following errors;


Notice: Undefined index: oid_index in C:\Inetpub\wwwroot\cacti\lib\data_query.php on line 156

Notice: Undefined index: oid_index in C:\Inetpub\wwwroot\cacti\lib\data_query.php on line 159

Warning: Variable passed to each() is not an array or object in C:\Inetpub\wwwroot\cacti\lib\data_query.php on line 513

Warning: Cannot modify header information - headers already sent by (output started at C:\Inetpub\wwwroot\cacti\lib\data_query.php:156) in C:\Inetpub\wwwroot\cacti\host.php on line 110

Not quite the same as a2line59, but it isn't working!

I'm running a fully patched 0.8.6f by the way.


Top
 Profile  
 
 Post subject: Not only for HUBS
PostPosted: Wed Sep 14, 2005 3:50 am 
Offline

Joined: Wed Sep 14, 2005 3:48 am
Posts: 11
RMON is not only for HUBS, it provides much more info on switched Ethernet ports than the generic interface MIB.

Started experimenting with this package, info comes soon...

Best Regards,

Sarge


Top
 Profile  
 
 Post subject: Broken...
PostPosted: Wed Sep 14, 2005 4:23 am 
Offline

Joined: Wed Sep 14, 2005 3:48 am
Posts: 11
This package seems like broken.

I am going to play a little around it, it may be resurrected.

Best Regards,

Sarge


Top
 Profile  
 
 Post subject: Getting the picture...
PostPosted: Wed Sep 14, 2005 6:27 am 
Offline

Joined: Wed Sep 14, 2005 3:48 am
Posts: 11
Renaming cacti_data_query_rmon_interface_statistics.xml to the referenced file does not help, because that file is not the file supposed to be placed at <path_cacti>/resource/snmp_queries/rmon-grp1-etherstats.xml . It has a totally different structure...

Unfortunately our friend stevew forget to include the real rmon-grp1-etherstats.xml in the package...

Are you here stevew???

sarge


Top
 Profile  
 
 Post subject: Problem solved...
PostPosted: Thu Sep 15, 2005 5:09 am 
Offline

Joined: Wed Sep 14, 2005 3:48 am
Posts: 11
All of the scripts work, but you need to manually copy the attached file to <path_cacti>/resource/snmp_queries/rmon-grp1-etherstats.xml.

Errors, All/Multicast/Broadcast, and packet distribution work for me. I have not tested inBits, it is just stupid to use if you have data from the Interface MIB to plot (for example on switches).

Errors show collisions and fragments on half-duplex switch ports, which is the way half-duplex Ethernet works (these are not errors but the way of life for half-duplex), other errors are considered real errors, if you see any you should find the cause.

Packet distribution seems to be consistent also...

Feedback is welcomed,

Sarge


Attachments:
File comment: The correct XML file...
rmon-grp1-etherstats.xml [5.49 KiB]
Downloaded 4197 times
Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 19, 2005 8:46 am 
Offline
Cacti User

Joined: Thu Oct 14, 2004 4:14 pm
Posts: 97
Good work Sarge. I was a bit narked when these templates wouldn't initially work, but your mods have allowed me to import them all fine.

I have one problem with this now, and it appears to be just these templates, in that the RRD files won't create for them! Weird or what. I've added another (different) script after these, associated it with a host, and the RRD file appeared ok. I'm really not sure why they won't for this!


Top
 Profile  
 
 Post subject: RRDs are not created for RMON data sources...
PostPosted: Fri Sep 30, 2005 4:56 am 
Offline

Joined: Wed Sep 14, 2005 3:48 am
Posts: 11
RRDs are created for me. In that sense even stevew's scripts are OK, just the data collector was missing.

Another extra info, consider using CACTID collector, not the PHP based one. There is a lot of data to collect, and cactid is much more efficient...

Sarge


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 21, 2005 9:45 am 
Offline

Joined: Wed Sep 07, 2005 11:47 am
Posts: 4
Every time I try to import these files I get the following error message:

Quote:
Error: XML: Cacti version does not exist.


Anybody see this before?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 21, 2005 9:50 am 
Offline
Cacti Guru User
User avatar

Joined: Fri Sep 19, 2003 8:36 am
Posts: 2326
Location: Sophia-Antipolis, France
monkranter wrote:
Every time I try to import these files I get the following error message:

Quote:
Error: XML: Cacti version does not exist.


Anybody see this before?
Hi

you have to use at least the same version than stevew

What version of Cacti are you using ?

_________________

HOWTOs :
Templates :


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 35 posts ]  Go to page 1, 2, 3  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group