Liebert GXT UPS

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
Ragnar
Posts: 5
Joined: Thu Aug 04, 2005 10:33 am

Liebert GXT UPS

#1 Post by Ragnar » Thu Aug 04, 2005 10:37 am

Only supports single input/output Liebert UPSs, tested on a GXT2U with SNMP (not OCWEBCARD- but it should work on that as well).

I recommend setting your SNMP timeout higher than 500 (mine's set to 5000) since the cards have a tendancy to be slow to respond when you hammer them with requests.

Contains:
1 Host template - Liebert UPS
4 Graph templates - Battery, Input, Output, Output Watts
9 Data templates
Attachments
liebert.xml
XML Containing all templates.
(56.42 KiB) Downloaded 2609 times

axelilly
Posts: 27
Joined: Thu Aug 04, 2005 12:23 pm

#2 Post by axelilly » Thu Nov 03, 2005 9:46 am

Nice template.

However I have a Liebert nFinity UPS. The OIDs you used are not found on our UPS. The nFinity must have different MIBS. I'm currently looking for them to see if I can just update the OIDs that you used but keep your templates.

jeffmeden
Posts: 14
Joined: Wed Mar 10, 2004 12:55 pm
Location: Columbus, OH

Liebert GXT2U with newest card

#3 Post by jeffmeden » Tue Nov 22, 2005 11:14 am

This template works with GXT2U and Nfinity UPS' with the newest (OCWEB) card.

Here is my save of your template, corrected to work with a GXT2U and the current network card. I have never worked with templates like this before so if anyone can test it and provide feedback that would be great.

edit/update: I changed the naming on the template so it will allow for multiple types of liebert UPSs.

Another edit/update: I altered the limits, which were the only things stopping this from working with a Nfinity (since the voltages are much higher).

If anyone is using this template, i would love to hear from you.
Attachments
cacti_host_template_liebert_ocweb.xml
liebert ups with ocweb card
(57.8 KiB) Downloaded 1668 times

User avatar
dorje
Posts: 8
Joined: Wed Dec 01, 2004 9:14 pm
Location: Santorini of the South - New Zealand

Modifed - environment temp added

#4 Post by dorje » Mon Jun 12, 2006 11:20 pm

I've modified the cacti_host_template_liebert_ocweb.xml to include
- Overview graph of temp / batt time at current load / output load
- Temp graph

Got the TEMP OID here
http://support.ipmonitor.com/mibs/LIEBE ... /tree.aspx
Great resource

This is up and monitoring a Liebert NX40 ups

All Temps are in degrees Celcius (NOTE there is a degrees Fahrenheit OID)

Thanks to jeffmeden for the orignal
Attachments
cacti_host_template_liebert_ocweb.xml
(70.99 KiB) Downloaded 2578 times

keymaker
Posts: 1
Joined: Wed Jul 12, 2006 9:49 am
Location: Toronto, ON
Contact:

Re: Modifed - environment temp added

#5 Post by keymaker » Wed Jul 12, 2006 9:51 am

Works great with a GXT2U 2000VA. I had to bump the "run time remaining" since with 4 external batteries I have about 7000 minutes at no load :-)

asjl
Posts: 2
Joined: Thu Aug 10, 2006 5:47 pm
Location: Aotearoa

Re: Modifed - environment temp added

#6 Post by asjl » Thu Aug 24, 2006 7:34 pm

I tried importing the various Liebert templates posted by ragnar, jeffmeden and dorje but I got this:

Error: XML: Hash version does not exist.

Any pointers appreciated

User avatar
rony
Developer/Forum Admin
Posts: 6016
Joined: Mon Nov 17, 2003 6:35 pm
Location: Michigan, USA
Contact:

#7 Post by rony » Thu Aug 24, 2006 7:53 pm

The template is created in a newer version of Cacti than you are using.
[size=117][i][b]Tony Roman[/b][/i][/size]
[size=84][i]Experience is what causes a person to make new mistakes instead of old ones.[/i][/size]
[size=84][i]There are only 3 way to complete a project: Good, Fast or Cheap, pick two.[/i][/size]
[size=84][i]With age comes wisdom, what you choose to do with it determines whether or not you are wise.[/i][/size]

carlo
Posts: 7
Joined: Mon Sep 11, 2006 7:55 pm

#8 Post by carlo » Tue Oct 10, 2006 3:29 am

has anyone gotten this working in an NX40? I loaded the templates but dont get any data (except temprature).

I used a mib tool and I verified the templates are correct as the values are graphable from solarwinds.

anyone?? :)

EDIT: Okay saw that the last template is for a NX40

what firmware is your OCEWEB card running.

EDIT: Okay figured it out. I added a "." (ie. full stop) before the OID and they all started working. I also had to adjust the graph scales as the default was 500 but my battery voltage for example is 577.

unc-newbie
Posts: 1
Joined: Thu Mar 08, 2007 12:26 pm

#9 Post by unc-newbie » Thu Mar 08, 2007 12:31 pm

I found out that the Fahrenheit MIB is .1.3.6.1.4.1.476.1.42.3.4.1.2.3.1.3.1 and so i had already imported the template. So i just went into the cacti templates and changed the references to Celsius to Fahrenheit and then went and changed to OID to the correct one. Did a delete from all the data and recreated the graphs but it is not graphing the Fahrenheit. Any ideas.

Post Reply