plethora of windows nsclient scripts

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

plethora of windows nsclient scripts

#1 Post by Alives » Mon Sep 26, 2005 3:01 pm

This is a dump of all the templates i have made to run checks on my windows server environment. It uses a perl script to check against a windows machine running nsclient.

I just grouped all the templates into a host file. It is the standard windows 2000/xp name, so if you want to import it and preserve your original file, either back it up or rename it.

I have included the perl script to check as well.

I have also included the Perfmon template which is bascially what all these run off of.

Template list:
Windows - .NET CLR Exceptions - aspnet_wp - # of Exceps Thrown / sec
Windows - .NET CLR Memory - aspnet_wp - # Gen 0 Collections
Windows - .NET CLR Memory - aspnet_wp - # Gen 1 Collections
Windows - .NET CLR Memory - aspnet_wp - # Gen 2 Collections
Windows - .NET CLR Memory - aspnet_wp - % Time in GC
Windows - ASP - Errors During Script Runtime
Windows - ASP - Errors From Script Compilers
Windows - ASP - Request Wait Time
Windows - ASP - Requests Rejected
Windows - ASP - Sessions Current
Windows - ASP.NET - Application Restarts
Windows - ASP.NET - Request Execution Time
Windows - ASP.NET - Request Wait Time
Windows - ASP.NET - Requests Current
Windows - ASP.NET - Requests Rejected
Windows - ASP.NET - Worker Process Restarts
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Cache Total Entries
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Cache Total Hit Ratio
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Cache Total Turnover Rate
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Compilations Total
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Errors During Execution
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Errors During Preprocessing
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Errors Unhandled During Execution
Windows - ASP.NET Applications - _LM_W3SVC_4_Root - Pipeline Instance Count
Windows - CPU Load
Windows - Disk Usage
Windows - IIS - Current Connections
Windows - Memory - Page Faults/sec
Windows - Memory - Usage
Windows - Perfmon Data
Windows - PhysicalDisk - Disk Queue Length
Windows - Process - aspnet_wp - % Processor Time
Windows - Process - aspnet_wp - Handle Count
Windows - Process - aspnet_wp - Private Bytes
Windows - Process - aspnet_wp - Virtual Bytes
Windows - SQL - Connections
Windows - SQL - Lock Timeouts/sec
Windows - SQL - Lock Wait Time (ms)
Windows - TS - Active Sessions
Attachments
Cacti-Windows-templates.zip
(34.52 KiB) Downloaded 8632 times

spoonman
Cacti User
Posts: 298
Joined: Tue May 03, 2005 8:54 am
Location: GA

#2 Post by spoonman » Mon Oct 03, 2005 3:44 pm

You Da PIMP!

Awesome THX!!!!!

Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

#3 Post by Alives » Mon Oct 03, 2005 4:45 pm

ha thanks... you can use the perfmon template to query anything from perfmon...thats what most of those do...

s16pt
Posts: 17
Joined: Mon Sep 12, 2005 12:03 am

#4 Post by s16pt » Wed Nov 09, 2005 8:30 pm

How do I add a item to show processor queue length ? Need your help.
Thanks.

Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

#5 Post by Alives » Wed Nov 09, 2005 8:32 pm

take a look at the data sources and you will see how they send the perf counter info to be checked. just duplicate a datasource and graph and set them up to check the new counter.

nduda78
Cacti User
Posts: 106
Joined: Tue Mar 01, 2005 11:26 am
Contact:

#6 Post by nduda78 » Thu Nov 10, 2005 9:46 am

can you give me an example, step by tep how to add the perl script in cacti. I have them in the folder, and the template imported. I'm new.

spignataro
Posts: 41
Joined: Mon Nov 07, 2005 11:21 pm

#7 Post by spignataro » Thu Nov 10, 2005 10:14 am

how do i get this to read off a server. If i have a Windows 2000 server I have to enable something. What do I enable. I have no problem monitoring my routers as it is just a simple string for the community. But what do you turn on or where is it on the windows box.

Thanks much for your help. O and thanks for the templates as this will be quite usefull for all our servers.

Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

#8 Post by Alives » Thu Nov 10, 2005 11:12 am

Topic says NSClient...

http://nsclient.ready2run.nl/ <- nsclient official site

Its used for nagios to check windows servers from linux.

If you are running cacti on a windows host i would recommend you rewrite the scripts to use Win32::PerfMon module instead as it will be cleaner and more secure. Also you will have access to WMI.

Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

#9 Post by Alives » Thu Nov 10, 2005 11:14 am

nduda78 wrote:can you give me an example, step by tep how to add the perl script in cacti. I have them in the folder, and the template imported. I'm new.
copy them to the cacti/scripts folder. I dont understand your question.

s16pt
Posts: 17
Joined: Mon Sep 12, 2005 12:03 am

#10 Post by s16pt » Sun Nov 13, 2005 9:30 pm

After I duplicate data source template ,graph template and host template and
modified some parameter.I got the graph as I want.

Thanks,

Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

#11 Post by Alives » Sun Nov 13, 2005 10:05 pm

no problem.. congratulations!

post your new template for the community

cactus_jack
Posts: 29
Joined: Mon Apr 11, 2005 9:31 am

#12 Post by cactus_jack » Tue Nov 15, 2005 8:45 am

Would these work for Windows 2003 as well or have the wmi labels changed?

Vince

Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

#13 Post by Alives » Tue Nov 15, 2005 9:40 am

THESE ARE NSCLIENT SCRIPTS... please read

kghammond
Posts: 9
Joined: Wed Nov 16, 2005 5:36 pm
Contact:

#14 Post by kghammond » Wed Nov 16, 2005 5:37 pm

I am getting the following error trying to import the template in 0.86g

Error: XML: Cacti version does not exist.

I have searched for this error message and it says I should only get this if the template is from a newer version of Cacti, but I am running the latest version.

What am I missing?

Alives
Cacti User
Posts: 103
Joined: Mon Jul 11, 2005 11:39 am

#15 Post by Alives » Wed Nov 16, 2005 5:48 pm

did you run the official patches too?

Post Reply