Error: XML: Hash version does not exist.

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
africanw
Cacti User
Posts: 124
Joined: Thu Mar 31, 2005 4:24 pm
Location: Sydney, Asutralia
Contact:

Error: XML: Hash version does not exist.

#1 Post by africanw » Fri Apr 08, 2005 12:11 pm

Hi,

I am running cacti verion 0.86c. I created graph/data templates which work on the 0.86c install and exported them. I then tried to import them into a 0.86b install and get this error:

Error: XML: Hash version does not exist.

Is it not possible to import templates from a later verion of cacti into an older version? Or is there something wrong with my templates?

Thanks

Grant
Attachments
IIS - WWW Connections NSCLIENT.rar
(4.34 KiB) Downloaded 509 times

User avatar
rony
Developer/Forum Admin
Posts: 6016
Joined: Mon Nov 17, 2003 6:35 pm
Location: Michigan, USA
Contact:

#2 Post by rony » Fri Apr 08, 2005 12:33 pm

Newer templates will not import into older version. That is the problem you are having.
[size=117][i][b]Tony Roman[/b][/i][/size]
[size=84][i]Experience is what causes a person to make new mistakes instead of old ones.[/i][/size]
[size=84][i]There are only 3 way to complete a project: Good, Fast or Cheap, pick two.[/i][/size]
[size=84][i]With age comes wisdom, what you choose to do with it determines whether or not you are wise.[/i][/size]

africanw
Cacti User
Posts: 124
Joined: Thu Mar 31, 2005 4:24 pm
Location: Sydney, Asutralia
Contact:

#3 Post by africanw » Fri Apr 08, 2005 12:36 pm

Fair enough....

ty

vivoli
Posts: 1
Joined: Wed May 24, 2006 9:17 am

#4 Post by vivoli » Wed May 24, 2006 9:21 am

I have a error, when i import templates :

TCP & HTTP :
http://forums.cacti.net/viewtopic.php?t=11020
MySQL :
http://forums.cacti.net/viewtopic.php?t=11010

"Error: XML: Hash version does not exist."

but i have the last Version 0.8.6h

my config_arrays.php :
$hash_version_codes = array(
"0.8.4" => "0000",
"0.8.5" => "0001",
"0.8.5a" => "0002",
"0.8.6" => "0003",
"0.8.6a" => "0004",
"0.8.6b" => "0005",
"0.8.6c" => "0006",
"0.8.6d" => "0007",
"0.8.6e" => "0008",
"0.8.6f" => "0009",
"0.8.6g" => "0010",
"0.8.6h" => "0011"
);

nilantha
Posts: 1
Joined: Tue Jul 28, 2009 12:04 am

#5 Post by nilantha » Tue Jul 28, 2009 2:41 am

rony wrote:Newer templates will not import into older version. That is the problem you are having.
how to find templates for older versions

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

#6 Post by gandalf » Tue Jul 28, 2009 2:17 pm

By asking the author to provide it, if possible
Reinhard

Post Reply