Search found 129 matches

by fletch
Tue Jul 30, 2013 1:18 am
Forum: Help: General
Topic: What can cause a cacti graph to look like this?
Replies: 7
Views: 798

Re: What can cause a cacti graph to look like this?

Here is the script I used to tune the MAX DS value up - graphs look correct now - I was surprised there were 800+ of them. #!/bin/csh set x = 0 while ( $x < 10 ) foreach i (`ls /var/www/html/rra/*traffic*$x.rrd`) rrdtool info $i | egrep 'max' | egrep '1.0000000000e\+07' >& /dev/null if ( ! $status )...
by fletch
Tue Jul 23, 2013 12:45 pm
Forum: Help: General
Topic: What can cause a cacti graph to look like this?
Replies: 7
Views: 798

Re: What can cause a cacti graph to look like this?

Good version (max is 1Gb): [[email protected] ~]# rrdtool info /var/www/html/rra/ccsr-01-dcs-switch2_traffic_in_7208.rrd | egrep max ds[traffic_in].max = 1.0000000000e+09 ds[traffic_out].max = 1.0000000000e+09 Bad version (max is too low 10 Mb): [[email protected] ~]# rrdtool info /var/www/html/rra/...
by fletch
Sun Jul 21, 2013 1:16 am
Forum: Help: General
Topic: What can cause a cacti graph to look like this?
Replies: 7
Views: 798

Re: What can cause a cacti graph to look like this?

What's the best way to check the upper limit for a specific graph? (these settings should come from the HP Procurve template - correct)?
Is there a way to make cacti log "exceeded upper limit" or "can't record OID due to"...any other reason.

thanks
by fletch
Sat Jul 20, 2013 7:03 pm
Forum: Help: General
Topic: What can cause a cacti graph to look like this?
Replies: 7
Views: 798

Re: What can cause a cacti graph to look like this?

I did not see timeouts or errors pertaining to this switch.
I created a 32 bit version of the same switch port - check out how completely different they are!

(The 32 bit version on the right has no gaps - what the heck is the 64bit version doing ?)
gappy64nogaps32bit.jpg
gappy64nogaps32bit.jpg (76.3 KiB) Viewed 768 times
thanks
by fletch
Fri Jul 19, 2013 1:36 am
Forum: Help: General
Topic: What can cause a cacti graph to look like this?
Replies: 7
Views: 798

What can cause a cacti graph to look like this?

Cacti v 0.8.7g
HP Procurve template graph of a 1 Gb switch port.
There are a small percentage (1-2%) of these procurve graphs which exhibit this.
The switches are responsive - 64 bit counters are in use.
cacti.log does not show errors or timeouts.

thanks for any tips!

Fletch.
by fletch
Fri Nov 16, 2012 5:54 pm
Forum: Help: General
Topic: Grey gaps on one switch port but not others
Replies: 1
Views: 324

Grey gaps on one switch port but not others

Hi - we are trying to debug why port F4 on our HP (ProCurve Switch 5406zl(J8697A)) K.15.04.0015m,ROMK.15.28 is showing these grey gaps in cacti 0.8.7g I've already tried dropping the graph and datasource and re-creating...the other ports, including F3 right next to it are fine (no gaps)...the switch...
by fletch
Mon Oct 03, 2011 10:36 pm
Forum: Help: General
Topic: mysql syslog how to purge/shrink?
Replies: 3
Views: 3494

Re: mysql syslog how to purge/shrink?

Worked like a charm!
thanks Witness,

Fletch.
by fletch
Mon Oct 03, 2011 7:12 pm
Forum: Help: General
Topic: mysql syslog how to purge/shrink?
Replies: 3
Views: 3494

mysql syslog how to purge/shrink?

Hi all - these syslog mysql files are blowing up my disk space - can someone recommend how to purge/shrink them back down? [[email protected] syslog]# du -skh * 8.0K db.opt 16K syslog_alert.frm 0 syslog_alert.MYD 8.0K syslog_alert.MYI 16K syslog.frm 16K syslog_incoming.frm 1.3G syslog_incoming.MYD 202M ...
by fletch
Tue Aug 16, 2011 5:42 pm
Forum: Scripts and Templates
Topic: HP Procurve MIB shows Hardware status? - OIDs?
Replies: 0
Views: 1243

HP Procurve MIB shows Hardware status? - OIDs?

We had 1 of the redundant power supplies fail on a HP Procurve 5406zl switch and so we are researching if the Procurve MIB exposes the hardware (Power, Fan, memory etc) status? I found a download link on the HP site, exploring the MIB its not obvious what the OIDs are... Anyone have the OIDs for pow...
by fletch
Thu Jan 20, 2011 7:37 pm
Forum: Help: General
Topic: switch interface datasources showing inconsistent maximums?
Replies: 1
Views: 333

switch interface datasources showing inconsistent maximums?

Hi, I am investigating why one switch interface is not graphing the traffic. I discovered the "Maximum Value" for traffic_in (and traffic_out) are not consistent - some have 0, some 10000000 (as in the problem case) and some 1000000000. At first I thought it was a 32 bit counter wrapping issue - but...
by fletch
Wed Dec 15, 2010 4:59 pm
Forum: Help: General
Topic: Procurve port counter numbers descrease?
Replies: 5
Views: 1487

Re: Procurve port counter numbers descrease?

:oops: how do I get the OID from the cacti graph? :oops:

then I'll try snmpget :D
by fletch
Wed Dec 15, 2010 4:54 pm
Forum: Help: General
Topic: Procurve port counter numbers descrease?
Replies: 5
Views: 1487

Re: Procurve port counter numbers descrease?

Not a wrap - only ~ 13% utilization and my queries are about 1 second apart

Our network group is going to apply a firmware upgrade and see if it persists

thanks
by fletch
Tue Dec 14, 2010 3:19 pm
Forum: Help: General
Topic: Procurve port counter numbers descrease?
Replies: 5
Views: 1487

Procurve port counter numbers descrease?

Hi, I was investigating why cacti was not reliably graphing the outbound bandwidth for one port on one of our HP Procurve switches. I’ve never seen this before – it appears the tx counter for interface D11 (in bold below) is not increasing as expected – but jumping up and down. This would cause cact...
by fletch
Thu Oct 07, 2010 1:04 pm
Forum: Help: General
Topic: plugins looking for images in wrong path after upgrade
Replies: 6
Views: 1856

Re: plugins looking for images in wrong path after upgrade

AWESOME :D

adding $url_path = "/";
to include/config.php fixed it!

I believe this used to be handled in include/global.php with:

$config['url_path'] = '/';

but was not longer doing it after the upgrade and patches
by fletch
Mon Oct 04, 2010 12:59 pm
Forum: Help: General
Topic: plugins looking for images in wrong path after upgrade
Replies: 6
Views: 1856

Re: plugins looking for images in wrong path after upgrade

I don't know how to fix is globally for all plugins, but for the weathermap plugin I fixed its appearance by reviewing the http error log for 404s and creating 3 symlinks: 1020 cd /var/www/html/plugins/weathermap 1021 cd images 1022 ln -s ../../../images/* . 1023 tail -90f /etc/httpd/logs/error_log ...