Search found 61 matches

by iggi
Thu Mar 01, 2012 8:10 pm
Forum: Addons for Cacti
Topic: Addon getting a graph & rrd id from cacti or DB
Replies: 1
Views: 2081

Addon getting a graph & rrd id from cacti or DB

I'm attempting to write an addon (or more of an export data script) that uses the graph export script to export the graphs to another server and then on that other server I need to be able to pull up the graph and some information derived from the RRD file. I can specify the data_template_id, host_i...
by iggi
Mon Dec 05, 2011 12:44 pm
Forum: Help: General
Topic: Custom Graph Time Range Broken In 0.8.7h
Replies: 3
Views: 563

Re: Custom Graph Time Range Broken In 0.8.7h

I grabbed the most recent 0.8.7h files and replaced timespan_settings.php, but it looks like it still doesn't work. Looks like I will have to try replacing the entire directory from SVN unless there is another suggestion?
by iggi
Sat Nov 26, 2011 11:22 am
Forum: Help: General
Topic: Custom Graph Time Range Broken In 0.8.7h
Replies: 3
Views: 563

Custom Graph Time Range Broken In 0.8.7h

I seem to have an issue with specifying a custom graph time period in the tree view, e.g. if I specify a start of 2011-10-01 00:00 and an end of 2011-11-01 00:00 both input fields get cleared and the page refreshes to a default 1 day time range. This happens with all time ranges entered, the only wa...
by iggi
Tue Oct 11, 2011 3:14 pm
Forum: Help: Windows Specific
Topic: nan's on interface graph, windows only
Replies: 2
Views: 1398

nan's on interface graph, windows only

I have an interface graph that works on all other hosts (Unix, Linux, Cisco, etc.) but does not work on my windows host. I have checked the RRD is created, but contains all nan values. The SNMP - Interface Statistics data query is associated with the host and other graphs work fine on the host. When...
by iggi
Fri Oct 07, 2011 12:48 am
Forum: Plugin: (MAC Track)
Topic: SNMP Options error
Replies: 10
Views: 4038

Re: SNMP Options error

Send me a message on Skype if you want to test/troubleshoot anything this weekend.
by iggi
Thu Oct 06, 2011 1:33 pm
Forum: Plugin: (MAC Track)
Topic: SNMP Options error
Replies: 10
Views: 4038

Re: SNMP Options error

What do you mean? Do I have to add a SQL table? or something else.
by iggi
Tue Oct 04, 2011 3:36 pm
Forum: Plugin: (MAC Track)
Topic: SNMP Options error
Replies: 10
Views: 4038

SNMP Options error

When I try to add SNMP options under a SNMP Options Set I get the error "Error: Save Failed: Field Input Error (Check Red Fields)." when there are no fields colored in red. See Attached image.
by iggi
Tue Oct 04, 2011 3:31 pm
Forum: Help: General
Topic: -nan values on all included graphs
Replies: 1
Views: 345

-nan values on all included graphs

After the install of cacti the included graphs (Load Average, Processes, etc.) showed just fine (the ones created by the installer), but once I deleted the graphs (not graph templates, those are in tact) and re created them, they no longer work. I tried the debugging page, but I cannot seem to find ...
by iggi
Thu Sep 29, 2011 9:45 pm
Forum: Help: General
Topic: Graph Template not showing 95th percentile and Total
Replies: 0
Views: 484

Graph Template not showing 95th percentile and Total

I was attempting to make a graph template that combines both the 95th percentile graph (Separated) and total bandwidth graphs. I was able to get everything working with the exception of the total bandwidth which reads 0 bytes on every graph. See the attached image for a picture of the items in the g...
by iggi
Fri Sep 17, 2010 8:35 am
Forum: Plugin Development
Topic: SQL Query For Relating Host, RRD File (rra), and Graph ID
Replies: 2
Views: 3917

Thank you gandalf, this really does help, but I am noticing one thing that is causing an issue for the query I am trying to write. In graph_tree_items rra_id appears as it relates to the id column in rra, but in my graph_tree_items tables, the entire rra_id column are 1's
by iggi
Mon Sep 13, 2010 5:04 pm
Forum: Plugin Development
Topic: SQL Query For Relating Host, RRD File (rra), and Graph ID
Replies: 2
Views: 3917

SQL Query For Relating Host, RRD File (rra), and Graph ID

I wrote a script, which in an archaic way references the RRD # and host id (I have a structured directory) and sends it to a script on my cacti server from my web server, then returns the data as XML, then it also pulls the graph from an internal path on the webserver where graphs are exported. All ...
by iggi
Mon Sep 13, 2010 4:04 pm
Forum: Help: General
Topic: Broken Forums?
Replies: 1
Views: 350

Broken Forums?

When I try to post on the forums, I get the following error: Error in posting DEBUG MODE SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' forum_topics = forum_topics + 1 WHERE forum_id = 23' at li...
by iggi
Sun May 02, 2010 10:42 pm
Forum: Plugin: (Threshold)
Topic: Threshold will not trigger
Replies: 1
Views: 957

Threshold will not trigger

I have one threshold just to get the system to work and for the life of me I cannot get it to trigger. If you look at the attached images you can see that I have the thold set 2260630 to 2260645, yet the current value is 2192849.6316. If I am not mistaken 2192849 < 2260645 which should cause an imme...
by iggi
Sun May 02, 2010 10:33 pm
Forum: Plugin: (Threshold)
Topic: Thold refencing all links within plugin directory
Replies: 1
Views: 822

Thold refencing all links within plugin directory

Whenever I click on a link for the thold plugin, any other link I click on (even thold links) reference invalid links within the thold directory i.e.: Not Found The requested URL /cacti/plugins/thold/plugins/thold/thold_templates.php was not found on this server. I am using the ssl plugin if that ma...
by iggi
Fri Apr 16, 2010 9:10 am
Forum: Help: General
Topic: Some graphs stopped graphing, but not all
Replies: 4
Views: 620

I ran that and it did not resolve the issue, any other ideas?