Search found 46 matches

by gundalba
Tue Feb 04, 2020 1:50 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

Cool that you are back up and running I would do this 1.) Create the Devices 2.) wait for the RRA's to be created 3.) copy/replace the RRA's from the old sub folder that should fo the trick I was hoping to be able to import old data from the dB - thus the backup? - as I got couple hundred devices t...
by gundalba
Fri Jan 31, 2020 3:55 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

try dropping the cacti db and create a new one see if the install works if it does then you can concentrate on whats going on with the current db Ok, I've zipped up the ~cacti/ folder with "tar zcvfh" just in case and the cacti dB got dropped from mariadb, which initialized the WebUI Instl. Wiz. ju...
by gundalba
Fri Jan 31, 2020 12:12 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

seanmancini wrote:
Fri Jan 31, 2020 11:30 am
try dropping the cacti db and create a new one
see if the install works if it does then you can concentrate on whats going on with the current db
Let me see if I can figure out how to do that and try...
by gundalba
Fri Jan 31, 2020 12:11 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

what does your cacti.log show as the errors ? should be in /var/www/html/cacti/log/cacti.log Here is the log file from the point where client cache/cookie cleared and logged in which will lead directly to "1.2.8 installed with error" screen. 2020/01/31 09:03:37 - AUTH DEBUG: User 'admin' attempting...
by gundalba
Thu Jan 30, 2020 8:01 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

then you can try to run the cacti db upgrade script sudo -ucac php -q cli/upgrade_database.php --forcever=`cat include/cacti_version` else try to reinstall mariadb : : : hey! shouldn't be a problem 10.1 works fine Good to know, thanks. As upgrade_database.php ran but did nothing (I think) saying it...
by gundalba
Thu Jan 30, 2020 1:26 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

Wow something seriously took a dump ok Specified key was too long; max key length is 767 bytes is because you were missing the large_prefix looking like the reload of the service originally did not pick up the changes ?? do a mysqldump save the db then you can try to run the cacti db upgrade script...
by gundalba
Wed Jan 29, 2020 7:20 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

Is version 10 supported in Cacti? Thank you but I am not sure sure on that. Not too experienced with dB in general here.... Should I uninstall this and try 5.5.64? Below is what yum notes on current version and not sure why one is "client" and the other is just mariadb-5.5.64 either.... [*]Package ...
by gundalba
Wed Jan 29, 2020 1:34 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

Tried manual run of the failed script but it don't seem to work???? # mysql -u root -p mysql Enter password: Reading table information for completion of table and column names You can turn off this feature to get a quicker startup with -A Welcome to the MariaDB monitor. Commands end with ; or \g. Yo...
by gundalba
Wed Jan 29, 2020 12:42 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Re: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

Thank you Sean, Few questions on your answer... Hopefully, you made a backup of the DB before you ran the upgrade Ouch! Too late on this I guess... I would run the command manually in this case login to the mysql shell i.e mysql -u root -p; select the cacti db i.e use cacti then run the alter comman...
by gundalba
Tue Jan 28, 2020 6:58 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)
Replies: 19
Views: 203

Cacti post-upgrade(1.2.2->1.2.8) config failure on dB update(1.2.3->1.2.5)

Hello All, OS: Centos 7 on VMWare 3.10.0-957.5.1.el7.x86_64 #1 SMP Fri Feb 1 14:54:57 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux Upgrade from/to: Cacti 1.2.2 -> 1.2.8 Just tried upgrading Cacti via yum and post upgrade config (web UI) failed and stuck there. Attached is the screen shot.. Any help will ...
by gundalba
Mon Jun 03, 2019 1:22 pm
Forum: Help: General
Topic: Unable to change a graph template on a CICSO interface
Replies: 1
Views: 294

Re: Unable to change a graph template on a CICSO interface

Please disregard this... Just found that the graph needs to be unlocked first.

Thank you!
by gundalba
Mon Jun 03, 2019 1:05 pm
Forum: Help: General
Topic: Unable to change a graph template on a CICSO interface
Replies: 1
Views: 294

Unable to change a graph template on a CICSO interface

Hello there, I have following running on CentOS 7 Cacti Version 1.2.2 MariaDB And when I attempted to change the template being used on a Cisco Interface Traffic graph, I am finding I am unable to change it as drop-down selection is grayed out. Below is the screen shot of it and any help on this is ...
by gundalba
Mon May 06, 2019 4:49 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti 1.2.2 upgrade / reinstall issue
Replies: 5
Views: 1478

Re: Cacti 1.2.2 upgrade / reinstall issue

Thank you NetniV,

Removing Cacti logrotate under /etc/rogrotate.d fixed the issue.
May be it was not cleaned out during the upgrade???

Cheers,
by gundalba
Thu Apr 25, 2019 1:46 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti 1.2.2 upgrade / reinstall issue
Replies: 5
Views: 1478

Re: Cacti 1.2.2 upgrade / reinstall issue

It doesn't sound like the database upgrade has actually taken. Are you sure the upgrade was performed properly and not just the files updated? sudo -u <website user> php cli/upgrade_database.php --forcever=1.1.9 Thank you for looking into this netniV. Prior to your reply, tried few things like chan...
by gundalba
Wed Apr 10, 2019 12:58 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti 1.2.2 upgrade / reinstall issue
Replies: 5
Views: 1478

Cacti 1.2.2 upgrade / reinstall issue

O/S : CentOS 7 dB: mariadb.x86_64 1:5.5.56-2.el7 rrd: rrdtool-1.4.8-9.el7.x86_64 PHP: 5.4.16-42.el7 Hello, After some issues with rrd file permission issues, I've decided to do another upgrade from 1.1.9 to 1.2.2 couple weeks ago. Upgrade seem to went ok but I found it stopped the graph update compl...