Search found 301 matches

by stormonts
Tue Nov 26, 2019 1:43 pm
Forum: Help: Linux/Unix Specific
Topic: Unable to move Cacti to new server
Replies: 10
Views: 486

Re: Unable to move Cacti to new server

PCRE library had to be re-compiled with the UTF8 and UTF8 properties support.
by stormonts
Tue Oct 22, 2019 2:23 pm
Forum: Help: General
Topic: Some graphs using the ucd/net memory template starting showing negative amounts
Replies: 8
Views: 746

Re: Some graphs using the ucd/net memory template starting showing negative amounts

I ended up having to re-work the CDEFs and also re-organized that graphs items (which then required more CDEF work).
by stormonts
Mon Oct 21, 2019 8:14 am
Forum: Help: General
Topic: Need help with CDEF creation
Replies: 3
Views: 560

Re: Need help with CDEF creation

Thank you! I tried 3-4 other RPN calculators but could not get the syntax correct for input. I have saved the link to the one that you provided as it is much easier!
by stormonts
Mon Oct 21, 2019 8:04 am
Forum: Help: General
Topic: Some graphs using the ucd/net memory template starting showing negative amounts
Replies: 8
Views: 746

Re: Some graphs using the ucd/net memory template starting showing negative amounts

Actually, it looks like the math on the graphs was never totally correct and cached memory was being shown as a separate item and not subtracted from free memory. When we went to CentOS 7, we stopped using swap which then further changed the calculations enough to make this issue obvious.
by stormonts
Thu Oct 17, 2019 11:55 am
Forum: Help: General
Topic: Need help with CDEF creation
Replies: 3
Views: 560

Need help with CDEF creation

I am trying to create a CDEF that says totals "b" + "c" + "f", subtracts that from "a" and then multiplies that by 1024 and I am stuck.
by stormonts
Tue Oct 15, 2019 12:58 pm
Forum: Help: General
Topic: Some graphs using the ucd/net memory template starting showing negative amounts
Replies: 8
Views: 746

Re: Some graphs using the ucd/net memory template starting showing negative amounts

This is the CDEF and graph template that haven't changed since we first used them.
graph.png
graph.png (127.47 KiB) Viewed 653 times
by stormonts
Sat Oct 12, 2019 3:10 pm
Forum: Help: General
Topic: Some graphs using the ucd/net memory template starting showing negative amounts
Replies: 8
Views: 746

Re: Some graphs using the ucd/net memory template starting showing negative amounts

I don't see anything wrong? 2019/10/12 16:03:06 - SPINE: Poller[1] PID[12991] DEBUG: In Poller, About to Start Polling of Device for Device ID 290 2019/10/12 16:03:06 - SPINE: Poller[1] PID[12991] NOTE: Device[290] Updating Full System Information Table 2019/10/12 16:03:06 - SPINE: Poller[1] PID[129...
by stormonts
Fri Oct 11, 2019 1:51 pm
Forum: Help: General
Topic: Some graphs using the ucd/net memory template starting showing negative amounts
Replies: 8
Views: 746

Some graphs using the ucd/net memory template starting showing negative amounts

We are running Cacti 1.2.7 and recently, a number of our graphs that use the ucd/net memory template started showing negative amounts of "Memory Used". memory.png The math seems right when subtracting Memory Free from Total Memory, but it is now just negative. All servers use the same template, but ...
by stormonts
Wed Sep 18, 2019 3:34 pm
Forum: Help: General
Topic: Cacti 1.2.6 is incredibly slow to display graphs and Boost seems to have stopped
Replies: 3
Views: 758

Re: Cacti 1.2.6 is incredibly slow to display graphs

I found a complaint about Boost slowing down after the upgrade to 1.2.6 (https://github.com/Cacti/cacti/issues/2929) and then looked at my settings where I saw the same thing happening. These number keep growing and growing and I wonder if that is what is making our server so slow (it does have 40 c...
by stormonts
Wed Sep 18, 2019 8:48 am
Forum: Help: General
Topic: Cacti 1.2.6 is incredibly slow to display graphs and Boost seems to have stopped
Replies: 3
Views: 758

Cacti 1.2.6 is incredibly slow to display graphs and Boost seems to have stopped

We were running 1.2.4 and when you click on a folder in the graph tree, the graphs would all be shown immediately (10 graphs per page). We upgraded to 1.2.6 and it takes minutes for the same 10 graphs to be displayed if they are even displayed at all. Does anyone have any ideas what might be causing...
by stormonts
Fri Sep 13, 2019 9:30 am
Forum: Help: Linux/Unix Specific
Topic: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6
Replies: 17
Views: 443

Re: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6

We think it is because we are using a symlink to point to the new directory and php-fpm had already cached the link (which had been pointing to the old location when it was cached) and restarting it caused php-fpm to grab the updated symlink.
by stormonts
Thu Sep 12, 2019 1:41 pm
Forum: Help: Linux/Unix Specific
Topic: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6
Replies: 17
Views: 443

Re: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6

Turns out that php-fpm was the problem. Once restarted, the installation continued as normal.
by stormonts
Wed Sep 11, 2019 2:33 pm
Forum: Help: Linux/Unix Specific
Topic: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6
Replies: 17
Views: 443

Re: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6

I am totally out of ideas on this one. Where we are now: httpd.conf points to /usr/local/cacti symlink = /usr/local/cacti-1.2.4 -> /usr/local/cacti path_webroot = /usr/local/cacti-1.2.4 Cacti 1.2.4 WORKS symlink = /usr/local/cacti-1.2.4 -> /usr/local/cacti path_webroot = /usr/local/cacti Cacti 1.2.4...
by stormonts
Wed Sep 11, 2019 10:18 am
Forum: Help: Linux/Unix Specific
Topic: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6
Replies: 17
Views: 443

Re: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6

That then got me to this screen. Definitely still something off given the references to both 1.2.4 and 1.2.6. When I click in the box to accept the agreement, I get a spinner and then it just comes back to the same page with the box unchecked.
cacti-1.png
cacti-1.png (40.34 KiB) Viewed 227 times
by stormonts
Wed Sep 11, 2019 10:08 am
Forum: Help: Linux/Unix Specific
Topic: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6
Replies: 17
Views: 443

Re: Unable to upgrade from 1.2.4 to either 1.2.5 or 1.2.6

This is what I see. mysql> SELECT * FROM settings where value like '/usr/local/cacti%'; +---------------------------+---------------------------------------+ | name | value | +---------------------------+---------------------------------------+ | boost_png_cache_directory | /usr/local/cacti/cache/bo...