Search found 25 matches

by nerdtalker
Sun Apr 02, 2006 10:39 pm
Forum: Help: Linux/Unix Specific
Topic: RRDtool graphs without text, labels, after apt-get update
Replies: 2
Views: 1640

rony wrote: Also, make sure that you have a proper path to a default font in the settings, or not font at all defined.
Yeah, I just gave a direct path to the font I want, and now the graphs are working. :lol:

I'm not sure what happened, but it's working now!
by nerdtalker
Sun Apr 02, 2006 5:39 pm
Forum: Help: Linux/Unix Specific
Topic: RRDtool graphs without text, labels, after apt-get update
Replies: 2
Views: 1640

RRDtool graphs without text, labels, after apt-get update

I've got a huge problem. I recently did a weekly apt-get update, upgrade on the server I have that runs cacti. I just said yes, assuming that it would peacefully update everything. However, after I did that, I noticed that my graphs now no longer have any labels or text on them. (see attached image)...
by nerdtalker
Sun Mar 26, 2006 12:03 pm
Forum: Help: General
Topic: Remove Spkie, and properly set max value
Replies: 7
Views: 3491

Re: Remove Spkie, and properly set max value

AFAIK, the spike removal is now part of the current cactid poller. But I did not check personally Reinhard I went and checked in the cacti changelog, and found something interesting: -feature: Added support for spike suppression within the cmd.php poller. This puzzles me, since it sounds like it's ...
by nerdtalker
Sat Mar 25, 2006 1:21 am
Forum: Help: General
Topic: Remove Spkie, and properly set max value
Replies: 7
Views: 3491

Remove Spkie, and properly set max value

I'm wondering what value I should set the max value field to. I know the maximum speed of the interface in mention, but I'm confused regarding the units in use. Would 10000000 be 10 gigabits? The other thing is that I've got a nice spike in one of my graphs. It's been a long time since I've been act...
by nerdtalker
Tue Feb 28, 2006 10:19 pm
Forum: Scripts and Templates
Topic: EDIT: Advanced Ping Template Version 1.3 for Cacti 0.8.6g
Replies: 526
Views: 694631

c) Run from the script server Paste the entire line ending in "TCP 80" into the script server window and hit <CR> d) Quit the script server quit <CR> Post the output. By <CR>, I assume you meant enter or something? Regardless, I get this: XboxServ:/usr/share/cacti/site# php script_server.php PHP Sc...
by nerdtalker
Sun Feb 26, 2006 8:51 pm
Forum: Scripts and Templates
Topic: EDIT: Advanced Ping Template Version 1.3 for Cacti 0.8.6g
Replies: 526
Views: 694631

I'm still getting graphs with 100% loss. I defined the protocol (TCP, since ICMP doesn't work) and the port number to use, but I'm not sure if the other values are right. I modified the data template itself because the data source properties doesn't have any of those fields. Needless to say, I'm sti...
by nerdtalker
Wed Feb 08, 2006 9:09 pm
Forum: Scripts and Templates
Topic: EDIT: Advanced Ping Template Version 1.3 for Cacti 0.8.6g
Replies: 526
Views: 694631

Unable to create socket: This leads to ths assumption, that the user "cacti" which runs the poller does not have permissions for creating ICMP sockets. This is a common problem with unixes. Is it possible for you to change "20 ICMP" to sth like "20 TCP 80"? Reinhard Awesome, that seems to work. Now...
by nerdtalker
Tue Feb 07, 2006 10:53 pm
Forum: Scripts and Templates
Topic: EDIT: Advanced Ping Template Version 1.3 for Cacti 0.8.6g
Replies: 526
Views: 694631

To all: Please switch to DEBUG mode (Settings-> Logging Level) and post log/cacti.log for exactly one poller's run. Don't forget to reset logging level afterwards or cacti will fill up your disk space... Please append follwing information: - parameters used (e.g. ICMP, UDP, TCP and Port if needed) ...
by nerdtalker
Sun Feb 05, 2006 8:55 pm
Forum: Scripts and Templates
Topic: EDIT: Advanced Ping Template Version 1.3 for Cacti 0.8.6g
Replies: 526
Views: 694631

This just plainly isn't working for me. I've imported everything, and made sure that it's all executable by everyone, but when I create a new host, and give it the graph template of PING - Advanced Ping v1.3, I'm not prompted about anything like I'm supposed to, nor do the graphs generate anything. ...
by nerdtalker
Sun Feb 05, 2006 5:30 pm
Forum: Scripts and Templates
Topic: DOCSIS Stats
Replies: 72
Views: 108808

Looks good, but my ISP (Comcast) disables SNMP access for customers, so it won't work.

Is there any way to do it with lynx and essentially capture those same values from the cable modem configuration pages?
by nerdtalker
Sun Feb 05, 2006 12:23 pm
Forum: Help: Linux/Unix Specific
Topic: Apache Problems on Debian Cacti 0.8.6h
Replies: 3
Views: 1724

Thanks for the suggestion, but I got it working finally.

I went and found adodb.inc.php, it was just in /usr/share/adodb/adodb.inc.php, instead of /usr/share/php/adodb/adodb.inc.php. I changed the /include/config.php appropriately and it works now. 8)
by nerdtalker
Sun Feb 05, 2006 12:30 am
Forum: Help: Linux/Unix Specific
Topic: Apache Problems on Debian Cacti 0.8.6h
Replies: 3
Views: 1724

Apache Problems on Debian Cacti 0.8.6h

I'm having some massive problems with cacti, when I go to myserverip/cacti, I see the following: Warning: main(/usr/share/php/adodb/adodb.inc.php): failed to open stream: No such file or directory in /usr/share/cacti/site/include/config.php on line 145 Warning: main(): Failed opening '/usr/share/php...
by nerdtalker
Mon Jan 30, 2006 11:41 pm
Forum: Help: Linux/Unix Specific
Topic: Fresh apt-get install on debian, no graphs
Replies: 26
Views: 22230

Well, I managed to get cacti working by deleting root's cronjob, and adding back the original one in /cron.d/cacti, so it works. Or should I say... worked. However, after I started looking around for templates, I noticed that I was running 0.8.6c, and I need 0.8.6g for the template in mind (advanced...
by nerdtalker
Sun Jan 29, 2006 5:59 pm
Forum: Help: Linux/Unix Specific
Topic: Fresh apt-get install on debian, no graphs
Replies: 26
Views: 22230

Can you change "cacti" to "www-data" in the crontab ? unless you have changed permission or ownership on cacti folders after install, that's how it is setup under debian. A file named "cacti" should be present under /etc/cron.d/ with this same line. there is no entry in root crontab for cacti. I mi...
by nerdtalker
Sat Jan 28, 2006 7:15 pm
Forum: Help: Linux/Unix Specific
Topic: Fresh apt-get install on debian, no graphs
Replies: 26
Views: 22230

Looks like I spoke too soon, the poller runs fine manually, but graphs aren't generating when I don't run it manually every once in a while. [email protected]:/usr/share/cacti/site$ php poller.php Waiting on 1/1 pollers. Waiting on 1/1 pollers. Waiting on 1/1 pollers. Waiting on 1/1 pollers. Waiting on...