Search found 16 matches

by catcha8
Mon Jul 26, 2010 6:34 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

:D :D :D :D

Yes! It works wonderfully now.
Thank you so much for the hard work, this plugin is really excellent.

Regards
by catcha8
Mon Jul 26, 2010 5:31 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

Hi Phalek,

Just tried with build 50 and 51. :)

With both, I'm getting back to the initial situation of this thread. PDF are well generated with no graph in them. The apache error is as follow:

Code: Select all

sh: .parallelGraphRetriever.exe: not found
by catcha8
Fri Jul 23, 2010 5:23 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

No problem, just give me instructions through private message.
I will arrange to find time.

Regards
by catcha8
Fri Jul 23, 2010 5:04 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

:) Don't worry, I really appreciate your help.

I followed your instruction, no more apache error but pdf created always named "\.pdf" with the following content :

<b>FPDF error:</b> Undefined font: B
by catcha8
Fri Jul 23, 2010 4:11 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

Each time I disable, uninstall the plugin, remove the folder, copy the new one, install and enable.
If I revert to version 0.84, I don't have this problem.

Would you like a copy of my 0.84 version?
by catcha8
Fri Jul 23, 2010 3:15 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

Hi Phalek,

Sorry but another another apache error with the latest build clicking on "NmidCreatePDF":

PHP Fatal error: Call to undefined function db_fetch_cell() in /usr/share/cacti/site/plugins/nmidCreatePDF/nmidCreatePDF_GenerateReports.php on line 51
by catcha8
Thu Jul 22, 2010 7:37 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

:) It's exactly what I was doing.

Here is my phpinfo, I just removed private informations (IP + hostname)
by catcha8
Thu Jul 22, 2010 7:03 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

No, it's off on both php.ini files.
by catcha8
Thu Jul 22, 2010 5:33 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

Unfortunately no.
From the tree view if I generate a graph, the file is named: \.pdf and the content is as follow: <b>FPDF error:</b> Undefined font: B

Maybe doing something wrong but don't know what. Rights are same than before, if I revert to 0.84 don't have this problem.
by catcha8
Thu Jul 22, 2010 4:25 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

I installed the new release but I receive the following apache error when trying to access "nmidCreatePDF" button :

PHP Fatal error: Call to undefined function db_fetch_cell() in /usr/share/cacti/site/plugins/nmidCreatePDF/nmidCreatePDF_GenerateReports.php on line 49
by catcha8
Wed Jul 21, 2010 8:39 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

Unfortunately no.
I'm available for the next 2-3 hours or maybe tomorrow if you prefer. I'm under the same timezone than you.

Regards
by catcha8
Wed Jul 21, 2010 8:30 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

Well I guess no... But I remember something for the SourceGuardian module installation. There's 2 php.ini files for my installation, one for the CLI and one for the web server: /etc/php5/apache2/php.ini /etc/php5/cli/php.ini Don't know if it can help. If you prefer, I can give you access to my syste...
by catcha8
Wed Jul 21, 2010 8:01 am
Forum: Plugin Architecture
Topic: No graphs on reports with nmidCreatePDF
Replies: 45
Views: 19940

Hi Phalek,

Thanks for your help.
The result of the php command just give me: Linux

And here is the result of the new debug.php (I only mask my hostname computer)

Regards
by catcha8
Thu May 20, 2010 2:27 pm
Forum: Plugin Architecture
Topic: cacti PIA on Ubuntu
Replies: 7
Views: 4684

Hello,

Did you check your config.php, there's some additional changes for ubuntu, maybe this one will match with your config:
include($config["library_path"]."/adodb/adodb.inc.php");
change it to:
include("/usr/share/php/adodb/adodb.inc.php");
Regards
by catcha8
Thu May 20, 2010 11:45 am
Forum: Plugin Architecture
Topic: How To Install Plugin Architecture on Ubuntu 9.10 Server ?!
Replies: 26
Views: 39850

Hello, You can have a look on this http://cactiusers.org/wiki/PluginArchitectureInstall for sources and documentation For a fresh install you have to import the pa.sql to your cacti database: mysql cacti < pa.sql -u root -p Then restart mysqld Take care of the configuration part (include/global.php)...