Search found 68 matches

by dgamble
Thu Oct 19, 2006 10:57 pm
Forum: Help: Linux/Unix Specific
Topic: cactid mysql error on 64bit
Replies: 16
Views: 6797

Well, you must have taken some of the cactid source as well. You need the Makefile.am, and then run automake. You will also need the error.c and error.h that I introduced in this new version. TheWitness Thanks for your reply. I am a bit confused here. Yes, of course I did take the cactid source... ...
by dgamble
Thu Oct 19, 2006 9:51 am
Forum: Help: Linux/Unix Specific
Topic: cactid mysql error on 64bit
Replies: 16
Views: 6797

Here are the results from simply trying to compile it (obtained from SVN around the time of my last post): gcc -I/usr/include/net-snmp -I/usr/include/net-snmp/.. -I/usr/include/mysql -g -O2 -L/usr/lib64 -L/usr/lib64/mysql -o cactid sql.o cactid.o util.o snmp.o locks.o poller.o nft_popen.o php.o ping...
by dgamble
Wed Oct 18, 2006 3:31 pm
Forum: Help: Linux/Unix Specific
Topic: cactid mysql error on 64bit
Replies: 16
Views: 6797

At least test it. TheWitness I'm sorry, I'll try to be more clear on my issue. I need more information such that I COULD test it. I'd LIKE to test it, because I have to migrate the 32-bit setup to a 64-bit machine ASAP. I have cacti data from a slightly older 32-bit installation. If I were to get a...
by dgamble
Wed Oct 18, 2006 3:09 pm
Forum: Help: Linux/Unix Specific
Topic: cactid mysql error on 64bit
Replies: 16
Views: 6797

Have either of you build BRANCH_0_8_6 of Cacti SVN? I specifically addressed this issue. I have to get to Ian to get the release done. TheWitness Sorry, I was typing my previous message while you were typing this one. :-) I am not sure if I can just take the database install from my 32-bit cactid-0...
by dgamble
Wed Oct 18, 2006 3:03 pm
Forum: Help: Linux/Unix Specific
Topic: cactid mysql error on 64bit
Replies: 16
Views: 6797

More info here... It looks like the configure script was simply never designed to look for 64-bit libraries. They're under /usr/lib64/{libdir} on RHEL, which I think is the typical location for Linux. I added the following block under the "for i in $MYSQL_DIR...." loop: str="$i/lib64/mysql/libmysqlc...
by dgamble
Wed Oct 18, 2006 2:28 pm
Forum: Help: Linux/Unix Specific
Topic: cactid mysql error on 64bit
Replies: 16
Views: 6797

I have the same issue. Looks like it affects all versions of cactid.
by dgamble
Wed Apr 12, 2006 2:37 pm
Forum: Help: General
Topic: ifSpeed not used for rrd_maximum on new Data Queries
Replies: 5
Views: 2637

The feature for setting rrd_maximum to the |query_ifSpeed| was introduced lately, AFAIK Reinhard No, this is the DEFAULT configuration for the interface graphs, and has been so for at least as long as I've been using cacti (0.8.6b). This is just the simple substitution that is also used by nearly e...
by dgamble
Wed Apr 12, 2006 11:16 am
Forum: Help: General
Topic: ifSpeed not used for rrd_maximum on new Data Queries
Replies: 5
Views: 2637

Re: ifSpeed not used for rrd_maximum on new Data Queries

I'm quite sure that this has been introduced only lately. So I recommend using cacti 0.8.6h Reinhard What are you referring to that has been introduced lately? This feature? This bug (if it is a bug)? A fix to this bug? If the latter, it's not in the changelog, as I noted. Can anyone confirm if thi...
by dgamble
Tue Apr 11, 2006 3:02 pm
Forum: Help: General
Topic: 64-bit int for v1 SNMP query: how to handle?
Replies: 9
Views: 5474

Right. And they don't seem inclined to fix it. Hence, I need to come up with a workaround. There are other devices that I use a perl script to extract data from. However, perl is fairly opaque to integer type. If I wrote a script to get the value, I suppose perl would just "pass it along" as whatev...
by dgamble
Tue Apr 11, 2006 1:43 pm
Forum: Help: General
Topic: ifSpeed not used for rrd_maximum on new Data Queries
Replies: 5
Views: 2637

ifSpeed not used for rrd_maximum on new Data Queries

Good day, I noticed that, when creating a Data Source from a (SNMP) Data Query, the suggested values for rrd_maximum (query_ifSpeed) doesn't get used. I have: rrd_maximum |query_ifSpeed| set for the Data Query. If I create a Data Source with this, the Data Source always gets created with maximum "10...
by dgamble
Wed Nov 23, 2005 12:21 pm
Forum: Help: General
Topic: no load average
Replies: 16
Views: 5452

Workarounds provided

jlim0930 wrote:i have changed from cactid to cmd.php and now the load averages are working...

give that a try
Guys, I gave you all no less than two cactid workarounds in this post. Just pick one and go with it, and let the developers fix it properly for the next version.
by dgamble
Wed Nov 16, 2005 2:21 pm
Forum: Help: General
Topic: Error when using second data source for GPRINT only
Replies: 21
Views: 5238

BelgianViking wrote:Yes, but this would adjust the scale according to that value too. And I won't want that.
You could make a CDEF that multiplies by zero. :wink:
by dgamble
Wed Nov 16, 2005 2:20 pm
Forum: Help: General
Topic: Error when using second data source for GPRINT only
Replies: 21
Views: 5238

Good day, I actually posted this bug in the bug tracker some time ago. Too bad I didn't see this thread sooner; I could have answered your question from the first post. :-? I've looked at the code, and to quickly sum up the issue, a datasource will not be included unless it is used for a visible gra...
by dgamble
Wed Nov 09, 2005 5:57 pm
Forum: Help: General
Topic: Graph URLs are redirected when they shouldn't be
Replies: 3
Views: 1650

If you just want to show the graphs, I would suggest using the Graph List View, which you can select a list of graphs you want and then send them that URL. I specifically designed that page, so no matter how many graphs you select, even accross pages, if the page is book marked, it will retain all ...
by dgamble
Wed Nov 09, 2005 5:52 pm
Forum: Help: General
Topic: Need LDAP help
Replies: 4
Views: 2026

rony wrote:This will not be updated in 0.8.6, it has been update in the 0.9.0 code tree, but it will not even be into beta testing until next year.
Ok, thanks for the info. I did open a report with details on this, you can either keep it open until 0.9 or close it now, your choice. :)