Search found 149 matches

by paulbeard206
Wed Aug 21, 2019 2:18 pm
Forum: Help: Linux/Unix Specific
Topic: Import DB error
Replies: 6
Views: 2493

Re: Import DB error

Well, this is nice to find out. What's the best way to fix this permanently? Dump the database and reimport into a correctly formatted one? Or does someone (perhaps one of the cacti devs who shat the bed here?) have a script with the right syntax that incorporates the variables detailed here? https:...
by paulbeard206
Sat Apr 13, 2019 4:59 pm
Forum: Help: General
Topic: Fresh install of 1.2.3 is stuck at Critical Binary Locations
Replies: 36
Views: 4718

Re: Fresh install of 1.2.3 is stuck at Critical Binary Locat

Yeah, this is dumb and should be fixed.

The log is writable/being written to, the permissions are right (same as the othr files) but the clever updater is screwed up.

This isn't the first time I've seen this. Someone needs to do a better job testing these releases.
by paulbeard206
Wed Jan 30, 2019 6:54 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti 1.2.1 Installation - Can't login
Replies: 14
Views: 1547

Re: Cacti 1.2.1 Installation - Can't login

Permissions seem fine. Spine is writing to the log happily. Why is this failing?

I changed /var/log/cacti to be owned by www:www and it worked. Changed it back and it still works.
by paulbeard206
Wed Jan 30, 2019 3:10 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti 1.2.1 Installation - Can't login
Replies: 14
Views: 1547

Re: Cacti 1.2.1 Installation - Can't login

OK. Seems like a fairly significant change to make. select id, realm_id, username from user_auth_realm uar inner join user_auth ua on ua.id = uar.user_id where realm_id = 26; Empty set (0.00 sec) So now what? How does fix this? What GRANT statement needs to be used (optimally as part of the upgrade ...
by paulbeard206
Mon Jan 28, 2019 9:16 pm
Forum: Help: Linux/Unix Specific
Topic: [SOLVED]Cannot Install Cacti-1.2.1 new release
Replies: 23
Views: 3360

Re: Cannot Install Cacti-1.2.1 new release

The attached is where things sit right now.

https://mywebsite.org/cacti/install/install.php is the URL that gets returned on each iteration/reload.
by paulbeard206
Sun Jan 27, 2019 10:13 am
Forum: Help: Linux/Unix Specific
Topic: [SOLVED]Cannot Install Cacti-1.2.1 new release
Replies: 23
Views: 3360

Re: Cannot Install Cacti-1.2.1 new release

Deinstalled/reinstalled cacti, the install/upgrade process is hung up somewhere. The /install directory is the default and nothing happens.

SElinux is not the problem. AppArmour is not the problem.

Monitoring this thread to see when a solution becomes available.
by paulbeard206
Sat Jan 26, 2019 9:09 pm
Forum: Help: Linux/Unix Specific
Topic: [SOLVED]Cannot Install Cacti-1.2.1 new release
Replies: 23
Views: 3360

Re: Cannot Install Cacti-1.2.1 new release

This suggests that your install isn't successfully calling the install/cli_check.php. sudo -u www-data php -q /path/to/cacti/install/cli_check.php extensions Replace www-data with the website user on your box. sudo -u www php -q ./cli_check.php PHP Notice: Undefined offset: 1 in /usr/local/share/ca...
by paulbeard206
Sat Jan 26, 2019 9:05 pm
Forum: Help: Linux/Unix Specific
Topic: Cacti 1.2.1 Installation - Can't login
Replies: 14
Views: 1547

Re: Cacti 1.2.1 Installation - Can't login

netniV wrote:Check that you have the Install/Upgrade permission against your user.
what does this even mean? I also upgraded thru FreeBSD ports and am now locked out with no login screen.
by paulbeard206
Sat Oct 20, 2018 3:28 pm
Forum: Help: Linux/Unix Specific
Topic: cacti reinstall, odd glitches, gotchas: RRAs not updating
Replies: 1
Views: 311

cacti reinstall, odd glitches, gotchas: RRAs not updating

Had a problem a few weeks ago when my database software (MySQL) was mysteriously uninstalled :-? :evil: . Managed to restore all the data but now after some time reinstalling cacti 1.1.37 my RRAs are not updating. All show mod times of Sept 28 and of course the graphs are not updating. Nothing jumps...
by paulbeard206
Mon Jun 04, 2018 7:31 am
Forum: Help: Linux/Unix Specific
Topic: No graphs: fontconfig and en-US language?
Replies: 2
Views: 409

Re: No graphs: fontconfig and en-US language?

Is there a patch? I saw the diff: is that all that's needed?
by paulbeard206
Sun Jun 03, 2018 8:58 pm
Forum: Help: Linux/Unix Specific
Topic: No graphs: fontconfig and en-US language?
Replies: 2
Views: 409

No graphs: fontconfig and en-US language?

Fontconfig warning: ignoring en-US: not a valid language tag (en-US.UTF-8) is what I see on the graph debug for one host but not for others. How do I fix that? I didn't make any font selections and the other hosts are good. Plus the host that this is failing on is that one where cacti runs/where th...
by paulbeard206
Sat May 17, 2014 9:29 pm
Forum: Scripts and Templates
Topic: Speedtest graph/data template available
Replies: 27
Views: 20443

Speedtest graph/data template available

Looks like this: graph_image.php.png Since the values being graphed are not the same (ms and Mbit/sec), I left off the Y axis label and let the Legend handle that. This is just after I got it working. From the Readme (enclosed in the zip file): Import the two enclosed files into Cacti through the ca...
by paulbeard206
Fri May 16, 2014 8:55 pm
Forum: Scripts and Templates
Topic: Request for help for a speedtest script + template
Replies: 5
Views: 3822

Re: Request for help for a speedtest script + template

This is also unhelpful: Applying a data template to a data source is a very simple process. The first thing you must do is select the data source you want to apply the template to under Data Sources. Under the Data Template Selection box, select the data template that you want to apply to the data s...
by paulbeard206
Thu May 15, 2014 8:52 pm
Forum: Scripts and Templates
Topic: Request for help for a speedtest script + template
Replies: 5
Views: 3822

Re: Request for help for a speedtest script + template

I am looking for the same thing. I have most of it built but there seem to be one or more steps missing in the documentation that links the data gathering to the graphing and presentation. I have this from Speedtest.net via a command line tool: Ping:34.094 Download:33.43 Upload:11.38 Nuggets like th...