Search found 80 matches

by smiles
Wed Dec 19, 2018 11:52 am
Forum: Plugin: (Network Weather Map)
Topic: Installation Guide (Standalone)
Replies: 16
Views: 1536

Re: Installation Guide (Standalone)

I did, but it was throwing an error. I assumed because of the deprecation. After researching more, I found this: "Bower is deprecating their registry hosted with Heroku. http://bower.herokuapp.com/ Will not be accessible anymore or it might be down intermittently, therefore, forcing users to a new r...
by smiles
Tue Dec 18, 2018 1:46 pm
Forum: Plugin: (Network Weather Map)
Topic: Installation Guide (Standalone)
Replies: 16
Views: 1536

Re: Installation Guide (Standalone)

I apologize for my ignorance. I assumed the master branch was the latest version since it had recent commits. I did read the readme. It said under the "Using the dev version" section that bower installs the necessary javascript dependencies under the /vendor directory. It also says further down unde...
by smiles
Tue Dec 18, 2018 10:13 am
Forum: Plugin: (Network Weather Map)
Topic: Installation Guide (Standalone)
Replies: 16
Views: 1536

Re: Installation Guide (Standalone)

I have the latest weathermap plugin installed and working for Cacti 1.2.0. Polling is working fine. I can view my old maps fine within cacti. The check.php script finds no issues with the php. However, I can not get the editor working. I believe this is due to bower being deprecated, and javascript/...
by smiles
Fri Sep 28, 2018 12:23 pm
Forum: Plugin General
Topic: Reportit plugin question
Replies: 1
Views: 246

Reportit plugin question

I have a question on the usage of this plugin. I have a working report that uses the f_max function and it appears to be working correctly. My question is, is there a way to note the timestamp/time period that the f_max was observed? Instead of having to spend a LOT of time going through the associa...
by smiles
Fri Dec 29, 2017 1:07 pm
Forum: Plugin General
Topic: Error in plugin routerconfigs
Replies: 6
Views: 977

Re: Error in plugin routerconfigs

The Router Debug Info output will tell you if cacti is successfully logging into the device or not, and also tell you if it's erroring out on any of the commands it's issuing to send the backup. That is why I asked for it's output.
by smiles
Fri Dec 29, 2017 12:34 pm
Forum: Plugin General
Topic: CaMM (Cacti Message Management) plugin v1.6.7 2010-08-26
Replies: 739
Views: 334778

Re: CaMM (Cacti Message Management) plugin v1.6.7 2010-08-26

If you are looking to alert based on SYSLOG messages, there is a plugin under the cacti repository on github called syslog here: https://github.com/Cacti/plugin_syslog


If you are looking for SNMP trap messaging, I'm not aware of any plugins compatible with Cacti 1.0+
by smiles
Fri Dec 29, 2017 12:19 pm
Forum: Plugin General
Topic: Error in plugin routerconfigs
Replies: 6
Views: 977

Re: Error in plugin routerconfigs

You will need to provide more information than you have in order for someone to help. That last error is not the reason your config is not backing up, it's function is merely to provide info in debugging and can be ignored or omitted from the code. Do you know that your configs can manually be backe...
by smiles
Tue Sep 05, 2017 3:24 pm
Forum: Plugin General
Topic: routerconfigs on cacti 1.1.17 ssh login fails
Replies: 27
Views: 2557

Re: routerconfigs on cacti 1.1.17 ssh login fails

I think smiles is running a different version of the code. Smiles, can you please attach the version you're actually running? I'd like to compare the files and see what we can find. I'm actually running a heavily modified version of routerconfigs, it won't line up with the github repo at all. When ...
by smiles
Thu Aug 31, 2017 12:45 pm
Forum: Plugin General
Topic: routerconfigs on cacti 1.1.17 ssh login fails
Replies: 27
Views: 2557

Re: routerconfigs on cacti 1.1.17 ssh login fails

No I have Cisco IOS-XR, IOS-XE, and IOS using SSH without issue. I also just successfully tested it on a 3850 using SSH and Telnet both.
by smiles
Wed Aug 30, 2017 4:05 pm
Forum: Scripts and Templates
Topic: Template for specific devices like Allot
Replies: 2
Views: 706

Re: Template for specific devices like Allot

https://github.com/cglass/cacti-allot.git

Looks like someone has a git repo for the data query, SNMP script, and graph query already built.

You just need to download those and import them, they also provided detailed instructions on how to install.
by smiles
Wed Aug 30, 2017 4:04 pm
Forum: Help: Linux/Unix Specific
Topic: Graph only displaying Cacti logo
Replies: 4
Views: 428

Re: Graph only displaying Cacti logo

Deleted post.
by smiles
Wed Aug 30, 2017 3:52 pm
Forum: Help: Linux/Unix Specific
Topic: Graph only displaying Cacti logo
Replies: 4
Views: 428

Re: Graph only displaying Cacti logo

In order to help, we really need to know what the response was in your graph debug (what's after the RRDtool Says:).

It should either say "OK", or give you a reason why the graph will not render.

Are your rrd files being written in the <cacti_path>/rra directory, and do they have content in them?
by smiles
Wed Aug 30, 2017 3:43 pm
Forum: Plugin General
Topic: routerconfigs on cacti 1.1.17 ssh login fails
Replies: 27
Views: 2557

Re: routerconfigs on cacti 1.1.17 ssh login fails

You can set up preshared SSH keys between your linux box that Cacti runs on and the switch/router you are connecting to, eliminating the need for username/password authentication.

What switch/router make and model are you connecting to?
by smiles
Tue Aug 29, 2017 9:28 am
Forum: Plugin General
Topic: routerconfigs on cacti 1.1.17 ssh login fails
Replies: 27
Views: 2557

Re: routerconfigs on cacti 1.1.17 ssh login fails

It's working for me using SSH, but I have preshared keys set up.

What does the console debug output look like on that device? (click on the router debug icon for that host on the devices page)
by smiles
Fri Aug 25, 2017 1:06 pm
Forum: Plugin: (Threshold)
Topic: Threshold settings not saving
Replies: 5
Views: 1703

Re: Threshold settings not saving

There should be a javascript window that pops up at the top with an error in RED telling you the record was not updated. This appears after submitting the form/clicking save telling you what's wrong if it isn't saving changes, it disappears quickly though if you are not watching for it. For me I've ...