Search found 256 matches

by GlueGuy
Tue Sep 05, 2017 9:13 am
Forum: Plugin General
Topic: Report plugin ''ReportIt" - v0.7.5a (released 23/12/11)
Replies: 993
Views: 582486

Re: Report plugin ''ReportIt" - v0.7.5a (released 23/12/11)

We've recently started using Cacti alot in our environment and recently upgraded to ver 1.1.21. We are very keen to use your plugin and have installed it as we want to do some reporting on our links. We have installed Reportit ver 1.0. I have used some old documentation to try and get it going but ...
by GlueGuy
Thu Aug 10, 2017 3:21 pm
Forum: Help: General
Topic: THOLD daemon: Can I set when it runs or anything?
Replies: 1
Views: 257

Re: THOLD daemon: Can I set when it runs or anything?

Sort of answered my own question. It appears that turning on the Threshold daemon breaks thresholds.

Doctor! It hurts when I turn on the Thresholds daemon! Doctor: "Don't turn on the Threshold daemon, son."
by GlueGuy
Thu Aug 10, 2017 2:18 pm
Forum: Help: General
Topic: THOLD daemon: Can I set when it runs or anything?
Replies: 1
Views: 257

THOLD daemon: Can I set when it runs or anything?

We turned on the THOLD daemon, but we don't really see it running. Is it just another instantiation of spine running or what? We thought that maybe we could set it to run at 1-minute intervals or something, but there doesn't appear to be anything we can do but turn it on? Am I just looking in the wr...
by GlueGuy
Mon Aug 07, 2017 5:49 pm
Forum: Help: Linux/Unix Specific
Topic: Apache2 on Debian 9: Where is the real cacti?
Replies: 4
Views: 889

Re: Apache2 on Debian 9: Where is the real cacti?

I think this is absolutely not related to Apache. I believe you, but I will do more poking around. Nope. This is the location where the Debian cacti package installs stuff. Please read the link in my signature. I suggest you purge the Debian cacti package before trying to install cacti from the cac...
by GlueGuy
Sun Jul 30, 2017 9:40 am
Forum: Help: Linux/Unix Specific
Topic: SOLVED:SPINE:Poller[1] FATAL:Connection Failed, Error:'1251'
Replies: 4
Views: 363

SOLVED: SPINE: Poller[1] FATAL: Connection Failed, Error:'12

Yes. Some modifications to the standard installation are required on Debian 9/PHP 7/MariaDB 15. It boils down to included libraries that no longer need to be added to extensions (they're already there).
by GlueGuy
Mon Jul 24, 2017 4:05 pm
Forum: Help: Linux/Unix Specific
Topic: Adding a second or third poller on the same server?
Replies: 1
Views: 364

Adding a second or third poller on the same server?

I've been looking around for information on how to set up a second poller on the same server. In this particular case, we want some critical systems to be polled on a 1-minute interval, but other less-critical systems polled on a 5-minute interval. Just looking at the poller.php and config.php files...
by GlueGuy
Mon Jul 24, 2017 2:58 pm
Forum: Help: Linux/Unix Specific
Topic: ERROR PHP NOTICE: Constant CACTI_VERSION already defined
Replies: 1
Views: 302

Re: ERROR PHP NOTICE: Constant CACTI_VERSION already defined

This was an outgrowth of my using an old-style THOLD with the new style cacti.

Guess I have some reading to do.
by GlueGuy
Mon Jul 24, 2017 1:31 pm
Forum: Plugin: (Threshold)
Topic: THOLD redeclares png2jpg
Replies: 4
Views: 623

Re: THOLD redeclares png2jpg

Sheesh. I must have missed the memo on this. I will say that I had to do some editing of THOLD to get it to run.

It fell on its face again after I wrote my last entry on this. I'll D/L the new THOLD and see how it goes.

Thanks Jimmy!
by GlueGuy
Mon Jul 24, 2017 12:03 pm
Forum: Help: Linux/Unix Specific
Topic: rrdtool 1.6.0 versus rrdtool 1.5.0
Replies: 4
Views: 803

Re: rrdtool 1.6.0 versus rrdtool 1.5.0

My conclusion at this point is to live with Apache2/Debian 9, and put all of cacti in /usr/share/cacti/site, and forget about /var/www/html/cacti -OR- teach Apache2/Debian 9 that the 'cacti' alias actually goes to /var/www/html/cacti. At this point, I've chosen the latter, as I'm familiar with manip...
by GlueGuy
Sun Jul 23, 2017 10:40 pm
Forum: Help: Linux/Unix Specific
Topic: ERROR PHP NOTICE: Constant CACTI_VERSION already defined
Replies: 1
Views: 302

ERROR PHP NOTICE: Constant CACTI_VERSION already defined

The actual error is: ERROR PHP NOTICE: Constant CACTI_VERSION already defined in file: /var/www/html/cacti/include/global.php on line: 47 I'm guessing this is some weirdness with Debian 9/PHP 7. I've been encountering a few. Unfortunately, when I comment out the define, I then get a different proble...
by GlueGuy
Sun Jul 23, 2017 10:10 pm
Forum: Plugin: (Threshold)
Topic: THOLD redeclares png2jpg
Replies: 4
Views: 623

Re: THOLD redeclares png2jpg

OK. Replaced split() with explode() per some bug reports I saw on the web regarding issues with Debian and PHP 7.

THOLD now seems to be working. Do this:
  • Comment out png2jpg
  • Replace split() with explode()
by GlueGuy
Sun Jul 23, 2017 9:52 pm
Forum: Plugin: (Threshold)
Topic: THOLD redeclares png2jpg
Replies: 4
Views: 623

Re: THOLD redeclares png2jpg

So I commented out that redundant function. I am now getting hung up on an undeclared function split() coming from thold/includes/polling.php 2017/07/23 19:44:14 - ERROR PHP ERROR in Plugin 'thold': Uncaught Error: Call to undefined function split() in /usr/share/cacti/site/plugins/thold/includes/po...
by GlueGuy
Sun Jul 23, 2017 9:43 pm
Forum: Plugin: (Threshold)
Topic: THOLD redeclares png2jpg
Replies: 4
Views: 623

THOLD redeclares png2jpg

We're attempting to migrate from 0.8.8h to 1.1.13. When we installed the THOLD plugin (v 0.5), we get the following error. 2017/07/23 16:56:28 - ERROR PHP COMPILE_ERROR in Plugin 'thold': Cannot redeclare png2jpeg() (previously declared in /usr/share/cacti/site/lib/reports.php:1244) in file: /usr/sh...
by GlueGuy
Sun Jul 23, 2017 3:56 pm
Forum: Help: Linux/Unix Specific
Topic: Upgrade from 0.8.8h to 1.1.13; no console?
Replies: 1
Views: 327

Re: Upgrade from 0.8.8h to 1.1.13; no console?

Consider this solved. It was only old cache data in my browser.

Now I have a new problem. When I try to open cacti, it thinks it needs to go through the upgrade wizard again. When I get to the last page, it then displays:
Error

Invalid Cacti version CACTI_VERSION, cannot upgrade to 1.1.13
by GlueGuy
Sun Jul 23, 2017 3:05 pm
Forum: Help: Linux/Unix Specific
Topic: Upgrade from 0.8.8h to 1.1.13; no console?
Replies: 1
Views: 327

Upgrade from 0.8.8h to 1.1.13; no console?

Just went through my 3rd try upgrading from 0.8.8h to 1.1.13, and I've gotten the same result each time. Now I'm not sure where to look. The results are that the database appears to convert with [SUCCESS] for all the conversions displayed at completion. However, I get a blank console (see below) whe...