Search found 13 matches

by Azendale
Sun Jun 16, 2019 9:07 am
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

pyron83 wrote:just for information, did you solve the issue?

thanks
I haven't. (Sorry.)
by Azendale
Fri Jul 20, 2018 6:48 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

If you change the XML you should probably be running a poller output clear / reindex to ensure that everything is in sync. I did try that, and then re-creating graphs & data sources. It didn't seem to fix it. At this point, I think I would be open to allowing a login to our server with SSH (send me...
by Azendale
Fri Jul 20, 2018 1:09 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

These two data source templates are using "Upgrade profile 1"? If you can create other graphs without issues I wouldn't think it's a permission issue. I might be wrong but.. Can't spot anything weird though. Turns out I have two "Upgrade profile 1" profiles. Renamed them to Profile 1 and Profile 2 ...
by Azendale
Thu Jul 19, 2018 2:35 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

Your problem is quite simple. You've a difference in the index in the oid_index key so it never finds any indexes beneath it. Remove the 1979719681 or maybe add it depend on which one is working and which isn't. Now I'm questioning what I know about indexed queries. I thought you wanted to find som...
by Azendale
Thu Jul 19, 2018 1:34 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

Pucho wrote:How does your data source template look like? The one that's not working.
Here you go:
Image
by Azendale
Wed Jul 18, 2018 9:30 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

Still having trouble with this, though maybe I found something. But first, I'm working around the forum upload troubles. See http://users.eoni.com/~azendale/cacti/ for a list of files I was able to export on one of the problematic graphs. Ok, back to what I noticed: Here's the datasource for a graph...
by Azendale
Sun Jul 15, 2018 7:55 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

I just tried renaming them, and the same "The upload was rejected because the uploaded file was identified as a possible attack vector." happened. I just tried re-adding the graphs after deleting the old ones that didn't work and were showing the .rrd error. Nothing showed up in the logs related to ...
by Azendale
Thu Jul 12, 2018 7:27 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Re: Cacti not creating data sources or rrd files when it sho

I don't think that is the problem, since other graphs and data sources can be created. But here's what I get trying to look at that: spruce:/usr/share/cacti/site# ls -lah |grep rra lrwxrwxrwx 1 root root 18 Apr 26 04:25 rra -> /var/lib/cacti/rra spruce:/usr/share/cacti/site# ls -lah /var/lib/cacti/ ...
by Azendale
Thu Jul 12, 2018 2:55 pm
Forum: Help: General
Topic: Cacti not creating data sources or rrd files when it should?
Replies: 16
Views: 2375

Cacti not creating data sources or rrd files when it should?

I have some indexed SNMP queries. (I've attached the XML definitions.) I have these associated with a host templete. When I add a device/host with that template, and then go to the "Create graphs for this host" link, I can see in the tables that the indexed queries are running and are successful in ...
by Azendale
Thu Jun 07, 2018 8:15 pm
Forum: Help: General
Topic: Trouble adding indexed SNMP query
Replies: 1
Views: 191

Re: Trouble adding indexed SNMP query

Think I found it. I've only been trying to get this for a day or so, and then I post a question and figure it out myself.

I had the Data Query's "Data Input Method" set to "Get script data indexed". Changed to "Get SNMP data (Indexed)" and now it shows 8 rows.
by Azendale
Thu Jun 07, 2018 7:09 pm
Forum: Help: General
Topic: Trouble adding indexed SNMP query
Replies: 1
Views: 191

Trouble adding indexed SNMP query

I'm trying to poll DOCSIS modems with Cacti. It seems like it is a case of "SNMP Index does not exist" as shown on the page https://docs.cacti.net/howto:data_query_templates#snmp_index_does_not_exist Here is part of the SNMP tree shown by snmpwalk: snmpwalk 10.5.6.5 -Of -On -c secretstring -v2c .1.3...
by Azendale
Sat Feb 21, 2015 7:28 pm
Forum: Help: General
Topic: Track down what is using snmpwalk -v2 instead of -v2c
Replies: 2
Views: 526

Re: Track down what is using snmpwalk -v2 instead of -v2c

An example of part of the poller output (run with -d --force): OK u:0.08 s:0.10 r:18.93 OK u:0.08 s:0.10 r:18.93 OK u:0.08 s:0.10 r:18.93 Waiting on 1 of 3 pollers. Waiting on 1 of 3 pollers. Waiting on 1 of 3 pollers. Waiting on 1 of 3 pollers. Waiting on 1 of 3 pollers. Waiting on 1 of 3 pollers. ...
by Azendale
Sat Feb 21, 2015 7:26 pm
Forum: Help: General
Topic: Track down what is using snmpwalk -v2 instead of -v2c
Replies: 2
Views: 526

Track down what is using snmpwalk -v2 instead of -v2c

I a running Cacti on a debian server that was recently upgraded to the latest stable version of debian. I was getting all sorts of errors that looked like missing MIBs after that when the poller was run (it ended up filling up the disk before I noticed!) I fixed that by installing the mibs-downloade...