Search found 216 matches

by johnrembo
Fri Nov 19, 2010 8:23 am
Forum: Scripts and Templates
Topic: L7_query - javascript/jQuery queries on DOM on target URLs
Replies: 0
Views: 874

L7_query - javascript/jQuery queries on DOM on target URLs

Hello everyone, if you're looking for an easy way to fetch and cacti-display some numbers from the particular website - this one should help Let's take some figures from finance.google.com for example: http://img641.imageshack.us/img641/1176/gfinance.jpg Here's what script does: # node L7_query.js "...
by johnrembo
Thu Aug 26, 2010 1:47 pm
Forum: Plugin Announcements
Topic: Transporter, now at v0.2
Replies: 36
Views: 37735

you should take a look at node_stats.php, line 228 (function node_stats) in theory it's more than simple, hoever due to resetting counters - some extra logic is necessary. here's a sample calculation - run it on your server: <?php //node_stats.php, continued from line:286 $alerts=array(); $polling_i...
by johnrembo
Thu Jul 29, 2010 9:36 am
Forum: Plugin Announcements
Topic: Transporter, now at v0.2
Replies: 36
Views: 37735

Has anyone had good success using this plugin an using a tool like Crystal Reports to report on Data? Havent tried it with Crystal Reports - theoretically it should work. I've just tried host this plugin works on latest cacti release with PA 2.8 and found that it doesn't display chart correctly (no...
by johnrembo
Tue Apr 06, 2010 12:23 pm
Forum: Plugin General
Topic: zond plug-in v0.34c released
Replies: 123
Views: 167215

I may be late to the party.. but i just got cacti up and running.. this plug in is something i really want.. does it work in the latest CACTI version? hmm...tried running it some half a year ago and it went fluently. However, please read the notes in the very first post - there might have been some...
by johnrembo
Mon Mar 01, 2010 10:06 am
Forum: Scripts and Templates
Topic: port status templates with automated port discovery v00.01
Replies: 6
Views: 4197

right, manage can't do that but there is a workaround in the ports template i don't recommend this (php time limit on scripts if you use this) but you can edit scripts/ports.inc to specifically add any port you want to scan 1 port per line... then run a Verbose Query Oh, I must have missed that... ...
by johnrembo
Mon Mar 01, 2010 7:20 am
Forum: Scripts and Templates
Topic: port status templates with automated port discovery v00.01
Replies: 6
Views: 4197

Re: z

you must download uncompressed .xml file + compressed .php file (.zip or .gzip) + Running data query [34]. + Found type = '4 '[script query]. + Could not find data query XML file at '.../resource/script_queries/socket_states.xml' + Error parsing XML file into an array. + Could not find data query X...
by johnrembo
Mon Mar 01, 2010 6:17 am
Forum: Scripts and Templates
Topic: port status templates with automated port discovery v00.01
Replies: 6
Views: 4197

Re: z

unnamed wrote:hmmmm I'm sorry but where is socket_states.xml .. :(
look above :)

you must download uncompressed .xml file + compressed .php file (.zip or .gzip)
by johnrembo
Fri Feb 26, 2010 11:48 am
Forum: Scripts and Templates
Topic: port status templates with automated port discovery v00.01
Replies: 6
Views: 4197

port status templates with automated port discovery v00.01

Hello community, I did not found any set of scripts/templates to check port(-s) status of a specific device, so had to make my own. Yes, I know - manage plug-in has this feature, but I've also needed a port scanner in addition. A data-query uses nmap to scan host and detect services running http://i...
by johnrembo
Mon Oct 26, 2009 2:28 pm
Forum: Plugin Announcements
Topic: Transporter, now at v0.2
Replies: 36
Views: 37735

Re: pb with plugins "Transporter"

hello, so, I have an ERROR with 'Transporter' ; 10/26/2009 03:40:03 PM - TRANSPORTER: Poller[0] TRANSPORTER: 1 of 1 record(s) processed 10/26/2009 03:40:03 PM - TRANSPORTER: Poller[0] TRANSPORTER: wrong or no data ???? An idea !!! excuse me for my english. Thank you for your help. My config is : Ca...
by johnrembo
Mon Aug 03, 2009 3:53 am
Forum: Plugin Development
Topic: out there and back ( lcoal_data_id <-> local_graph_id)
Replies: 7
Views: 21937

source from zond_init.php ( http://forums.cacti.net/viewtopic.php?t=24934 ) //extracts all local_data_ids associated with current local_graph_id //COMMENTS - > COMMENT#1 $l_d_i=db_fetch_assoc('select data_template_rrd.id as id, data_template_rrd.local_data_id, data_template_rrd.data_source_type_id, ...
by johnrembo
Fri Jul 31, 2009 9:48 am
Forum: Plugin General
Topic: (topic closed) ZOND plugin v0.32 released (beta)
Replies: 194
Views: 93126

both of these plugins are independent. ZOND has no advantages if compared to "realtime". Moreover - it has issues that can't be solved at cacti-side. I'm not supporting ZOND plugin for over the year now. Community uses "realtime" - so should you. All quesitons reg. "realtime" should not be addressed...
by johnrembo
Fri Jul 31, 2009 2:59 am
Forum: Plugin General
Topic: (topic closed) ZOND plugin v0.32 released (beta)
Replies: 194
Views: 93126

by johnrembo
Mon Dec 22, 2008 3:09 am
Forum: Plugin General
Topic: zond plug-in v0.34c released
Replies: 123
Views: 167215

Yes u right, the values are taken in different time spaces. But, if you look at the values, they are completely different. One of them has Mega other one have not. As you know, the difference between two delta time must not be like that. you should take a look at my last post (image) on page-2. Whe...
by johnrembo
Mon Dec 22, 2008 2:52 am
Forum: Plugin General
Topic: zond plug-in v0.34c released
Replies: 123
Views: 167215

TFC, i remember we allreade had similar discussion on page-6 of this topic. I was investigating this problem intensively and have come to a conclusion there are external processes that sometimes randomly terminate zonds "sleep()" function - this is not a bug, but normal unix sleep() behaviour. Becau...
by johnrembo
Wed Dec 03, 2008 9:07 am
Forum: Plugin General
Topic: zond plug-in v0.34c released
Replies: 123
Views: 167215

yes all boxes are checked. I have tryed both ways enabled for every user and on a per user basis. hmm...any other plugins using same auth_realm as zond does? first, you could try disabling all plugins except zond and see if it helps. second, you could try changing zond's auth realm to any other num...