Search found 14 matches

by mmandrino
Thu Jul 11, 2019 7:58 am
Forum: Help: General
Topic: Cacti SNMP and old telewell Firewall
Replies: 2
Views: 576

Re: Cacti SNMP and old telewell Firewall

When I was trying to get data from old SNMP enabled devices, finding OID description was always very helpful.
by mmandrino
Tue Jul 09, 2019 4:10 am
Forum: Help: General
Topic: NaN from Generic SNMP template
Replies: 5
Views: 613

Re: NaN from Generic SNMP template

[quote="camerabob"]From the device management window, click the yellow arrow indicated below and let us know the results. Here is the result: Total: 0.000000, Delta: 0.000000, Running Data Query [4]. Total: 0.000000, Delta: 0.000000, Found Type = '3' [SNMP Query]. Total: 0.000000, Delta: 0.000000, F...
by mmandrino
Mon Jul 08, 2019 6:30 am
Forum: Help: General
Topic: NaN from Generic SNMP template
Replies: 5
Views: 613

Re: NaN from Generic SNMP template

From the device management window, click the yellow arrow indicated below and let us know the results. Thank you for your reply. Now that you explain it, I notice that Associated Data Queries is SNMP - Interface Statistics, but I am not trying to get Interfece stats. I was using Generic SNMP Device...
by mmandrino
Fri Jul 05, 2019 7:35 am
Forum: Help: General
Topic: NaN from Generic SNMP template
Replies: 5
Views: 613

Re: NaN from Generic SNMP template

When you run a debug/verbose query, what do you see? I am sorry to say but I am not sure I understand what do you mean. When I run Data Source Troubleshooter I get all green except last one: Issues: Data Source returned Bad Results for snmp_oid in the log file (with log level set to DEBUG) i can se...
by mmandrino
Wed Jun 26, 2019 6:50 am
Forum: Help: General
Topic: NaN from Generic SNMP template
Replies: 5
Views: 613

NaN from Generic SNMP template

Hello, I am trying to graph temperature from SNMP enabled monitoring device - NewMar SPM200 I got the correct OID from doc, and when I run snmpwalk I get the result: snmpwalk -v2c -c XXXX NNNN 1.3.6.1.4.1.44686.1.3.1 SNMPv2-SMI::enterprises.44686.1.3.1.0 = INTEGER: 19 I used SNMP - Generic OID templ...
by mmandrino
Fri Jun 14, 2019 8:31 am
Forum: Help: General
Topic: Graph error
Replies: 7
Views: 517

Re: Graph error

Hello,

Try to leave out username in crontab. It helped me on CentOS 7

Also check your firewall fore rate limit and SElinux settings
by mmandrino
Fri Jun 07, 2019 8:32 am
Forum: Help: General
Topic: Reset cacti password
Replies: 2
Views: 396

Re: Reset cacti password

Hello, Try to search the forum. This is a well know issue If you have mysql user and pass you can login and change it via SQL command like: mysql -u root -p once you have Welcome to the MariaDB monitor. Commands end with ; or \g. Your MariaDB connection id is 6419 Server version: 5.5.60-MariaDB Mari...
by mmandrino
Mon Jun 04, 2018 7:27 am
Forum: Help: General
Topic: Graph problem Cacti 1.1.38
Replies: 9
Views: 1555

Re: Graph problem Cacti 1.1.38

I had an issue like that.

My problem was in crontab. I used php /usr/share/cacti/poller.php but i needed /usr/bin/php .....

What is the status of your Main Pooler ? (Console>Data Collectors) - it must be IDLE when all ok - not red (Unknown / down)

Hope this helps
by mmandrino
Fri Jun 01, 2018 5:29 am
Forum: Help: Linux/Unix Specific
Topic: Spine 1.1.37 configure error
Replies: 15
Views: 4036

Re: Spine 1.1.37 configure error

!!SOLVED!! Thank you very much netniV I added some devel packages I found installed on a working cacti server: libdb-devel.x86 httpd-devel net-snmp-devel openssl-devel perl-devel rpm-devel and it works, at least i get past the first problem - then the error was: Cannot find MySQL headers. To solve t...
by mmandrino
Tue May 29, 2018 8:05 am
Forum: Help: Linux/Unix Specific
Topic: Spine 1.1.37 configure error
Replies: 15
Views: 4036

Spine 1.1.37 configure error

!!! WRONG FORUM - sorry, please move to Linux help!! Hello I tried to install new version -1.1.37 on new server, but after cacti install is complete cannot install spine. OS: Centos 7.4.1708 - 3.10.0-862.2.3.el7.x86_64 Apache: 2.4.6 Cacti & Spine - 1.1.37 PHP: 5.4.16 when i run ./configure i get err...
by mmandrino
Fri Feb 09, 2018 4:33 am
Forum: Help: Linux/Unix Specific
Topic: Cacti and remote poller
Replies: 0
Views: 529

Cacti and remote poller

Hello, I installed new version of Cacti recently and wanted to make setup with 2 -3 remote pollers. At moment of install it was Version 1.1.28 OS is Centos7 I installed master of cacti OK, no problems, and got it working. I cloned VM, flushed entire DB, and started the wizard to set remote pooler. W...
by mmandrino
Sun Sep 24, 2017 4:47 am
Forum: Help: General
Topic: Solved: Main pooler down
Replies: 0
Views: 856

Solved: Main pooler down

Hi, I have a same problem for over 2 weeks now. My main, and only, poller shows status as: Unknown/Down. Last run is a week ago when i tried to run in manually and it worked. I think my cron is OK: */5 * * * * cacti /usr/bin/php /usr/share/cacti/poller.php > /dev/null 2>&1 Trying to run in manually ...
by mmandrino
Sun Sep 24, 2017 3:57 am
Forum: Help: General
Topic: Where are the data queries
Replies: 1
Views: 222

Re: Where are the data queries

Hi,

I had a same issue - no even basic data query.

So i exported one form my old cacti install - SNMP - Interface statistics.

I was able to create graph - but I get no data in it - guess its another issue.

There are also other templates to find on forum and support sites.
by mmandrino
Mon Jun 22, 2015 3:38 am
Forum: Scripts and Templates
Topic: adding hosts and graphs, and updating via cli
Replies: 1
Views: 975

adding hosts and graphs, and updating via cli

Hello, I have been trying for a week to make this work, with no luck I successfully used add_device and add_graphs, in a custom made php script that adds new devices to cacti from our DB. Then I ran in to problems when a host data in our DB changes (we move device to another location and it gets a n...