[Solved] Problems upgrading from 1.1.38 (Windows)

Beta testing discussion area

Moderators: Moderators, Developers

Post Reply
Author
Message
Beast
Cacti User
Posts: 65
Joined: Tue Feb 07, 2017 1:55 pm
Location: Venezuela

[Solved] Problems upgrading from 1.1.38 (Windows)

#1 Post by Beast » Thu Oct 18, 2018 7:35 am

Hi to all, i just try to upgrade my cacti test server from version 1.1.38 but i get blank page just after the login with the /install/install.php script and it get stuck there, i use the same procedure for upgrade than previous versions but don't now if there is some aditional steps for this version.
Last edited by Beast on Fri May 31, 2019 8:16 am, edited 2 times in total.
Beast
GitHub: DoubleBeast

netniV
Cacti Guru User
Posts: 2686
Joined: Sun Aug 27, 2017 12:05 am

Re: Problems upgrading from 1.1.38 (Windows)

#2 Post by netniV » Thu Oct 18, 2018 9:41 am

We have not fully tested an update/install on Windows yet. This is in the works.

In the meantime, can you post a screenshot of how it's stuck? Also, check your apache or IIS log files for any errors

Beast
Cacti User
Posts: 65
Joined: Tue Feb 07, 2017 1:55 pm
Location: Venezuela

Re: Problems upgrading from 1.1.38 (Windows)

#3 Post by Beast » Thu Oct 18, 2018 10:40 am

thanks for the replay, i made a step by step verification of my update process and now i can access to the setup but get stuck in the section that is shown in the images attached, when i hit next it just reload the same page.

By the way i select english language in the instalation setup but aparently the language selection of the previous version took over :)

if there is a log that help you with any of this just let me know.
Attachments
cacti2.png
after correction of file path (hit next and it simply reload de page)
cacti2.png (160.39 KiB) Viewed 331 times
cacti1.png
before correction of file path
cacti1.png (165.72 KiB) Viewed 331 times
Beast
GitHub: DoubleBeast

netniV
Cacti Guru User
Posts: 2686
Joined: Sun Aug 27, 2017 12:05 am

Re: Problems upgrading from 1.1.38 (Windows)

#4 Post by netniV » Thu Oct 18, 2018 7:10 pm

In your database, insert a row in settings with name of 'log_install' and value of '3'. This will generate files in your log/ folder call install-*. If you can send those to me at [email protected] and we will see if I can spot anything.

User avatar
Pucho
Cacti User
Posts: 180
Joined: Wed Jul 20, 2016 8:00 pm

Re: Problems upgrading from 1.1.38 (Windows)

#5 Post by Pucho » Thu Oct 18, 2018 7:13 pm

What happens if you populate sendmail path again? It looks like it doesn't exist when the installer checks for it and removes the path. Does that make any sense?


Btw, those screenshots just reminded me that I've never pushed the new Spanish translation. Hopefully next week.
Cacti - 1.1.37
Poller Type - Spine
Weathermap 0.98a
Server Info - Linux 3.10.0 - Centos 7
Web Server - Apache/2.4.6 PHP 5.4.16
MySQL - 5.5 ;RRDTool - 1.4.8 ;SNMP - 5.7.2
Religion - Anti forum pets

Code: Select all

SYSTEM STATS: Time:17.7383 Method:spine Processes:1 Threads:10 Hosts:279 HostsPerProcess:279 DataSources:7309 RRDsProcessed:3718

Code: Select all

WEATHERMAP STATS: Weathermap 0.98 run complete - Thu, 16 Nov 17 08:42:56 +1300: 39 maps were run in 23.22 seconds with 0 warnings.

netniV
Cacti Guru User
Posts: 2686
Joined: Sun Aug 27, 2017 12:05 am

Re: Problems upgrading from 1.1.38 (Windows)

#6 Post by netniV » Fri Oct 19, 2018 4:11 am

I have also just remembered that the latest development code removes SendMail from Windows configuration as it's not used. Beta 1 still has that in but Beta 2 won't.

Beast
Cacti User
Posts: 65
Joined: Tue Feb 07, 2017 1:55 pm
Location: Venezuela

Re: Problems upgrading from 1.1.38 (Windows)

#7 Post by Beast » Fri Oct 19, 2018 7:49 am

netniV wrote:In your database, insert a row in settings with name of 'log_install' and value of '3'. This will generate files in your log/ folder call install-*. If you can send those to me at [email protected] and we will see if I can spot anything.
i just send you the info.
Beast
GitHub: DoubleBeast

Beast
Cacti User
Posts: 65
Joined: Tue Feb 07, 2017 1:55 pm
Location: Venezuela

Re: Problems upgrading from 1.1.38 (Windows)

#8 Post by Beast » Fri Oct 19, 2018 8:01 am

Pucho wrote:What happens if you populate sendmail path again? It looks like it doesn't exist when the installer checks for it and removes the path. Does that make any sense?


Btw, those screenshots just reminded me that I've never pushed the new Spanish translation. Hopefully next week.

every time i send the path corrected (green check) the page just reload and the log file shows "[2018-10-19 08:31:24] [ info ] addError(Paths, settings_sendmail_path, File not found)"

i even check the path directly in the database before running the install and the path is present and valid as can be seen on the image, so i think it could be an script problem or maybe is related with the last comment of @NetNiv and the future elimination of that funtion for windows.

PD: if you need some backups for the spanish translation just let me know :D
Attachments
cacti3.png
sendmail path present ansd valid in the database before the install
cacti3.png (222.8 KiB) Viewed 310 times
Beast
GitHub: DoubleBeast

netniV
Cacti Guru User
Posts: 2686
Joined: Sun Aug 27, 2017 12:05 am

Re: Problems upgrading from 1.1.38 (Windows)

#9 Post by netniV » Fri Oct 19, 2018 8:51 am

Down the latest develop code and see how you fair with that.

Beast
Cacti User
Posts: 65
Joined: Tue Feb 07, 2017 1:55 pm
Location: Venezuela

Re: Problems upgrading from 1.1.38 (Windows)

#10 Post by Beast » Fri Oct 19, 2018 4:09 pm

i installed the dev version from github and it works just fine (bypass sendmail verification), excellent work with the new install interface guys, as far as i can tell everything works great with the new version (except email but that is an old figth that i have with php mailer :x )

Case closed for me, thanks for the support.
Beast
GitHub: DoubleBeast

Post Reply