Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Thu Apr 25, 2019 7:11 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Error on automation: creation of a new tree rule
PostPosted: Thu Nov 01, 2018 2:06 am 
Offline
Cacti User

Joined: Wed Dec 07, 2011 9:19 am
Posts: 322
When I try to create a new tree rule, as soon as I change the leaf item type to equipment, i got an error, and I can't create my tree rule


Change Leaf Type

WARNING:You are changing the leaf type to "Device" which does not support Graph-based object matching/creation.By changing the leaf type, all invalid rules will be automatically removed and will not be recoverable.

Are you sure you wish to continue?

_________________
CentOS
Production
Cacti 0.8.8h
Spine 0.8.8h
PIA 3.1
Aggregate 0.75
Monitor 1.3
Settings 0.71
Weathermap 0.98
Thold 0.5
rrdclean 0.41

Own plugin: LinkDiscovery 0.3, Map 0.4

Test
Cacti 1.2.1
Spine 1.2.1
thold 1.0.6
monitor 2.3.5
php 7.2.11
mariadb 5.5.56
Own plugin:
ExtendDB 1.1.2
LinkDiscovery 1.2.4
Map 1.2.5


Top
 Profile  
 
 Post subject: Re: Error on automation: creation of a new tree rule
PostPosted: Thu Nov 01, 2018 4:10 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2414
Did you click continue? The reason for the message is that there are two types of rules and when you switch, it causes errors if those erroneous items are not removed. However, you may not wish those items to be removed and may have accidentally switched types without realising... so I introduced the dialog to cover both scenario's.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Error on automation: creation of a new tree rule
PostPosted: Thu Nov 01, 2018 4:16 am 
Offline
Cacti User

Joined: Wed Dec 07, 2011 9:19 am
Posts: 322
Yes I did
but then name is cleared and setting is set back as new (no name, default tree and graphics)

To resolve this issue, I have to set a name, save it, then re-open it and change the setting after that

_________________
CentOS
Production
Cacti 0.8.8h
Spine 0.8.8h
PIA 3.1
Aggregate 0.75
Monitor 1.3
Settings 0.71
Weathermap 0.98
Thold 0.5
rrdclean 0.41

Own plugin: LinkDiscovery 0.3, Map 0.4

Test
Cacti 1.2.1
Spine 1.2.1
thold 1.0.6
monitor 2.3.5
php 7.2.11
mariadb 5.5.56
Own plugin:
ExtendDB 1.1.2
LinkDiscovery 1.2.4
Map 1.2.5


Top
 Profile  
 
 Post subject: Re: Error on automation: creation of a new tree rule
PostPosted: Thu Nov 01, 2018 4:44 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2414
Oh, so this is with a new blank rule, change the option, it doesn't keep the settings? If so, I would open that as a new issue since I doubt it's been resolved.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group